Loading ...
Sorry, an error occurred while loading the content.
 

Re: Compiling libtorrent in QNAP 509 Pro

Expand Messages
  • Brian
    Just when I found out his problem, captainaatif disappeared from the group with all his messages. I was not able to replicate his problem first.
    Message 1 of 5 , Mar 8, 2010
      Just when I found out his problem, "captainaatif" <aatif@> disappeared from the group with all his messages.

      I was not able to replicate his problem first. Then I intentionally renamed /opt/bin/sed to /opt/bin/sed.bak, and got exactly same error message. So if he or anyone else see this, make sure to use /opt/bin/sed which should link to /opt/bin/gnu-sed.

      -Brian

      --- In nslu2-linux@yahoogroups.com, "Brian" <b88zhou@...> wrote:
      >
      > Try put /opt/bin at the front of your PATH, at least for the compiling session. I suspect busybox /bin/awk is getting in the way.
      >
      > To be able to compile libsigc++, you might want to "mv /opt/lib/libstdc++.la{,.bak}" as root (admin on QNAP).
      >
      > -Brian
      >
      > --- In nslu2-linux@yahoogroups.com, "captainaatif" <aatif@> wrote:
      > >
      > > Now I get this:
      > >
      > > ......contd.
      > > lling operator() template methods.... yes
      > > checking if C++ compiler supports the use of a particular specialization when ca lling operator() template methods omitting the template keyword.... yes
      > > checking if C++ compiler allows usage of member function in initialization of st atic member field.... yes
      > > checking whether C++ library symbols are declared in namespace std... yes
      > > checking for non-standard Sun libCstd reverse_iterator... no
      > > configure: creating ./config.status
      > > config.status: creating Makefile
      > > gawk: ./conf46N9qk/subs.awk:3: S["/; s/!.*/"]=SHELL!/bin/sh%!_!# "/bin/sh"
      > > gawk: ./conf46N9qk/subs.awk:3: ^ syntax error
      > > gawk: ./conf46N9qk/subs.awk:3: S["/; s/!.*/"]=PATH_SEPARATOR!:%!_!# ":"
      > > gawk: ./conf46N9qk/subs.awk:3: ^ syntax error
      > > gawk: ./conf46N9qk/subs.awk:4: S["/; s/!.*/"]=PATH_SEPARATOR!:%!_!# ":"
      > > gawk: ./conf46N9qk/subs.awk:4: ^ syntax error
      > > gawk: ./conf46N9qk/subs.awk:5: S["/; s/!.*/"]=PACKAGE_NAME!libsigc++%!_!# "libsi gc++"
      > > gawk: ./conf46N9qk/subs.awk:5: ^ syntax error
      > > gawk: ./conf46N9qk/subs.awk:6: S["/; s/!.*/"]=PACKAGE_TARNAME!libsigc++%!_!# "li bsigc++"
      > > gawk: ./conf46N9qk/subs.awk:6: ^ syn tax error
      > > gawk: ./conf46N9qk/subs.awk:7: S["/; s/!.*/"]=PACKAGE_VERSION!2.2.3%!_!# "2.2.3"
      > > gawk: ./conf46N9qk/subs.awk:7: ^ syntax error
      > > gawk: ./conf46N9qk/subs.awk:8: S["/; s/!.*/"]=PACKAGE_STRING!libsigc++ 2.2.3%!_! # "libsigc++ 2.2.3"
      > > gawk: ./conf46N9qk/subs.awk:8: ^ syntax error
      > > gawk: ./conf46N9qk/subs.awk:8: S["/; s/!.*/"]=PACKAGE_BUGREPORT!libsigc-list@gno me.org%!_!# "libsigc-list@"
      > > gawk: ./conf46N9qk/subs.awk:8: ^ in valid char '@' in expression
      > > config.status: error: could not create Makefile
      > > make[1]: *** [/share/MD0_DATA/aatif/optware/ts509/builds/libsigc++/.configured] Error 1
      > > make[1]: Leaving directory `/share/MD0_DATA/aatif/optware/ts509'
      > > make: *** [/share/MD0_DATA/aatif/optware/ts509/builds/libtorrent/.configured] Er ror 2
      > >
      > >
      > >
      > >
      > >
      > > --- In nslu2-linux@yahoogroups.com, Robert Hammond <robham@> wrote:
      > > >
      > > > In message <hjl0sm+tgq0@>, captainaatif <aatif@>
      > > > writes
      > > > > 
      > > > >
      > > > >Thanks for the reply.
      > > > >
      > > > >Installed optware-devel just fine, but ..
      > > > >
      > > > >[~] # svn co https://svn.nslu2-linux.org/svnroot/optware/trunk optware
      > > > >Authentication realm: https://svn.nslu2-linux.org:443
      > > > >Client certificate filename:
      > > > >
      > > > >and after 3 tries ...
      > > > >
      > > > >Client certificate filename:
      > > > >svn: OPTIONS of 'https://svn.nslu2-linux.org/svnroot/optware/trunk': SSL
      > > > >handshake failed, client certificate was requested: SSL error: sslv3 alert
      > > > >handshake failure (https://svn.nslu2-linux.org)
      > > > >any help?
      > > > >
      > > >
      > > > Change the https above to http
      > > >
      > > > https is only needed if you want to upload anything to the svn, i.e have
      > > > developer access. You can down load the complete svn using just http
      > > > --
      > > > Robert Hammond
      > > > PGP:0x154144DA
      > > > 592B 0199 2D7F FC05 C4B1 0404 2258 4471 1541 44DA
      > > >
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.