Loading ...
Sorry, an error occurred while loading the content.
 

ssh not running- help?

Expand Messages
  • Matt Tancock
    Hi, running slugOS on an nslu2 (5.3 I think) off a flash drive, with a hd on the other usb port. It s been running fine for about 3 months, just running an
    Message 1 of 6 , Jan 19, 2010
      Hi, running slugOS on an nslu2 (5.3 I think) off a flash drive, with a hd on the other usb port.

      It's been running fine for about 3 months, just running an mt-daapd server.

      I've been trying to work out how to stream video to my xbox360, so went to login to the slug, but am getting connection refused via ssh.

      I've rebooted about 5 or 6 times, and I'm still getting connection refused. Don't understand why.

      Mt-daapd is fine, and every time I reboot, that comes back up again and is streaming as we speak.

      Any ideas how I can get back into my box? I took me soooo long to get it working the first time, if I have to start again and re-flash it again I suspect my wife may throw it out when I'm not here!!

      Thanks,

      Matt
    • Ian Barton
      ... Ty running ssh -v yourslug.com. This will pint out debug info, which should give you a clue as to why the connection is being refused. Ian.
      Message 2 of 6 , Jan 21, 2010
        > I've rebooted about 5 or 6 times, and I'm still getting connection
        > refused. Don't understand why.
        >
        > Mt-daapd is fine, and every time I reboot, that comes back up again and
        > is streaming as we speak.
        >
        > Any ideas how I can get back into my box? I took me soooo long to get it
        > working the first time, if I have to start again and re-flash it again I
        > suspect my wife may throw it out when I'm not here!!
        >
        Ty running ssh -v yourslug.com. This will pint out debug info, which
        should give you a clue as to why the connection is being refused.

        Ian.
      • Matt Tancock
        Okay, done that... OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009 debug1: Reading configuration data /etc/ssh_config debug1: Connecting to 192.168.1.5 [192.168.1.5]
        Message 3 of 6 , Jan 21, 2010
          Okay, done that...

          OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009
          debug1: Reading configuration data /etc/ssh_config
          debug1: Connecting to 192.168.1.5 [192.168.1.5] port 22.
          debug1: connect to address 192.168.1.5 port 22: Connection refused
          ssh: connect to host 192.168.1.5 port 22: Connection refused

          That's it... is this any help? (It's not to me...)

          Matt


          On Thu, Jan 21, 2010 at 11:16 AM, Ian Barton <lists@...> wrote:
           

          > I've rebooted about 5 or 6 times, and I'm still getting connection
          > refused. Don't understand why.
          >
          > Mt-daapd is fine, and every time I reboot, that comes back up again and
          > is streaming as we speak.
          >
          > Any ideas how I can get back into my box? I took me soooo long to get it
          > working the first time, if I have to start again and re-flash it again I
          > suspect my wife may throw it out when I'm not here!!
          >
          Ty running ssh -v yourslug.com. This will pint out debug info, which
          should give you a clue as to why the connection is being refused.

          Ian.

        • Carl Steinhilber
          Are you able to telnet in? If so, is the ssh service running? And, if so, is the IP of the slug still 192.168.1.5? ________________________________ From: Matt
          Message 4 of 6 , Jan 21, 2010
            Are you able to telnet in?
            If so, is the ssh service running?
            And, if so, is the IP of the slug still 192.168.1.5?



            From: Matt Tancock <matttancock@...>
            To: nslu2-linux@yahoogroups.com
            Sent: Thu, January 21, 2010 8:34:48 AM
            Subject: Re: [nslu2-linux] ssh not running- help?

             

            Okay, done that...

            OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009
            debug1: Reading configuration data /etc/ssh_config
            debug1: Connecting to 192.168.1.5 [192.168.1.5] port 22.
            debug1: connect to address 192.168.1.5 port 22: Connection refused
            ssh: connect to host 192.168.1.5 port 22: Connection refused

            That's it... is this any help? (It's not to me...)

            Matt


            On Thu, Jan 21, 2010 at 11:16 AM, Ian Barton <lists@manor- farm.org> wrote:
             

            > I've rebooted about 5 or 6 times, and I'm still getting connection
            > refused. Don't understand why.
            >
            > Mt-daapd is fine, and every time I reboot, that comes back up again and
            > is streaming as we speak.
            >
            > Any ideas how I can get back into my box? I took me soooo long to get it
            > working the first time, if I have to start again and re-flash it again I
            > suspect my wife may throw it out when I'm not here!!
            >
            Ty running ssh -v yourslug.com. This will pint out debug info, which
            should give you a clue as to why the connection is being refused.

            Ian.


          • Ian Barton
            It sounds as though the ssh server isn t listening. You should see something like: ian@blacky:~$ ssh -v firewall.bantercat.co.uk OpenSSH_5.1p1 Debian-6ubuntu2,
            Message 5 of 6 , Jan 21, 2010
              It sounds as though the ssh server isn't listening. You should see
              something like:

              ian@blacky:~$ ssh -v firewall.bantercat.co.uk
              OpenSSH_5.1p1 Debian-6ubuntu2, OpenSSL 0.9.8g 19 Oct 2007
              debug1: Reading configuration data /home/ian/.ssh/config
              debug1: Reading configuration data /etc/ssh/ssh_config
              debug1: Applying options for *
              debug1: Connecting to firewall.bantercat.co.uk [192.168.0.30] port 22.
              debug1: Connection established.
              debug1: identity file /home/ian/.ssh/identity type -1
              debug1: identity file /home/ian/.ssh/id_rsa type 1
              debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048

              Are you sure it's running on port 22? Try putting ther flash drive into
              another computer and see if there is anything in auth.log which might
              give a clue.

              Ian.

              > Okay, done that...
              >
              > OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009
              > debug1: Reading configuration data /etc/ssh_config
              > debug1: Connecting to 192.168.1.5 [192.168.1.5] port 22.
              > debug1: connect to address 192.168.1.5 port 22: Connection refused
              > ssh: connect to host 192.168.1.5 port 22: Connection refused
              >
              > That's it... is this any help? (It's not to me...)
              >
              > Matt
              >
              >
              > On Thu, Jan 21, 2010 at 11:16 AM, Ian Barton <lists@...
              > <mailto:lists@...>> wrote:
              >
              >
              >
              > > I've rebooted about 5 or 6 times, and I'm still getting connection
              > > refused. Don't understand why.
              > >
              > > Mt-daapd is fine, and every time I reboot, that comes back up
              > again and
              > > is streaming as we speak.
              > >
              > > Any ideas how I can get back into my box? I took me soooo long to
              > get it
              > > working the first time, if I have to start again and re-flash it
              > again I
              > > suspect my wife may throw it out when I'm not here!!
              > >
              > Ty running ssh -v yourslug.com <http://yourslug.com>. This will pint
              > out debug info, which
              > should give you a clue as to why the connection is being refused.
              >
            • Matt Tancock
              I ve had a look at the drive (booted slug without it, ssh in, then mounted drive) and there s no auth.log... It s definitely on the default port - I can view
              Message 6 of 6 , Jan 22, 2010
                I've had a look at the drive (booted slug without it, ssh in, then mounted drive) and there's no auth.log...

                It's definitely on the default port - I can view my terminal command history going back about 4 months (to when I compiled upslug when I was setting up slugOS) and I've never specified a different port.

                I've not installed telnet, and am assuming by it refusing my connections that it's not installed by default... I'm thinking this isn't looking good :/

                Matt


                On Thu, Jan 21, 2010 at 7:23 PM, Ian Barton <lists@...> wrote:
                It sounds as though the ssh server isn't listening. You should see
                something like:

                ian@blacky:~$ ssh -v firewall.bantercat.co.uk
                OpenSSH_5.1p1 Debian-6ubuntu2, OpenSSL 0.9.8g 19 Oct 2007
                debug1: Reading configuration data /home/ian/.ssh/config
                debug1: Reading configuration data /etc/ssh/ssh_config
                debug1: Applying options for *
                debug1: Connecting to firewall.bantercat.co.uk [192.168.0.30] port 22.
                debug1: Connection established.
                debug1: identity file /home/ian/.ssh/identity type -1
                debug1: identity file /home/ian/.ssh/id_rsa type 1
                debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048

                Are you sure it's running on port 22? Try putting ther flash drive into
                another computer and see if there is anything in auth.log which might
                give a clue.

                Ian.

                > Okay, done that...
                >
                > OpenSSH_5.2p1, OpenSSL 0.9.8k 25 Mar 2009
                > debug1: Reading configuration data /etc/ssh_config
                > debug1: Connecting to 192.168.1.5 [192.168.1.5] port 22.
                > debug1: connect to address 192.168.1.5 port 22: Connection refused
                > ssh: connect to host 192.168.1.5 port 22: Connection refused
                >
                > That's it... is this any help? (It's not to me...)
                >
                > Matt
                >
                >
                > On Thu, Jan 21, 2010 at 11:16 AM, Ian Barton <lists@...
                > <mailto:lists@...>> wrote:
                >
                >
                >
                >      > I've rebooted about 5 or 6 times, and I'm still getting connection
                >      > refused. Don't understand why.
                >      >
                >      > Mt-daapd is fine, and every time I reboot, that comes back up
                >     again and
                >      > is streaming as we speak.
                >      >
                >      > Any ideas how I can get back into my box? I took me soooo long to
                >     get it
                >      > working the first time, if I have to start again and re-flash it
                >     again I
                >      > suspect my wife may throw it out when I'm not here!!
                >      >
                >     Ty running ssh -v yourslug.com <http://yourslug.com>. This will pint
                >     out debug info, which
                >     should give you a clue as to why the connection is being refused.
                >



                ------------------------------------

                Yahoo! Groups Links

                <*> To visit your group on the web, go to:
                   http://groups.yahoo.com/group/nslu2-linux/

                <*> Your email settings:
                   Individual Email | Traditional

                <*> To change settings online go to:
                   http://groups.yahoo.com/group/nslu2-linux/join
                   (Yahoo! ID required)

                <*> To change settings via email:
                   nslu2-linux-digest@yahoogroups.com
                   nslu2-linux-fullfeatured@yahoogroups.com

                <*> To unsubscribe from this group, send an email to:
                   nslu2-linux-unsubscribe@yahoogroups.com

                <*> Your use of Yahoo! Groups is subject to:
                   http://docs.yahoo.com/info/terms/


              Your message has been successfully submitted and would be delivered to recipients shortly.