Loading ...
Sorry, an error occurred while loading the content.

Re: Compiling libtorrent in QNAP 509 Pro

Expand Messages
  • Brian
    If you use optware as development environment, you don t need -dev packages. Try: ipkg install optware-devel svn co
    Message 1 of 5 , Jan 21, 2010
    • 0 Attachment
      If you use optware as development environment, you don't need -dev packages. Try:

      ipkg install optware-devel
      svn co https://svn.nslu2-linux.org/svnroot/optware/trunk optware
      cd optware; make ts509-target
      cd ts509; make directories toolchain ipkg-utils

      make libtorrent-ipk

      -Brian

      --- In nslu2-linux@yahoogroups.com, "captainaatif" <aatif@...> wrote:
      >
      > Anyone who can help me out please???
      >
      > Is it possible for someone to create ipkg of libsigc++ dev package?
      >
      >
      >
      > --- In nslu2-linux@yahoogroups.com, "captainaatif" <aatif@> wrote:
      > >
      > > Hello
      > >
      > > I am a n00b with linux and just trying to have some understanding of how
      > > things work. Now, I know rTorrent is compiled and already available
      > > here, but I wanted to try compiling it myself.
      > >
      > > Now here's the approach I took with IPKG
      > >
      > > 1) ipkg update
      > > 2) ipkg install gcc
      > > 3) ipkg install pkgconfig
      > > 4) ipkg install openssl-dev5) ipkg install libsigc++
      > > 6) I used this code for libsigc++.pc in pkgconfig folder to fix an error
      > > that sigc++2.0.pc was missing
      > >
      > > prefix=/opt
      > > exec_prefix=${prefix}
      > > libdir=${exec_prefix}/lib
      > > includedir=${prefix}/include
      > >
      > > Name: libsigc++ 2
      > > Description: Typesafe signal and callback system for C++
      > > Version: 2.2.2
      > > Requires:
      > > Libs: -L${libdir} -lsigc-2.0
      > > Cflags: -I${includedir}
      > >
      > > Here's my IPKG list_installed command:
      > > [~/libtorrent-0.11.5/libtorrent-0.11.5] # ipkg list_installed
      > > binutils - 2.17-2 - The GNU assembler and linker and related tools
      > > gcc - 4.2.1-5 - The GNU Compiler Collection.
      > > grep - 2.5.3-1 - Global regular expression parser
      > > libc-dev - 2.6.1-5 - libc development files.
      > > libcurl - 7.19.7-1 - Curl is a command line tool for transferring files
      > > with URL syntax, supporting FTP, FTPS, HTTP, HTTPS, GOPHER, TELNET,
      > > DICT, FI
      > > libnsl - 2.6.1-4 - Network Services Library
      > > libsigc++ - 2.2.3-1 - libsigc++ implements a typesafe callback system
      > > for standard C++.
      > > libstdc++ - 6.0.9-6 - Standard C++ library, needed for dynamically
      > > linked C++ programs
      > > libtorrent - 0.12.5-2 -
      > > libxml2 - 2.7.6-1 - Libxml2 is the XML C parser and toolkit developed
      > > for the Gnome project.
      > > ncurses - 5.7-1 - NCurses libraries
      > > ncursesw - 5.7-1 - NCurses libraries with wide char support.
      > > openssl - 0.9.8l-1 - Openssl provides the ssl implementation in
      > > libraries libcrypto and libssl, and is needed by many other applications
      > > and librari
      > > pcre - 8.00-1 - Perl-compatible regular expression library
      > > pkgconfig - 0.15.0-1 - Package configuration tool
      > > rtorrent - 0.8.5-1 -
      > > screen - 4.0.3-2 - A screen manager that supports multiple logins on
      > > single terminal
      > > termcap - 1.3.1-2 - Terminal emulation library
      > > unrar - 3.9.6-1 - unrar is an application that can decompress files and
      > > archives created using the RAR compression scheme
      > > xmlrpc-c - 1.11.00-3 - A library providing modular implementation of
      > > XML-RPC for C and C++.
      > > zlib - 1.2.3-3 - zlib is a library implementing the 'deflate'
      > > compression system.
      > > Successfully terminated.[~/libtorrent-0.11.5/libtorrent-0.11.5] #
      > >
      > >
      > >
      > > Now, I get this error when I configure and make:
      > >
      > >
      > > [~/libtorrent-0.12.6/libtorrent-0.12.6] # ./configure && make
      > > checking for a BSD-compatible install... /usr/bin/install -c
      > > checking whether build environment is sane... yes
      > > checking for a thread-safe mkdir -p... ./install-sh -c -d
      > > checking for gawk... no
      > > checking for mawk... no
      > > checking for nawk... no
      > > checking for awk... awk
      > > checking whether make sets $(MAKE)... no
      > > checking build system type... i686-pc-linux-gnu
      > > checking host system type... i686-pc-linux-gnu
      > > checking for style of include used by make... none
      > > checking for gcc... gcc
      > > checking for C compiler default output file name... a.out
      > > checking whether the C compiler works... yes
      > > checking whether we are cross compiling... no
      > > checking for suffix of executables...
      > > checking for suffix of object files... o
      > > checking whether we are using the GNU C compiler... yes
      > > checking whether gcc accepts -g... yes
      > > checking for gcc option to accept ISO C89... none needed
      > > checking dependency style of gcc... none
      > > checking for a sed that does not truncate output... /bin/sed
      > > checking for grep that handles long lines and -e... /opt/bin/grep
      > > checking for egrep... /opt/bin/grep -E
      > > checking for fgrep... /opt/bin/grep -F
      > > checking for ld used by gcc...
      > > /share/MD0_DATA/.qpkg/Optware/i686-unknown-linux-gnu/bin/ld
      > > checking if the linker
      > > (/share/MD0_DATA/.qpkg/Optware/i686-unknown-linux-gnu/bin/ld) is GNU
      > > ld... yes
      > > checking for BSD- or MS-compatible name lister (nm)... /opt/bin/nm -B
      > > checking the name lister (/opt/bin/nm -B) interface... BSD nm
      > > checking whether ln -s works... yes
      > > checking the maximum length of command line arguments... 32768
      > > checking whether the shell understands some XSI constructs... yes
      > > checking whether the shell understands "+="... yes
      > > checking for /share/MD0_DATA/.qpkg/Optware/i686-unknown-linux-gnu/bin/ld
      > > option to reload object files... -r
      > > checking for objdump... objdump
      > > checking how to recognize dependent libraries... pass_all
      > > checking for ar... ar
      > > checking for strip... strip
      > > checking for ranlib... ranlib
      > > checking command to parse /opt/bin/nm -B output from gcc object... ok
      > > checking how to run the C preprocessor... gcc -E
      > > checking for ANSI C header files... yes
      > > checking for sys/types.h... yes
      > > checking for sys/stat.h... yes
      > > checking for stdlib.h... yes
      > > checking for string.h... yes
      > > checking for memory.h... yes
      > > checking for strings.h... yes
      > > checking for inttypes.h... yes
      > > checking for stdint.h... yes
      > > checking for unistd.h... yes
      > > checking for dlfcn.h... yes
      > > checking for objdir... .libs
      > > checking if gcc supports -fno-rtti -fno-exceptions... ./configure: line
      > > 7610: diff: command not found
      > > no
      > > checking for gcc option to produce PIC... -fPIC -DPIC
      > > checking if gcc PIC flag -fPIC -DPIC works... yes
      > > checking if gcc static flag -static works... no
      > > checking if gcc supports -c -o file.o... yes
      > > checking if gcc supports -c -o file.o... (cached) yes
      > > checking whether the gcc linker
      > > (/share/MD0_DATA/.qpkg/Optware/i686-unknown-linux-gnu/bin/ld) supports
      > > shared libraries... yes
      > > checking whether -lc should be explicitly linked in... no
      > > checking dynamic linker characteristics... GNU/Linux ld.so
      > > checking how to hardcode library paths into programs... immediate
      > > checking whether stripping libraries is possible... yes
      > > checking if libtool supports shared libraries... yes
      > > checking whether to build shared libraries... yes
      > > checking whether to build static libraries... no
      > > checking for g++... g++
      > > checking whether we are using the GNU C++ compiler... yes
      > > checking whether g++ accepts -g... yes
      > > checking dependency style of g++... none
      > > checking whether we are using the GNU C++ compiler... (cached) yes
      > > checking whether g++ accepts -g... (cached) yes
      > > checking dependency style of g++... (cached) none
      > > checking how to run the C++ preprocessor... g++ -E
      > > checking for ld used by g++...
      > > /share/MD0_DATA/.qpkg/Optware/i686-unknown-linux-gnu/bin/ld
      > > checking if the linker
      > > (/share/MD0_DATA/.qpkg/Optware/i686-unknown-linux-gnu/bin/ld) is GNU
      > > ld... yes
      > > checking whether the g++ linker
      > > (/share/MD0_DATA/.qpkg/Optware/i686-unknown-linux-gnu/bin/ld) supports
      > > shared libraries... yes
      > > checking for g++ option to produce PIC... -fPIC -DPIC
      > > checking if g++ PIC flag -fPIC -DPIC works... yes
      > > checking if g++ static flag -static works... no
      > > checking if g++ supports -c -o file.o... yes
      > > checking if g++ supports -c -o file.o... (cached) yes
      > > checking whether the g++ linker
      > > (/share/MD0_DATA/.qpkg/Optware/i686-unknown-linux-gnu/bin/ld) supports
      > > shared libraries... yes
      > > checking dynamic linker characteristics... GNU/Linux ld.so
      > > checking how to hardcode library paths into programs... immediate
      > > checking whether byte ordering is bigendian... no
      > > checking the byte alignment... none needed
      > > checking for user-defined CXXFLAGS... user-defined "-g -O2"
      > > checking for TR1 support... yes
      > > checking for special C compiler options needed for large files... no
      > > checking for _FILE_OFFSET_BITS value needed for large files... 64
      > > checking for epoll support... yes
      > > checking size of long... 4
      > > checking sys/vfs.h usability... yes
      > > checking sys/vfs.h presence... yes
      > > checking for sys/vfs.h... yes
      > > checking sys/statvfs.h usability... yes
      > > checking sys/statvfs.h presence... yes
      > > checking for sys/statvfs.h... yes
      > > checking sys/statfs.h usability... yes
      > > checking sys/statfs.h presence... yes
      > > checking for sys/statfs.h... yes
      > > checking for statvfs... ok
      > > checking if compiler supports __attribute__((visibility("default")))...
      > > yes
      > > checking for pkg-config... /opt/bin/pkg-config
      > > checking pkg-config is at least version 0.9.0... yes
      > > checking for OPENSSL... yes
      > > checking for STUFF... yes
      > > checking for madvise... yes
      > > checking signedness of mincore parameter... unsigned
      > > checking for proper overloaded template function disambiguation... yes
      > > checking if compiler supports __attribute__((unused))... yes
      > > configure: creating ./config.status
      > > config.status: creating libtorrent.pc
      > > awk: ./confUjMY9W/subs.awk:2: Unexpected token
      > > config.status: error: could not create libtorrent.pc
      > > [~/libtorrent-0.12.6/libtorrent-0.12.6] #
      > >
      > >
      > >
      > > Can anyone explain what "awk:2: Unexpected token" means? I tried google,
      > > but no help so far ((
      > > Here are config.status and config.log files in rar format:
      > > http://rapidshare.com/files/329931009/pkgconfig_omdb.rar
      > > <http://rapidshare.com/files/329931009/pkgconfig_omdb.rar>
      > >
      >
    • Robert Hammond
      In message , captainaatif writes ... Change the https above to http https is only needed if you want to upload
      Message 2 of 5 , Jan 25, 2010
      • 0 Attachment
        In message <hjl0sm+tgq0@...>, captainaatif <aatif@...>
        writes

        >
        >Thanks for the reply.
        >
        >Installed optware-devel just fine, but ..
        >
        >[~] # svn co https://svn.nslu2-linux.org/svnroot/optware/trunk optware
        >Authentication realm: https://svn.nslu2-linux.org:443
        >Client certificate filename:
        >
        >and after 3 tries ...
        >
        >Client certificate filename:
        >svn: OPTIONS of 'https://svn.nslu2-linux.org/svnroot/optware/trunk': SSL
        >handshake failed, client certificate was requested: SSL error: sslv3 alert
        >handshake failure (https://svn.nslu2-linux.org)
        >any help?
        >

        Change the https above to http

        https is only needed if you want to upload anything to the svn, i.e have
        developer access. You can down load the complete svn using just http
        --
        Robert Hammond
        PGP:0x154144DA
        592B 0199 2D7F FC05 C4B1 0404 2258 4471 1541 44DA
      • Brian
        Try put /opt/bin at the front of your PATH, at least for the compiling session. I suspect busybox /bin/awk is getting in the way. To be able to compile
        Message 3 of 5 , Jan 30, 2010
        • 0 Attachment
          Try put /opt/bin at the front of your PATH, at least for the compiling session. I suspect busybox /bin/awk is getting in the way.

          To be able to compile libsigc++, you might want to "mv /opt/lib/libstdc++.la{,.bak}" as root (admin on QNAP).

          -Brian

          --- In nslu2-linux@yahoogroups.com, "captainaatif" <aatif@...> wrote:
          >
          > Now I get this:
          >
          > ......contd.
          > lling operator() template methods.... yes
          > checking if C++ compiler supports the use of a particular specialization when ca lling operator() template methods omitting the template keyword.... yes
          > checking if C++ compiler allows usage of member function in initialization of st atic member field.... yes
          > checking whether C++ library symbols are declared in namespace std... yes
          > checking for non-standard Sun libCstd reverse_iterator... no
          > configure: creating ./config.status
          > config.status: creating Makefile
          > gawk: ./conf46N9qk/subs.awk:3: S["/; s/!.*/"]=SHELL!/bin/sh%!_!# "/bin/sh"
          > gawk: ./conf46N9qk/subs.awk:3: ^ syntax error
          > gawk: ./conf46N9qk/subs.awk:3: S["/; s/!.*/"]=PATH_SEPARATOR!:%!_!# ":"
          > gawk: ./conf46N9qk/subs.awk:3: ^ syntax error
          > gawk: ./conf46N9qk/subs.awk:4: S["/; s/!.*/"]=PATH_SEPARATOR!:%!_!# ":"
          > gawk: ./conf46N9qk/subs.awk:4: ^ syntax error
          > gawk: ./conf46N9qk/subs.awk:5: S["/; s/!.*/"]=PACKAGE_NAME!libsigc++%!_!# "libsi gc++"
          > gawk: ./conf46N9qk/subs.awk:5: ^ syntax error
          > gawk: ./conf46N9qk/subs.awk:6: S["/; s/!.*/"]=PACKAGE_TARNAME!libsigc++%!_!# "li bsigc++"
          > gawk: ./conf46N9qk/subs.awk:6: ^ syn tax error
          > gawk: ./conf46N9qk/subs.awk:7: S["/; s/!.*/"]=PACKAGE_VERSION!2.2.3%!_!# "2.2.3"
          > gawk: ./conf46N9qk/subs.awk:7: ^ syntax error
          > gawk: ./conf46N9qk/subs.awk:8: S["/; s/!.*/"]=PACKAGE_STRING!libsigc++ 2.2.3%!_! # "libsigc++ 2.2.3"
          > gawk: ./conf46N9qk/subs.awk:8: ^ syntax error
          > gawk: ./conf46N9qk/subs.awk:8: S["/; s/!.*/"]=PACKAGE_BUGREPORT!libsigc-list@gno me.org%!_!# "libsigc-list@..."
          > gawk: ./conf46N9qk/subs.awk:8: ^ in valid char '@' in expression
          > config.status: error: could not create Makefile
          > make[1]: *** [/share/MD0_DATA/aatif/optware/ts509/builds/libsigc++/.configured] Error 1
          > make[1]: Leaving directory `/share/MD0_DATA/aatif/optware/ts509'
          > make: *** [/share/MD0_DATA/aatif/optware/ts509/builds/libtorrent/.configured] Er ror 2
          >
          >
          >
          >
          >
          > --- In nslu2-linux@yahoogroups.com, Robert Hammond <robham@> wrote:
          > >
          > > In message <hjl0sm+tgq0@>, captainaatif <aatif@>
          > > writes
          > > > 
          > > >
          > > >Thanks for the reply.
          > > >
          > > >Installed optware-devel just fine, but ..
          > > >
          > > >[~] # svn co https://svn.nslu2-linux.org/svnroot/optware/trunk optware
          > > >Authentication realm: https://svn.nslu2-linux.org:443
          > > >Client certificate filename:
          > > >
          > > >and after 3 tries ...
          > > >
          > > >Client certificate filename:
          > > >svn: OPTIONS of 'https://svn.nslu2-linux.org/svnroot/optware/trunk': SSL
          > > >handshake failed, client certificate was requested: SSL error: sslv3 alert
          > > >handshake failure (https://svn.nslu2-linux.org)
          > > >any help?
          > > >
          > >
          > > Change the https above to http
          > >
          > > https is only needed if you want to upload anything to the svn, i.e have
          > > developer access. You can down load the complete svn using just http
          > > --
          > > Robert Hammond
          > > PGP:0x154144DA
          > > 592B 0199 2D7F FC05 C4B1 0404 2258 4471 1541 44DA
          > >
          >
        • Don Muller
          Curious why you are attempting to compile this for the QNAP 509 when it is available on the 509 ipkg feed. [~] # ipkg list libtorrent libtorrent - 0.12.6-1 -
          Message 4 of 5 , Mar 8, 2010
          • 0 Attachment
            Curious why you are attempting to compile this for the QNAP 509 when it is
            available on the 509 ipkg feed.

            [~] # ipkg list libtorrent
            libtorrent - 0.12.6-1 - libtorrent is a BitTorrent library with a focus on
            high performance and good code.


            > -----Original Message-----
            > From: nslu2-linux@yahoogroups.com [mailto:nslu2-linux@yahoogroups.com]
            > On Behalf Of captainaatif
            > Sent: Monday, March 08, 2010 2:56 PM
            > To: nslu2-linux@yahoogroups.com
            > Subject: [nslu2-linux] Re: Compiling libtorrent in QNAP 509 Pro
            >
            > Anyone?
            >
            > --- In nslu2-linux@yahoogroups.com, "captainaatif" <aatif@...> wrote:
            > >
            > > I tried that, but no luck. I am including the Putty log file, please
            > have a look:
            > >
            > > http://www.megaupload.com/?d=K236C7GQ
            > > or
            > > http://rapidshare.com/files/344045554/putty.log.html
            > >
            > > Thanks.
            > >
            > >
            > > >
            > > > Try put /opt/bin at the front of your PATH, at least for the
            > compiling session. I suspect busybox /bin/awk is getting in the way.
            > > >
            > > > To be able to compile libsigc++, you might want to "mv
            > /opt/lib/libstdc++.la{,.bak}" as root (admin on QNAP).
            > > >
            > > > -Brian
            > > >
            > >
            >
            >
            >
            >
            > ------------------------------------
            >
            > Yahoo! Groups Links
            >
            >
            >
          • Brian
            Just when I found out his problem, captainaatif disappeared from the group with all his messages. I was not able to replicate his problem first.
            Message 5 of 5 , Mar 8, 2010
            • 0 Attachment
              Just when I found out his problem, "captainaatif" <aatif@> disappeared from the group with all his messages.

              I was not able to replicate his problem first. Then I intentionally renamed /opt/bin/sed to /opt/bin/sed.bak, and got exactly same error message. So if he or anyone else see this, make sure to use /opt/bin/sed which should link to /opt/bin/gnu-sed.

              -Brian

              --- In nslu2-linux@yahoogroups.com, "Brian" <b88zhou@...> wrote:
              >
              > Try put /opt/bin at the front of your PATH, at least for the compiling session. I suspect busybox /bin/awk is getting in the way.
              >
              > To be able to compile libsigc++, you might want to "mv /opt/lib/libstdc++.la{,.bak}" as root (admin on QNAP).
              >
              > -Brian
              >
              > --- In nslu2-linux@yahoogroups.com, "captainaatif" <aatif@> wrote:
              > >
              > > Now I get this:
              > >
              > > ......contd.
              > > lling operator() template methods.... yes
              > > checking if C++ compiler supports the use of a particular specialization when ca lling operator() template methods omitting the template keyword.... yes
              > > checking if C++ compiler allows usage of member function in initialization of st atic member field.... yes
              > > checking whether C++ library symbols are declared in namespace std... yes
              > > checking for non-standard Sun libCstd reverse_iterator... no
              > > configure: creating ./config.status
              > > config.status: creating Makefile
              > > gawk: ./conf46N9qk/subs.awk:3: S["/; s/!.*/"]=SHELL!/bin/sh%!_!# "/bin/sh"
              > > gawk: ./conf46N9qk/subs.awk:3: ^ syntax error
              > > gawk: ./conf46N9qk/subs.awk:3: S["/; s/!.*/"]=PATH_SEPARATOR!:%!_!# ":"
              > > gawk: ./conf46N9qk/subs.awk:3: ^ syntax error
              > > gawk: ./conf46N9qk/subs.awk:4: S["/; s/!.*/"]=PATH_SEPARATOR!:%!_!# ":"
              > > gawk: ./conf46N9qk/subs.awk:4: ^ syntax error
              > > gawk: ./conf46N9qk/subs.awk:5: S["/; s/!.*/"]=PACKAGE_NAME!libsigc++%!_!# "libsi gc++"
              > > gawk: ./conf46N9qk/subs.awk:5: ^ syntax error
              > > gawk: ./conf46N9qk/subs.awk:6: S["/; s/!.*/"]=PACKAGE_TARNAME!libsigc++%!_!# "li bsigc++"
              > > gawk: ./conf46N9qk/subs.awk:6: ^ syn tax error
              > > gawk: ./conf46N9qk/subs.awk:7: S["/; s/!.*/"]=PACKAGE_VERSION!2.2.3%!_!# "2.2.3"
              > > gawk: ./conf46N9qk/subs.awk:7: ^ syntax error
              > > gawk: ./conf46N9qk/subs.awk:8: S["/; s/!.*/"]=PACKAGE_STRING!libsigc++ 2.2.3%!_! # "libsigc++ 2.2.3"
              > > gawk: ./conf46N9qk/subs.awk:8: ^ syntax error
              > > gawk: ./conf46N9qk/subs.awk:8: S["/; s/!.*/"]=PACKAGE_BUGREPORT!libsigc-list@gno me.org%!_!# "libsigc-list@"
              > > gawk: ./conf46N9qk/subs.awk:8: ^ in valid char '@' in expression
              > > config.status: error: could not create Makefile
              > > make[1]: *** [/share/MD0_DATA/aatif/optware/ts509/builds/libsigc++/.configured] Error 1
              > > make[1]: Leaving directory `/share/MD0_DATA/aatif/optware/ts509'
              > > make: *** [/share/MD0_DATA/aatif/optware/ts509/builds/libtorrent/.configured] Er ror 2
              > >
              > >
              > >
              > >
              > >
              > > --- In nslu2-linux@yahoogroups.com, Robert Hammond <robham@> wrote:
              > > >
              > > > In message <hjl0sm+tgq0@>, captainaatif <aatif@>
              > > > writes
              > > > > 
              > > > >
              > > > >Thanks for the reply.
              > > > >
              > > > >Installed optware-devel just fine, but ..
              > > > >
              > > > >[~] # svn co https://svn.nslu2-linux.org/svnroot/optware/trunk optware
              > > > >Authentication realm: https://svn.nslu2-linux.org:443
              > > > >Client certificate filename:
              > > > >
              > > > >and after 3 tries ...
              > > > >
              > > > >Client certificate filename:
              > > > >svn: OPTIONS of 'https://svn.nslu2-linux.org/svnroot/optware/trunk': SSL
              > > > >handshake failed, client certificate was requested: SSL error: sslv3 alert
              > > > >handshake failure (https://svn.nslu2-linux.org)
              > > > >any help?
              > > > >
              > > >
              > > > Change the https above to http
              > > >
              > > > https is only needed if you want to upload anything to the svn, i.e have
              > > > developer access. You can down load the complete svn using just http
              > > > --
              > > > Robert Hammond
              > > > PGP:0x154144DA
              > > > 592B 0199 2D7F FC05 C4B1 0404 2258 4471 1541 44DA
              > > >
              > >
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.