Loading ...
Sorry, an error occurred while loading the content.

man / groff shows undecoded escape sequences (was: "groff" install broken, need some hint)

Expand Messages
  • Mai Kee Reis
    Hi Brian and all, Now I switched from busybox s less to optware s less. Also, I export PAGER=/opt/bin/less (even if opkg install less does something to bend
    Message 1 of 1 , Oct 31, 2009
    • 0 Attachment
      Hi Brian and all,

      Now I switched from busybox's less to optware's less.
      Also, I export PAGER=/opt/bin/less
      (even if "opkg install less" does something to bend less to the new one).

      The problem doesn't disappear. Same as before.
      "ncurses" is installed, but "ncursesw" isn't - and can't.
      As far as I can see, it doesn't exist in ipkg nor opkg.

      Thus, I changed in /opt/etc/man.con the line with "GROFF".
      Just added "-c" to it, as told in
      and <http://osdir.com/ml/lfs.support/2002-10/msg00353.html>.

      This made man working only in black and grey letters on white background,
      but - it's okay! Let's say "WORKSFORME".

      Thank you all for friendly assistance!!!

      If we want to try out, why opkg less didn't fixed it ... let's talk further.

      > ________________________________________________________________________
      > 1b. Re: "groff" install broken, need some hint
      > Posted by: "brian_zhou" b88zhou@... brian_zhou
      > Date: Thu Oct 29, 2009 1:27 pm ((PDT))
      > Don't know why libstdc++ got "Status: install ok not-installed".
      > For the corrupt man screen problem, can you make sure optware less is installed, and export PAGER=/opt/bin/less ? Note optware mc is compiled with slang, while less depends on ncursesw.
      > -Brian
      > --- In nslu2-linux@yahoogroups.com, Mai Kee Reis <maik_nospam_reiss@...> wrote:
      >> Hi Mike and Brian,
      >> and all others who would like to help,
      >> Yes it is a pair of NSLU2s, both running SlugOS/LE 5.3 with optware feed
      >> installed.
      >> Adviced by your hints, guesses and questions, I asked again the ipkg,
      >> this time about libstdc:
      >> MySlug:~# ipkg info 'libstdc*'
      >> Package: libstdc++
      >> Version: 6.0.9-6
      >>> Status: install ok not-installed
      >> Section: util
      >> Architecture: arm
      >> maintainer: NSLU2 Linux <nslu2-linux@yahoogroups.com>
      >> MD5Sum: c2ad38208949ec60177569a55455055a
      >> Size: 217708
      >> Filename: libstdc++_6.0.9-6_arm.ipk
      >> Source: /
      >> Description: Standard C++ library, needed for dynamically linked C++
      >> programs
      >> See above, the line at the '>' mark. Looks like groff ipkg packet really
      >> has problems to resolve libstdc dependency, right?
      >> Groff knows about the dependancy, see here:
      >> MySlug:~# ipkg status groff
      >> Package: groff
      >> Version: 1.19.2-2
      >>> Depends: libstdc++
      >> Status: install ok installed
      >> Architecture: arm
      >> But for some unknown reasons, I have to manually install libstdc++ now.
      >> Okay, I'll do it now:
      >> MySlug:~# ipkg install libstdc++
      >> (please wait a while, it is just running...okay, it has finished)
      >> Now, 'man' and 'groff' have all subsequent libraries .....
      >> Oooops!!! New trouble!
      >> .... something with the terminal control is bad. See below snipped, I
      >> removed some of the blank lines.
      >> MySlug:~# man man
      >> ________________________________________________________________
      >> man(1)
      >> man(1)
      >> [[1mNAME[[0m
      >> man - format and display the on-line manual pages
      >> [[1mSYNOPSIS[[0m
      >> ________________________________________________________________
      >> It looks to me as if ESCAPE-sequences for colorisation are used, but the
      >> teminal does not understand it.
      >> Please note, my terminal does understand such stuff. I'm connected via
      >> ssh, ls and midnight commander
      >> are working very well in full colored mode. Just checked it twice again.
      >> The related settings are:
      >> PAGER='less'
      >> VISUAL='joe'
      >> TERM='linux'
      >> TERMINFO='/opt/lib/terminfo'
      >> LS_OPTIONS='--color=auto -h -a -L'
      >> But I don't know enough about linux to tell you which terminfo version I
      >> installed once.
      >> I'm pretty shure, it's the one which was required to get midnight
      >> commander working.
      >> I would highly appreciate further help from you all,
      >> with best regards,
      >> Mai Kee R.
      >> BTW.:
      >> Each day I'm using SlugOS, I see I wasted years of my life with DOS and
      >> Windows.
    Your message has been successfully submitted and would be delivered to recipients shortly.