Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] "groff" install broken, need some hint

Expand Messages
  • Mike Westerhof (mwester)
    I m guessing that the hardware is an NSLU2, but beyond that, it s pretty hard to tell for sure. You might be running the Unslung firmware -- but I don t know
    Message 1 of 5 , Oct 27, 2009
    • 0 Attachment
      I'm guessing that the hardware is an NSLU2, but beyond that, it's pretty
      hard to tell for sure. You might be running the Unslung firmware -- but
      I don't know what version. You might also be running a SlugOS firmware,
      using the optware feeds -- but again, not sure what version.

      If you go to the wiki, one of the links (on the left margin) is to the
      ipkg search engine. It will allow you to do a query by filename to
      locate the package that contains libstdc++.so.6. Install the correct
      version of that package (depends on what firmware and version of that
      firmware you are running -- you didn't tell us that).

      And this is certainly a bug in the dependencies for the groff package;
      it should be marked to require that library.

      -Mike (mwester)

      Mai Kee Reis wrote:
      > Hi again,
      >
      > I could use some help by your experts. Groff is installed, but does not
      > work. Please see here:
      > MySlug:~# groff
      > groff: error while loading shared libraries: libstdc++.so.6: cannot
      > open shared object file: No such file or directory
      > MySlug:~# which groff
      > /opt/bin/groff
      >
      > Status of the groff packet shall be okay:
      > MySlug:~# ipkg info groff
      > Package: groff
      > Version: 1.19.2-2
      > Depends: libstdc++
      > Status: install ok installed
      > Section: util
      > Architecture: arm
      > Filename: groff_1.19.2-2_arm.ipk
      > Source: http://ftp.gnu.org/gnu/groff/groff-1.19.2.tar.gz
      > ....
      >
      > So I want to ask you, how can I resolve the 'libstdc++.so.6' issue?
      > I guess, it's something with "ln -s /opt/.../lib....", but what exactly?
      > How can I learn where 'libstdc++.so.6' has to be located?
      > How can I learn where libstdc++.so.<whatever> is located? /(I think I
      > won't have locate on my tiny boxes)
      >
      >
      > with best regards,
      > Mai Kee Reis
      >
      >
      >
      >
      > ------------------------------------
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
      >
    • brian_zhou
      groff already depends on libstdc++ libstdc++ is supposed to have libstdc++.so* files under /opt/lib The ipk name indicates arm not armeb, so you re probably
      Message 2 of 5 , Oct 27, 2009
      • 0 Attachment
        groff already depends on libstdc++
        libstdc++ is supposed to have libstdc++.so* files under /opt/lib

        The ipk name indicates arm not armeb, so you're probably using neither unslung nor slugosbe. And the hardware may be not nslu2 at all. You definitely need to provide more info for people to help you.

        BTW, you can install mlocate from optware, manually invoke updatedb.

        -Brian

        --- In nslu2-linux@yahoogroups.com, Mai Kee Reis <maik_nospam_reiss@...> wrote:
        >
        > Hi again,
        >
        > I could use some help by your experts. Groff is installed, but does not
        > work. Please see here:
        > MySlug:~# groff
        > groff: error while loading shared libraries: libstdc++.so.6: cannot
        > open shared object file: No such file or directory
        > MySlug:~# which groff
        > /opt/bin/groff
        >
        > Status of the groff packet shall be okay:
        > MySlug:~# ipkg info groff
        > Package: groff
        > Version: 1.19.2-2
        > Depends: libstdc++
        > Status: install ok installed
        > Section: util
        > Architecture: arm
        > Filename: groff_1.19.2-2_arm.ipk
        > Source: http://ftp.gnu.org/gnu/groff/groff-1.19.2.tar.gz
        > ....
        >
        > So I want to ask you, how can I resolve the 'libstdc++.so.6' issue?
        > I guess, it's something with "ln -s /opt/.../lib....", but what exactly?
        > How can I learn where 'libstdc++.so.6' has to be located?
        > How can I learn where libstdc++.so.<whatever> is located? /(I think I
        > won't have locate on my tiny boxes)
        >
        >
        > with best regards,
        > Mai Kee Reis
        >
      • Mai Kee Reis
        Hi Mike and Brian, and all others who would like to help, Yes it is a pair of NSLU2s, both running SlugOS/LE 5.3 with optware feed installed. Adviced by your
        Message 3 of 5 , Oct 29, 2009
        • 0 Attachment
          Hi Mike and Brian,
          and all others who would like to help,

          Yes it is a pair of NSLU2s, both running SlugOS/LE 5.3 with optware feed
          installed.
          Adviced by your hints, guesses and questions, I asked again the ipkg,
          this time about libstdc:
          MySlug:~# ipkg info 'libstdc*'
          Package: libstdc++
          Version: 6.0.9-6
          > Status: install ok not-installed
          Section: util
          Architecture: arm
          maintainer: NSLU2 Linux <nslu2-linux@yahoogroups.com>
          MD5Sum: c2ad38208949ec60177569a55455055a
          Size: 217708
          Filename: libstdc++_6.0.9-6_arm.ipk
          Source: /
          Description: Standard C++ library, needed for dynamically linked C++
          programs

          See above, the line at the '>' mark. Looks like groff ipkg packet really
          has problems to resolve libstdc dependency, right?
          Groff knows about the dependancy, see here:
          MySlug:~# ipkg status groff
          Package: groff
          Version: 1.19.2-2
          > Depends: libstdc++
          Status: install ok installed
          Architecture: arm

          But for some unknown reasons, I have to manually install libstdc++ now.
          Okay, I'll do it now:
          MySlug:~# ipkg install libstdc++
          (please wait a while, it is just running...okay, it has finished)
          Now, 'man' and 'groff' have all subsequent libraries .....

          Oooops!!! New trouble!

          .... something with the terminal control is bad. See below snipped, I
          removed some of the blank lines.

          MySlug:~# man man
          ________________________________________________________________

          man(1)
          man(1)
          [[1mNAME[[0m
          man - format and display the on-line manual pages
          [[1mSYNOPSIS[[0m
          ________________________________________________________________

          It looks to me as if ESCAPE-sequences for colorisation are used, but the
          teminal does not understand it.
          Please note, my terminal does understand such stuff. I'm connected via
          ssh, ls and midnight commander
          are working very well in full colored mode. Just checked it twice again.
          The related settings are:
          PAGER='less'
          VISUAL='joe'
          TERM='linux'
          TERMINFO='/opt/lib/terminfo'
          LS_OPTIONS='--color=auto -h -a -L'
          But I don't know enough about linux to tell you which terminfo version I
          installed once.
          I'm pretty shure, it's the one which was required to get midnight
          commander working.

          I would highly appreciate further help from you all,
          with best regards,
          Mai Kee R.

          BTW.:
          Each day I'm using SlugOS, I see I wasted years of my life with DOS and
          Windows.

          > Messages in this topic (3)
          > ________________________________________________________________________
          > 1b. Re: "groff" install broken, need some hint
          > Posted by: "Mike Westerhof (mwester)" mwester@... mjwest61
          > Date: Tue Oct 27, 2009 8:21 pm ((PDT))
          >
          > I'm guessing that the hardware is an NSLU2, but beyond that, it's pretty
          > hard to tell for sure. You might be running the Unslung firmware -- but
          > I don't know what version. You might also be running a SlugOS firmware,
          > using the optware feeds -- but again, not sure what version.
          >
          > If you go to the wiki, one of the links (on the left margin) is to the
          > ipkg search engine. It will allow you to do a query by filename to
          > locate the package that contains libstdc++.so.6. Install the correct
          > version of that package (depends on what firmware and version of that
          > firmware you are running -- you didn't tell us that).
          >
          > And this is certainly a bug in the dependencies for the groff package;
          > it should be marked to require that library.
          >
          > -Mike (mwester)
          >
          > Mai Kee Reis wrote:
          >
          >> Hi again,
          >>
          >> I could use some help by your experts. Groff is installed, but does not
          >> work. Please see here:
          >> MySlug:~# groff
          >> groff: error while loading shared libraries: libstdc++.so.6: cannot
          >> open shared object file: No such file or directory
          >> MySlug:~# which groff
          >> /opt/bin/groff
          >>
          >> Status of the groff packet shall be okay:
          >> MySlug:~# ipkg info groff
          >> Package: groff
          >> Version: 1.19.2-2
          >> Depends: libstdc++
          >> Status: install ok installed
          >> Section: util
          >> Architecture: arm
          >> Filename: groff_1.19.2-2_arm.ipk
          >> Source: http://ftp.gnu.org/gnu/groff/groff-1.19.2.tar.gz
          >> ....
          >>
          >> So I want to ask you, how can I resolve the 'libstdc++.so.6' issue?
          >> I guess, it's something with "ln -s /opt/.../lib....", but what exactly?
          >> How can I learn where 'libstdc++.so.6' has to be located?
          >> How can I learn where libstdc++.so.<whatever> is located? /(I think I
          >> won't have locate on my tiny boxes)
          >>
          >>
          >> with best regards,
          >> Mai Kee Reis
          >>
          >>
          >>
          >>
          >> ------------------------------------
          >>
          >> Yahoo! Groups Links
          >>
          >>
          >>
          >>
          >>
          >>
          >
          >
          >
          >
          >
          > Messages in this topic (3)
          > ________________________________________________________________________
          > 1c. Re: "groff" install broken, need some hint
          > Posted by: "brian_zhou" b88zhou@... brian_zhou
          > Date: Tue Oct 27, 2009 8:40 pm ((PDT))
          >
          > groff already depends on libstdc++
          > libstdc++ is supposed to have libstdc++.so* files under /opt/lib
          >
          > The ipk name indicates arm not armeb, so you're probably using neither unslung nor slugosbe. And the hardware may be not nslu2 at all. You definitely need to provide more info for people to help you.
          >
          > BTW, you can install mlocate from optware, manually invoke updatedb.
          >
          > -Brian
          >
          >
        • brian_zhou
          Don t know why libstdc++ got Status: install ok not-installed . For the corrupt man screen problem, can you make sure optware less is installed, and export
          Message 4 of 5 , Oct 29, 2009
          • 0 Attachment
            Don't know why libstdc++ got "Status: install ok not-installed".

            For the corrupt man screen problem, can you make sure optware less is installed, and export PAGER=/opt/bin/less ? Note optware mc is compiled with slang, while less depends on ncursesw.

            -Brian

            --- In nslu2-linux@yahoogroups.com, Mai Kee Reis <maik_nospam_reiss@...> wrote:
            >
            > Hi Mike and Brian,
            > and all others who would like to help,
            >
            > Yes it is a pair of NSLU2s, both running SlugOS/LE 5.3 with optware feed
            > installed.
            > Adviced by your hints, guesses and questions, I asked again the ipkg,
            > this time about libstdc:
            > MySlug:~# ipkg info 'libstdc*'
            > Package: libstdc++
            > Version: 6.0.9-6
            > > Status: install ok not-installed
            > Section: util
            > Architecture: arm
            > maintainer: NSLU2 Linux <nslu2-linux@yahoogroups.com>
            > MD5Sum: c2ad38208949ec60177569a55455055a
            > Size: 217708
            > Filename: libstdc++_6.0.9-6_arm.ipk
            > Source: /
            > Description: Standard C++ library, needed for dynamically linked C++
            > programs
            >
            > See above, the line at the '>' mark. Looks like groff ipkg packet really
            > has problems to resolve libstdc dependency, right?
            > Groff knows about the dependancy, see here:
            > MySlug:~# ipkg status groff
            > Package: groff
            > Version: 1.19.2-2
            > > Depends: libstdc++
            > Status: install ok installed
            > Architecture: arm
            >
            > But for some unknown reasons, I have to manually install libstdc++ now.
            > Okay, I'll do it now:
            > MySlug:~# ipkg install libstdc++
            > (please wait a while, it is just running...okay, it has finished)
            > Now, 'man' and 'groff' have all subsequent libraries .....
            >
            > Oooops!!! New trouble!
            >
            > .... something with the terminal control is bad. See below snipped, I
            > removed some of the blank lines.
            >
            > MySlug:~# man man
            > ________________________________________________________________
            >
            > man(1)
            > man(1)
            > [[1mNAME[[0m
            > man - format and display the on-line manual pages
            > [[1mSYNOPSIS[[0m
            > ________________________________________________________________
            >
            > It looks to me as if ESCAPE-sequences for colorisation are used, but the
            > teminal does not understand it.
            > Please note, my terminal does understand such stuff. I'm connected via
            > ssh, ls and midnight commander
            > are working very well in full colored mode. Just checked it twice again.
            > The related settings are:
            > PAGER='less'
            > VISUAL='joe'
            > TERM='linux'
            > TERMINFO='/opt/lib/terminfo'
            > LS_OPTIONS='--color=auto -h -a -L'
            > But I don't know enough about linux to tell you which terminfo version I
            > installed once.
            > I'm pretty shure, it's the one which was required to get midnight
            > commander working.
            >
            > I would highly appreciate further help from you all,
            > with best regards,
            > Mai Kee R.
            >
            > BTW.:
            > Each day I'm using SlugOS, I see I wasted years of my life with DOS and
            > Windows.
            >
            > > Messages in this topic (3)
            > > ________________________________________________________________________
            > > 1b. Re: "groff" install broken, need some hint
            > > Posted by: "Mike Westerhof (mwester)" mwester@... mjwest61
            > > Date: Tue Oct 27, 2009 8:21 pm ((PDT))
            > >
            > > I'm guessing that the hardware is an NSLU2, but beyond that, it's pretty
            > > hard to tell for sure. You might be running the Unslung firmware -- but
            > > I don't know what version. You might also be running a SlugOS firmware,
            > > using the optware feeds -- but again, not sure what version.
            > >
            > > If you go to the wiki, one of the links (on the left margin) is to the
            > > ipkg search engine. It will allow you to do a query by filename to
            > > locate the package that contains libstdc++.so.6. Install the correct
            > > version of that package (depends on what firmware and version of that
            > > firmware you are running -- you didn't tell us that).
            > >
            > > And this is certainly a bug in the dependencies for the groff package;
            > > it should be marked to require that library.
            > >
            > > -Mike (mwester)
            > >
            > > Mai Kee Reis wrote:
            > >
            > >> Hi again,
            > >>
            > >> I could use some help by your experts. Groff is installed, but does not
            > >> work. Please see here:
            > >> MySlug:~# groff
            > >> groff: error while loading shared libraries: libstdc++.so.6: cannot
            > >> open shared object file: No such file or directory
            > >> MySlug:~# which groff
            > >> /opt/bin/groff
            > >>
            > >> Status of the groff packet shall be okay:
            > >> MySlug:~# ipkg info groff
            > >> Package: groff
            > >> Version: 1.19.2-2
            > >> Depends: libstdc++
            > >> Status: install ok installed
            > >> Section: util
            > >> Architecture: arm
            > >> Filename: groff_1.19.2-2_arm.ipk
            > >> Source: http://ftp.gnu.org/gnu/groff/groff-1.19.2.tar.gz
            > >> ....
            > >>
            > >> So I want to ask you, how can I resolve the 'libstdc++.so.6' issue?
            > >> I guess, it's something with "ln -s /opt/.../lib....", but what exactly?
            > >> How can I learn where 'libstdc++.so.6' has to be located?
            > >> How can I learn where libstdc++.so.<whatever> is located? /(I think I
            > >> won't have locate on my tiny boxes)
            > >>
            > >>
            > >> with best regards,
            > >> Mai Kee Reis
            > >>
            > >>
            > >>
            > >>
            > >> ------------------------------------
            > >>
            > >> Yahoo! Groups Links
            > >>
            > >>
            > >>
            > >>
            > >>
            > >>
            > >
            > >
            > >
            > >
            > >
            > > Messages in this topic (3)
            > > ________________________________________________________________________
            > > 1c. Re: "groff" install broken, need some hint
            > > Posted by: "brian_zhou" b88zhou@... brian_zhou
            > > Date: Tue Oct 27, 2009 8:40 pm ((PDT))
            > >
            > > groff already depends on libstdc++
            > > libstdc++ is supposed to have libstdc++.so* files under /opt/lib
            > >
            > > The ipk name indicates arm not armeb, so you're probably using neither unslung nor slugosbe. And the hardware may be not nslu2 at all. You definitely need to provide more info for people to help you.
            > >
            > > BTW, you can install mlocate from optware, manually invoke updatedb.
            > >
            > > -Brian
            > >
            > >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.