Loading ...
Sorry, an error occurred while loading the content.

Cant run perl from optware/ts101 feed - Compile shared libraries with -fPIC!

Expand Messages
  • jasoncraneuk@hotmail.com
    Hello I m having a problem running Perl that I ve installed via ipkg from the optware/ts101/cross/ feed onto my Qnap TS-101. Firstly, I hope this is this the
    Message 1 of 4 , Oct 14, 2009
    • 0 Attachment
      Hello

      I'm having a problem running Perl that I've installed via ipkg from the optware/ts101/cross/ feed onto my Qnap TS-101.

      Firstly, I hope this is this the right forum for asking this, nslug1-linux is listed as the package maintainer in the feed.

      The actual problem is that when I try to run perl I get this:
      [~] # perl -v
      R_PPC_REL24: Compile shared libraries with -fPIC!

      perl: symbol 'malloc': can't handle reloc type 0xa


      I did the usual ipkg install perl, and it reported no problems. Everything I've found on the web points to this being flags that were missing when the package was built, or other problems with compiling or linking. (e.g. http://www.gentoo.org/proj/en/base/amd64/howtos/index.xml?part=1&chap=3 its for gentoo, but I guess the principal is the same)

      Is there is anything I can do about this or does the package or one of its dependencies need updating by a developer? I'd have a go at building this myself, but I'm a bit of a linux noob and my previous attempts to set up a build environment or cross compiler have both failed, so I'm stuck with downloading the pre compiled binaries. I've tried re-installing, uninstalling and updating with no effect. Other stuff I've installed with ipkg has worked fine.

      Thanks in advance for any help

      Jason
    • perror@rocketmail.com
      ... I ve just installed the latest package, perl_5.8.8-22_powerpc.ipk and get the same error. This is my first attempt at using OptWare and I would really like
      Message 2 of 4 , Nov 18, 2009
      • 0 Attachment
        --- In nslu2-linux@yahoogroups.com, jasoncraneuk@... wrote:
        >
        > Hello
        >
        > I'm having a problem running Perl that I've installed via ipkg from the optware/ts101/cross/ feed onto my Qnap TS-101.
        >
        > Firstly, I hope this is this the right forum for asking this, nslug1-linux is listed as the package maintainer in the feed.
        >
        > The actual problem is that when I try to run perl I get this:
        > [~] # perl -v
        > R_PPC_REL24: Compile shared libraries with -fPIC!
        >
        > perl: symbol 'malloc': can't handle reloc type 0xa
        >
        >

        I've just installed the latest package, perl_5.8.8-22_powerpc.ipk and get the same error.
        This is my first attempt at using OptWare and I would really like to get Perl working! I've tried to find older packages but without any luck.
      • perror@rocketmail.com
        ... Just for the record, In perl_5.8.8-23_powerpc.ipk this have been fixed!
        Message 3 of 4 , Dec 6, 2009
        • 0 Attachment
          --- In nslu2-linux@yahoogroups.com, "perror@..." <perror@...> wrote:
          >
          >
          >
          > --- In nslu2-linux@yahoogroups.com, jasoncraneuk@ wrote:
          > >
          > > Hello
          > >
          > > I'm having a problem running Perl that I've installed via ipkg from the optware/ts101/cross/ feed onto my Qnap TS-101.
          > >
          > > Firstly, I hope this is this the right forum for asking this, nslug1-linux is listed as the package maintainer in the feed.
          > >
          > > The actual problem is that when I try to run perl I get this:
          > > [~] # perl -v
          > > R_PPC_REL24: Compile shared libraries with -fPIC!
          > >
          > > perl: symbol 'malloc': can't handle reloc type 0xa
          > >
          > >
          >
          > I've just installed the latest package, perl_5.8.8-22_powerpc.ipk and get the same error.
          > This is my first attempt at using OptWare and I would really like to get Perl working! I've tried to find older packages but without any luck.
          >

          Just for the record, In perl_5.8.8-23_powerpc.ipk this have been fixed!
        • jasoncraneuk@hotmail.com
          ... Thanks for the heads up. I ve just upgraded from 22 to 23 and it works a treat. :)
          Message 4 of 4 , Dec 8, 2009
          • 0 Attachment
            --- In nslu2-linux@yahoogroups.com, "perror@..." <perror@...> wrote:
            >
            >
            >
            > --- In nslu2-linux@yahoogroups.com, "perror@" <perror@> wrote:
            > >
            > >
            > >
            > > --- In nslu2-linux@yahoogroups.com, jasoncraneuk@ wrote:
            > > >
            > > > Hello
            > > >
            > > > I'm having a problem running Perl that I've installed via ipkg from the optware/ts101/cross/ feed onto my Qnap TS-101.
            > > >
            > > > Firstly, I hope this is this the right forum for asking this, nslug1-linux is listed as the package maintainer in the feed.
            > > >
            > > > The actual problem is that when I try to run perl I get this:
            > > > [~] # perl -v
            > > > R_PPC_REL24: Compile shared libraries with -fPIC!
            > > >
            > > > perl: symbol 'malloc': can't handle reloc type 0xa
            > > >
            > > >
            > >
            > > I've just installed the latest package, perl_5.8.8-22_powerpc.ipk and get the same error.
            > > This is my first attempt at using OptWare and I would really like to get Perl working! I've tried to find older packages but without any luck.
            > >
            >
            > Just for the record, In perl_5.8.8-23_powerpc.ipk this have been fixed!
            >

            Thanks for the heads up. I've just upgraded from 22 to 23 and it works a treat. :)
          Your message has been successfully submitted and would be delivered to recipients shortly.