Loading ...
Sorry, an error occurred while loading the content.

[nslu2-linux] Cant get Mysql conenction on Ruby 1.9 on Unslung

Expand Messages
  • keserc
    I have a NSLU2 with Unslung firmware. I have installed ruby using ipkg, and the version that came was 1.9. I have also installed mysql server using ipkg, and
    Message 1 of 1 , Sep 23, 2009
    • 0 Attachment
      I have a NSLU2 with Unslung firmware.

      I have installed ruby using ipkg, and the version that came was 1.9.
      I have also installed mysql server using ipkg, and the version was 4.1.2.
      Now I need to connect to that mysql server from my ruby code but; I can't
      install any Ruby Mysql adapters becuase of the 1.9 version I have.

      I have tried the "Ruby/Mysql" API written in Ruby but; it gives "Packets out
      of order" error where I can connect to Mysql server from other computers (I
      have checked user privileges etc stuff on mysql).

      I have tried installing mysql gem using 'gem install ruby' but; since that
      requires 'make'ing of external files it didn't install on NSLU2.

      What else can I do?

      Does anyone have the old Ruby 1.8.X version ipk so that I can install that?
      I guess that would solve my problem...?
    Your message has been successfully submitted and would be delivered to recipients shortly.