Loading ...
Sorry, an error occurred while loading the content.

mediatomb transcoding

Expand Messages
  • h_ching
    I am wondering if anyone has experience in this. I am trying to get mediatomb to transcode from my slug and my sheevaplug but the standard install is missing
    Message 1 of 4 , Sep 11, 2009
    • 0 Attachment
      I am wondering if anyone has experience in this. I am trying to get mediatomb to transcode from my slug and my sheevaplug but the standard install is missing the mpeg2video encoder.

      After a bit of research, I learned that I need to install libavcodec-unstripped-51 but apt-get install libavcodec-unstripped-51 gives me

      Package libavcodec-unstripped-51 is not available, but is referred to by another package.
      This may mean that the package is missing, has been obsoleted, or
      is only available from another source
      E: Package libavcodec-unstripped-51 has no installation candidate

      Any idea on how do I get this to work? I am using Debian Lenny distro.

      Thanks in advance. Henry
    • h_ching
      ... Anyone has any thoughts on this or am I going about it the wrong way?
      Message 2 of 4 , Sep 15, 2009
      • 0 Attachment
        --- In nslu2-linux@yahoogroups.com, "h_ching" <h_ching@...> wrote:
        >
        > I am wondering if anyone has experience in this. I am trying to get mediatomb to transcode from my slug and my sheevaplug but the standard install is missing the mpeg2video encoder.
        >
        > After a bit of research, I learned that I need to install libavcodec-unstripped-51 but apt-get install libavcodec-unstripped-51 gives me
        >
        > Package libavcodec-unstripped-51 is not available, but is referred to by another package.
        > This may mean that the package is missing, has been obsoleted, or
        > is only available from another source
        > E: Package libavcodec-unstripped-51 has no installation candidate
        >
        > Any idea on how do I get this to work? I am using Debian Lenny distro.
        >
        > Thanks in advance. Henry
        >


        Anyone has any thoughts on this or am I going about it the wrong way?
      • slackline
        ... I wouldn t bother trying to get the slug to transcode video, it just doesn t pack enough punch. You may get more mileage out of the Sheevaplug though, but
        Message 3 of 4 , Sep 15, 2009
        • 0 Attachment
          --- In nslu2-linux@yahoogroups.com, "h_ching" <h_ching@...> wrote:
          >
          > --- In nslu2-linux@yahoogroups.com, "h_ching" <h_ching@> wrote:
          > >
          > > I am wondering if anyone has experience in this. I am trying to get mediatomb to transcode from my slug and my sheevaplug but the standard install is missing the mpeg2video encoder.
          > >
          > > After a bit of research, I learned that I need to install libavcodec-unstripped-51 but apt-get install libavcodec-unstripped-51 gives me
          > >
          > > Package libavcodec-unstripped-51 is not available, but is referred to by another package.
          > > This may mean that the package is missing, has been obsoleted, or
          > > is only available from another source
          > > E: Package libavcodec-unstripped-51 has no installation candidate
          > >
          > > Any idea on how do I get this to work? I am using Debian Lenny distro.
          > >
          > > Thanks in advance. Henry
          > >
          >
          >
          > Anyone has any thoughts on this or am I going about it the wrong way?
          >

          I wouldn't bother trying to get the slug to transcode video, it just doesn't pack enough punch.

          You may get more mileage out of the Sheevaplug though, but I've not got one to play with (yet :-) so can't comment.
        • h_ching
          ... I agree and I am pinning my hopes on the Sheevaplug but I know both of them access the same Linux software library so I am hoping some brave souls may have
          Message 4 of 4 , Sep 15, 2009
          • 0 Attachment
            --- In nslu2-linux@yahoogroups.com, "slackline" <nshephard@...> wrote:
            >
            > --- In nslu2-linux@yahoogroups.com, "h_ching" <h_ching@> wrote:
            > >
            > > --- In nslu2-linux@yahoogroups.com, "h_ching" <h_ching@> wrote:
            > > >
            > > > I am wondering if anyone has experience in this. I am trying to get mediatomb to transcode from my slug and my sheevaplug but the standard install is missing the mpeg2video encoder.
            > > >
            > > > After a bit of research, I learned that I need to install libavcodec-unstripped-51 but apt-get install libavcodec-unstripped-51 gives me
            > > >
            > > > Package libavcodec-unstripped-51 is not available, but is referred to by another package.
            > > > This may mean that the package is missing, has been obsoleted, or
            > > > is only available from another source
            > > > E: Package libavcodec-unstripped-51 has no installation candidate
            > > >
            > > > Any idea on how do I get this to work? I am using Debian Lenny distro.
            > > >
            > > > Thanks in advance. Henry
            > > >
            > >
            > >
            > > Anyone has any thoughts on this or am I going about it the wrong way?
            > >
            >
            > I wouldn't bother trying to get the slug to transcode video, it just doesn't pack enough punch.
            >
            > You may get more mileage out of the Sheevaplug though, but I've not got one to play with (yet :-) so can't comment.
            >

            I agree and I am pinning my hopes on the Sheevaplug but I know both of them access the same Linux software library so I am hoping some brave souls may have attempted this before or at least aware of the issue and have some ideas on how to get around this.

            I went a bit further and listed all the supported format with ffmpeg -formats. The encoder for mpeg2video does not come with the standard install but mpeg1video does. However, it only transcoded one of my avi files for about 3 seconds and the the process is <defunct> when I was monitoring this using the 'top' command. A bit stuck.
          Your message has been successfully submitted and would be delivered to recipients shortly.