Loading ...
Sorry, an error occurred while loading the content.

Re: direct ethernet connection from PC to slug

Expand Messages
  • Richard
    Ah, good idea. However I tried to share my wireless with my hardwired ethernet connection but windows ICS won t let me because it tries to change the wireless
    Message 1 of 8 , Jun 25, 2009
    • 0 Attachment
      Ah, good idea. However I tried to share my wireless with my hardwired ethernet connection but windows ICS won't let me because it tries to change the wireless ip to 192.168.0.1, but my gateway has the same ip. I even tried manually assigning the wireless ip to 192.168.0.2 but that doesn't help. It seems I've hit another dead end.

      --- In nslu2-linux@yahoogroups.com, whaly <whaly.ml@...> wrote:
      >
      > Hi,
      >
      > You can share internet in windows xp, follow :
      > http://support.microsoft.com/kb/306126
      >
      > Then on the nslu2 network settings, add 192.168.1.66 for the gateway.
      >
      > Good luck,
      > Whaly
      >
      > On Thu, Jun 25, 2009 at 11:08 AM, Richard<jut.shanahan@...> wrote:
      > >
      > >
      > > I'm sharing a wireless connection with my neighbor. This router is upstairs
      > > and I cannot plug my slug into it. Therefore I have an ethernet cable going
      > > from my pc (win xp) to the slug directly. I also have a wireless adapter
      > > that I get internet access through.
      > >
      > > Now I was able to see the web page for the slug just fine and uploaded the
      > > debian installer image fine as well. I am now at the beginning of the debian
      > > install where it's asking for a suitable mirror to use for downloading
      > > packages. But as you may have guessed, the slug, and thus the debian
      > > installer cannot see the outside world (the internet). Can someone suggest
      > > how to circumvent this problem? I tried setting up a web proxy server and
      > > letting the debian installer know about it, but that was a no go :(
      > >
      > > My ip's are:
      > >
      > > wireless adapter: 192.168.0.101
      > > pc ethernet: 192.168.1.66
      > > slug: 192.168.1.77
      > >
      > > Any suggestions would be wonderful!
      > >
      > >
      >
    • David Wurz
      try 10.0.0.1 for slug, 10.0.0.2 for slugs port on PC then it should work. Ah, good idea. However I tried to share my wireless with my hardwired ethernet
      Message 2 of 8 , Jun 25, 2009
      • 0 Attachment
        try 10.0.0.1 for slug, 10.0.0.2 for slugs port on PC then it should work.
         

        Ah, good idea. However I tried to share my wireless with my hardwired ethernet connection but windows ICS won't let me because it tries to change the wireless ip to 192.168.0.1, but my gateway has the same ip. I even tried manually assigning the wireless ip to 192.168.0.2 but that doesn't help. It seems I've hit another dead end.

        --- In nslu2-linux@ yahoogroups. com, whaly <whaly.ml@.. .> wrote:

        >
        > Hi,
        >
        > You
        can share internet in windows xp, follow :
        >
        href="http://support.microsoft.com/kb/306126">http://support. microsoft. com/kb/306126
        >
        > Then on the nslu2 network settings, add 192.168.1.66 for the
        gateway.
        >
        > Good luck,
        > Whaly
        >
        > On Thu, Jun
        25, 2009 at 11:08 AM, Richard<jut. shanahan@ ...> wrote:
        > >
        > >
        > > I'm sharing a wireless connection with my
        neighbor. This router is upstairs
        > > and I cannot plug my slug into
        it. Therefore I have an ethernet cable going
        > > from my pc (win xp) to
        the slug directly. I also have a wireless adapter
        > > that I get
        internet access through.
        > >
        > > Now I was able to see the web
        page for the slug just fine and uploaded the
        > > debian installer image
        fine as well. I am now at the beginning of the debian
        > > install where
        it's asking for a suitable mirror to use for downloading
        > > packages.
        But as you may have guessed, the slug, and thus the debian
        > >
        installer cannot see the outside world (the internet). Can someone suggest
        > > how to circumvent this problem? I tried setting up a web
        proxy server and
        > > letting the debian installer know about it, but
        that was a no go :(
        > >
        > > My ip's are:
        > >
        > > wireless adapter: 192.168.0.101
        > > pc ethernet:
        192.168.1.66
        > > slug: 192.168.1.77
        > >
        > > Any
        suggestions would be wonderful!
        > >
        > >
        >

      • Richard
        Is it possible to change the slug s ip after the debian installer has been initiated? I tried opening a command shell and editing /etc/network/interfaces with
        Message 3 of 8 , Jun 25, 2009
        • 0 Attachment
          Is it possible to change the slug's ip after the debian installer has been initiated?

          I tried opening a command shell and editing /etc/network/interfaces with a new ip, and then rebooting the slug, but that didn't work.


          --- In nslu2-linux@yahoogroups.com, "David Wurz" <dwwurz@...> wrote:
          >
          > try 10.0.0.1 for slug, 10.0.0.2 for slugs port on PC then it should work.
          >
          >
          >
          >
          > Ah, good idea. However I tried to share my wireless with my hardwired
          > ethernet connection but windows ICS won't let me because it tries to change
          > the wireless ip to 192.168.0.1, but my gateway has the same ip. I even tried
          > manually assigning the wireless ip to 192.168.0.2 but that doesn't help. It
          > seems I've hit another dead end.
          >
          > --- In nslu2-linux@yahoogroups.com, whaly <whaly.ml@> wrote:
          > >
          > > Hi,
          > >
          > > You can share internet in windows xp, follow :
          > > http://support.microsoft.com/kb/306126
          > >
          > > Then on the nslu2 network settings, add 192.168.1.66 for the gateway.
          > >
          > > Good luck,
          > > Whaly
          > >
          > > On Thu, Jun 25, 2009 at 11:08 AM, Richard<jut.shanahan@> wrote:
          > > >
          > > >
          > > > I'm sharing a wireless connection with my neighbor. This router is
          > > > upstairs
          > > > and I cannot plug my slug into it. Therefore I have an ethernet cable
          > > > going
          > > > from my pc (win xp) to the slug directly. I also have a wireless adapter
          > > > that I get internet access through.
          > > >
          > > > Now I was able to see the web page for the slug just fine and uploaded
          > > > the
          > > > debian installer image fine as well. I am now at the beginning of the
          > > > debian
          > > > install where it's asking for a suitable mirror to use for downloading
          > > > packages. But as you may have guessed, the slug, and thus the debian
          > > > installer cannot see the outside world (the internet). Can someone
          > > > suggest
          > > > how to circumvent this problem? I tried setting up a web proxy server
          > > > and
          > > > letting the debian installer know about it, but that was a no go :(
          > > >
          > > > My ip's are:
          > > >
          > > > wireless adapter: 192.168.0.101
          > > > pc ethernet: 192.168.1.66
          > > > slug: 192.168.1.77
          > > >
          > > > Any suggestions would be wonderful!
          > > >
          > > >
          > >
          >
        • Richard
          Yeah I tried that but I m still unable to share the wireless internet connection with the slug via win xp ICS. ICS requires the use of 192.168.0.1, but the
          Message 4 of 8 , Jun 25, 2009
          • 0 Attachment
            Yeah I tried that but I'm still unable to share the wireless internet connection with the slug via win xp ICS. ICS requires the use of 192.168.0.1, but the router already uses this IP as it's gateway. I have no access to the wireless router btw.

            Can you tell me why this approach doesn't work: I setup a web proxy server to listen on 10.0.0.1, and then I tell the debian installer to use this proxy for getting packages, but it doesn't work.


            --- In nslu2-linux@yahoogroups.com, "David Wurz" <dwwurz@...> wrote:
            >
            > try 10.0.0.1 for slug, 10.0.0.2 for slugs port on PC then it should work.
            >
            >
            >
            >
            > Ah, good idea. However I tried to share my wireless with my hardwired
            > ethernet connection but windows ICS won't let me because it tries to change
            > the wireless ip to 192.168.0.1, but my gateway has the same ip. I even tried
            > manually assigning the wireless ip to 192.168.0.2 but that doesn't help. It
            > seems I've hit another dead end.
            >
            > --- In nslu2-linux@yahoogroups.com, whaly <whaly.ml@> wrote:
            > >
            > > Hi,
            > >
            > > You can share internet in windows xp, follow :
            > > http://support.microsoft.com/kb/306126
            > >
            > > Then on the nslu2 network settings, add 192.168.1.66 for the gateway.
            > >
            > > Good luck,
            > > Whaly
            > >
            > > On Thu, Jun 25, 2009 at 11:08 AM, Richard<jut.shanahan@> wrote:
            > > >
            > > >
            > > > I'm sharing a wireless connection with my neighbor. This router is
            > > > upstairs
            > > > and I cannot plug my slug into it. Therefore I have an ethernet cable
            > > > going
            > > > from my pc (win xp) to the slug directly. I also have a wireless adapter
            > > > that I get internet access through.
            > > >
            > > > Now I was able to see the web page for the slug just fine and uploaded
            > > > the
            > > > debian installer image fine as well. I am now at the beginning of the
            > > > debian
            > > > install where it's asking for a suitable mirror to use for downloading
            > > > packages. But as you may have guessed, the slug, and thus the debian
            > > > installer cannot see the outside world (the internet). Can someone
            > > > suggest
            > > > how to circumvent this problem? I tried setting up a web proxy server
            > > > and
            > > > letting the debian installer know about it, but that was a no go :(
            > > >
            > > > My ip's are:
            > > >
            > > > wireless adapter: 192.168.0.101
            > > > pc ethernet: 192.168.1.66
            > > > slug: 192.168.1.77
            > > >
            > > > Any suggestions would be wonderful!
            > > >
            > > >
            > >
            >
          • Richard
            Update: I was able to get the debian installer working, aka got it to find a mirror successfuly, aka got the installer internet access. Here s what I did for
            Message 5 of 8 , Jun 26, 2009
            • 0 Attachment
              Update:

              I was able to get the debian installer working, aka got it to find a mirror successfuly, aka got the installer internet access. Here's what I did for any future users with the same problem.

              First of all, to recap, here's my setup and situation. I'm running win xp. I've connecting to someone's router via a wireless connection. I don't have access to that router, so i cannot plug my slug into i (which would make life easy). My computer has wireless adapter and a wired ethernet connection. My goal is to load debian on the slug via the wired connection. To do so I need to ssh into the slug and the slug needs internet access.

              background info:
              My wireless adapter ip is 192.168.0.2

              Steps taken:
              1. Using the Linksys web interface, assign the slug a fixed ip that is on the same subnet as your wireless. For me I gave the slug an ip of 192.168.0.77, which is similar to the default. Subnet mask of 255.255.255.0 is good to go. No need to enter a gateway.

              2. Also assign a manual ip to your wired connection on the same subnet. I used 192.168.0.66. To confirm your slug and wired connection are on the same wave length, go to http://192.168.0.77 and make sure the linksys web interface comes up.

              3. Follow instructions here to get the debian on the slug:
              http://www.cyrius.com/debian/nslu2/install.html

              4. SSH into the slug with Putty using the ip you assigned it; 192.168.0.77

              5. Proceed through the install sequence. At some point the installer will ask what mirror to use. And then it'll ask if you want to use a web proxy server, which you will.

              6. Install a web proxy server on your computer. I used ccproxy:
              http://download.cnet.com/CC-Proxy-Server/3000-2155_4-10062250.html
              Once installed, choose Options. From the "Local Address" drop down, choose the wired ip (192.168.0.66). Note the port number used for http (808 by default)

              7. Back to the debian installer. For a http proxy, tell it to use:
              http://192.168.0.66:808

              You should be good to go now. Note that some mirrors don't have right packages for the slug, so just try different ones until you get a hit.


              1.
            • hvontres
              ... I think you want to do something like this: http://www.nanodocumet.com/?p=14 ICS is just a NAT setup. Unfortunately, M$ in their inifinite wisdom has set
              Message 6 of 8 , Jun 26, 2009
              • 0 Attachment
                --- In nslu2-linux@yahoogroups.com, "Richard" <jut.shanahan@...> wrote:
                >
                > Yeah I tried that but I'm still unable to share the wireless internet connection with the slug via win xp ICS. ICS requires the use of 192.168.0.1, but the router already uses this IP as it's gateway. I have no access to the wireless router btw.



                I think you want to do something like this:

                http://www.nanodocumet.com/?p=14

                ICS is just a NAT setup. Unfortunately, M$ in their inifinite wisdom has set it up to use 192.168.0.1 for the default, the same as most wireless routers or even DSL modems :(
              Your message has been successfully submitted and would be delivered to recipients shortly.