Loading ...
Sorry, an error occurred while loading the content.
 

Re: [nslu2-linux] NSLU2 stucked in "Assign mode"

Expand Messages
  • Rod Whitby
    Have a look at the upslug2 tool. I seem to remember it being able to handle assign mode. -- Rod ... From: xenshs Date: Tuesday, Jun 16,
    Message 1 of 3 , Jun 18, 2009
      Have a look at the upslug2 tool.
      I seem to remember it being able to handle assign mode.
      -- Rod

      -----Original Message-----
      From: "xenshs" <xenshs@...>
      Date: Tuesday, Jun 16, 2009 11:47 pm
      Subject: [nslu2-linux] NSLU2 stucked in "Assign mode"
      To: nslu2-linux@yahoogroups.comReply-To: nslu2-linux@yahoogroups.com

      Hello,
      >
      >a friend of mine gave me his "dead" nslu2 NAS. When I power it on, the "Ready/Status" led first shows up and then start blinking.
      >
      >I didn't know what to do so I "created" a cheap TTL to RS232 converter and added a serial port (http://www.nslu2-linux.org/wiki/HowTo/AddASerialPort).
      >
      >Now I'm able to monitor my NSLU2 from its serial port and here's the output of redboot:
      >
      >------------------
      >+Ethernet eth0: MAC address 00:c0:02:01:01:02
      >IP: 192.168.0.1/255.255.255.0, Gateway: 192.168.0.1
      >Default server: 0.0.0.0, DNS server IP: 0.0.0.0
      >
      >RedBoot(tm) bootstrap and debug environment [ROMRAM]
      >Red Hat certified release, version 1.92 - built 15:16:07, Feb 3 2004
      >
      >Platform: IXDP425 Development Platform (XScale)
      >Copyright (C) 2000, 2001, 2002, Red Hat, Inc.
      >
      >RAM: 0x00000000-0x02000000, 0x000723a0-0x01ff3000 available
      >FLASH: 0x50000000 - 0x50800000, 64 blocks of 0x00020000 bytes each.
      >== Executing boot script in 2.000 seconds - enter ^C to abort
      >RedBoot> boot;exec 0x01d00000
      >have eRcOmM
      >no node address
      >Assign mode
      >------------------
      >
      >The device is always stucked in assign mode I don't know what to do.
      >
      >I tried reflashing the firmware with official images without success, I also tried to reinstall it completely from a jtag interface but it's always stucked at this point.
      >
      >I already read the whole nslu2-linux.org website and tried a lots of things wo success.
      >
      >Hope to have more answers here :)
      >
      >Thanks, Romain
      >
      >
      >
      >------------------------------------
      >
      >Yahoo! Groups Links
      >
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.