Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Re: Looking for email client or server

Expand Messages
  • John
    ... If the problem is with procmail and not fetchmail, did you check procmail s log? You can also turn on verbose logging for better diagnostics However, also
    Message 1 of 7 , May 11 1:49 PM
    • 0 Attachment
      On Mon, May 11, 2009 at 07:42:27PM -0000, adamwaller_333 wrote:
      > LOGFILE=$PMDIR/procmail.log
      > LOGABSTRACT=NONE
      > SHELL=/bin/sh
      > #VERBOSE=NONE

      If the problem is with procmail and not fetchmail, did you
      check procmail's log? You can also turn on verbose logging for
      better diagnostics

      However, also check:

      On Mon, May 11, 2009 at 07:42:27PM -0000, adamwaller_333 wrote:
      > PATH=$HOME/usr/bin:/usr/local/bin:/opt/bin
      > [snip]
      >
      > :0 c
      > * ^From:.*myphonenumber@...
      > * ^Subject: Test
      > | { cd ~/home/scripts ; test }
      >
      > The script that i want to run in this case is "/home/scripts/test"
      > I can exicute the script itself in the command line and it works just fine.

      Note that "/home/scripts/test" is not in the path you
      specified. If this is the only problem, the solution might be as
      simple as:

      :0 c
      * ^From:.*myphonenumber@...
      * ^Subject: Test
      | /home/scripts/test

      However, note that you cd to "~/home/scripts". If you are
      running as root, then that directory expands (see shell documents
      for "tilda expansion") to "/root/home/scripts" and not
      "/home/scripts" where you said "test" resided. Does
      "/root/home/scripts" exist? If not, the shell would generate an
      error message when cd'ing to it.

      Also, examine the path:

      > PATH=$HOME/usr/bin:/usr/local/bin:/opt/bin

      The first element of the path, if you are running as root, expands
      ("variable expansion") to /root/usr/bin which probably doesn't
      exist. You likely wanted

      PATH=$HOME/scripts:/usr/bin:/usr/local/bin:/opt/bin

      or, maybe:

      PATH=/home/scripts:/usr/bin:/usr/local/bin:/opt/bin

      If you also want the path to include the current directory (i.e.
      whatever you have cd'd into), then add a final colon:

      PATH=$HOME/scripts:/usr/bin:/usr/local/bin:/opt/bin:

      John
    • adamwaller_333
      THANK YOU A LOT. That helped a lot. There is no /root/home but there is a /root and /home . I copied the .procmail and the .fetchamil to /root just in
      Message 2 of 7 , May 11 11:55 PM
      • 0 Attachment
        THANK YOU A LOT.
        That helped a lot. There is no "/root/home" but there is a "/root" and "/home". I copied the .procmail and the .fetchamil to /root just in case that would help make things easier, had them in the /home. I also fixed the PATH line. Works like I had hoped it would.



        --- In nslu2-linux@yahoogroups.com, John <jl.050877@...> wrote:
        >
        > On Mon, May 11, 2009 at 07:42:27PM -0000, adamwaller_333 wrote:
        > > LOGFILE=$PMDIR/procmail.log
        > > LOGABSTRACT=NONE
        > > SHELL=/bin/sh
        > > #VERBOSE=NONE
        >
        > If the problem is with procmail and not fetchmail, did you
        > check procmail's log? You can also turn on verbose logging for
        > better diagnostics
        >
        > However, also check:
        >
        > On Mon, May 11, 2009 at 07:42:27PM -0000, adamwaller_333 wrote:
        > > PATH=$HOME/usr/bin:/usr/local/bin:/opt/bin
        > > [snip]
        > >
        > > :0 c
        > > * ^From:.*myphonenumber@...
        > > * ^Subject: Test
        > > | { cd ~/home/scripts ; test }
        > >
        > > The script that i want to run in this case is "/home/scripts/test"
        > > I can exicute the script itself in the command line and it works just fine.
        >
        > Note that "/home/scripts/test" is not in the path you
        > specified. If this is the only problem, the solution might be as
        > simple as:
        >
        > :0 c
        > * ^From:.*myphonenumber@...
        > * ^Subject: Test
        > | /home/scripts/test
        >
        > However, note that you cd to "~/home/scripts". If you are
        > running as root, then that directory expands (see shell documents
        > for "tilda expansion") to "/root/home/scripts" and not
        > "/home/scripts" where you said "test" resided. Does
        > "/root/home/scripts" exist? If not, the shell would generate an
        > error message when cd'ing to it.
        >
        > Also, examine the path:
        >
        > > PATH=$HOME/usr/bin:/usr/local/bin:/opt/bin
        >
        > The first element of the path, if you are running as root, expands
        > ("variable expansion") to /root/usr/bin which probably doesn't
        > exist. You likely wanted
        >
        > PATH=$HOME/scripts:/usr/bin:/usr/local/bin:/opt/bin
        >
        > or, maybe:
        >
        > PATH=/home/scripts:/usr/bin:/usr/local/bin:/opt/bin
        >
        > If you also want the path to include the current directory (i.e.
        > whatever you have cd'd into), then add a final colon:
        >
        > PATH=$HOME/scripts:/usr/bin:/usr/local/bin:/opt/bin:
        >
        > John
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.