Loading ...
Sorry, an error occurred while loading the content.

Re: [Debian] [lenny] apt-get update problem

Expand Messages
  • firestorm1325
    Hi, Sorry to bump an old thread but I ran into the same problem trying to install Lenny as well. When installing using the directions on
    Message 1 of 4 , May 4, 2009
      Hi, Sorry to bump an old thread but I ran into the same problem trying to install Lenny as well. When installing using the directions on http://www.cyrius.com/debian/nslu2/install.html I could not get past downloading Packages.gz because the installer said it was corrupt. I tried many different mirrors all with the same result. So I went the "Unpack tar ball route" (http://www.cyrius.com/debian/nslu2/unpack.html - thanks, Martin!) and I now have a working Lenny installation but I cannot apt-get update. When I do, I get the same sort of errors that opt12001 was getting:

      # apt-get update
      Get:1 http://security.debian.org lenny/updates Release.gpg [197B]
      Get:2 http://security.debian.org lenny/updates Release [40.8kB]
      Get:3 http://ftp.at.debian.org lenny Release.gpg [394B]
      Get:4 http://ftp.at.debian.org lenny Release [73.6kB]
      Get:5 http://security.debian.org lenny/updates/main Packages [109kB]
      Get:6 http://ftp.at.debian.org lenny/main Packages [6706kB]
      Get:7 http://security.debian.org lenny/updates/main Sources [31.8kB]
      Get:8 http://ftp.at.debian.org lenny/main Sources [2980kB]
      84% [6 Packages gzip 23490560] [8 Sources 1402522/2980kB 47%] 88.5kB/s 17s
      gzip: stdin: invalid compressed data--crc error

      gzip: stdin: invalid compressed data--length error
      Err http://ftp.at.debian.org lenny/main Packages
      Sub-process gzip returned an error code (1)
      Fetched 9941kB in 2min23s (69.5kB/s)
      W: Failed to fetch http://security.debian.org/dists/lenny/updates/main/binary-armel/Packages.gz Hash Sum mismatch

      W: Failed to fetch http://ftp.at.debian.org/debian/dists/lenny/main/binary-armel/Packages.gz Sub-process gzip returned an error code (1)

      E: Some index files failed to download, they have been ignored, or old ones used instead.


      I have not been able to solve this and it prevents me from being able to use the system. I tried `apt-get dist-upgrade` anyway, but the kernel flash seems to have gone bad (or I'm missing a step) because the slug couldn't reboot and I had to unpack the tarball and re-flash the original Lenny kernel.

      > I eventually solved my problem trying one more time the clean /var/lib/apt/lists (which I did several times before) and trying again with your original mirror and it worked !
      > I do not know what was the problem and I do not dare to "apt-get update" again for the moment, nor to "apt-get upgrade"...

      I tried this route also but it does not seem to be working either. Did you find out what was wrong? Does your apt-get work now? How can I fix this?


    Your message has been successfully submitted and would be delivered to recipients shortly.