Loading ...
Sorry, an error occurred while loading the content.

Squid on SlugOS 3.10 & constant disk access

Expand Messages
  • obi_jan
    I have recently installed Squid (from the opt feed) on my NSLU2 with SlugOS 3.10. I then noticed that my Maxtor OneTouch II didn t spin down anymore due to
    Message 1 of 1 , Apr 5, 2009
    • 0 Attachment
      I have recently installed Squid (from the opt feed) on my NSLU2 with SlugOS 3.10. I then noticed that my Maxtor OneTouch II didn't spin down anymore due to frequent disk access. I then did the following:

      1) Relocated all Squid log files to a ramfs volume (which I was already using for all other log files). This ramfs volume is located at /var/log.

      2) Changed the squid.conf to pretty much disable the disk cache by using the following settings:

      no_cache deny all
      maximum_object_size 0 KB
      cache_dir ufs /opt/var/squid/cache 1 16 256 read-only
      access_log /var/log/squid/access.log squid
      cache_log /var/log/squid/cache.log
      cache_store_log /var/log/squid/store.log

      Note that I was not able to nullify the cache_dir instruction by saying "cache_dir null /dev/null" or something like that, as it caused an abnormal termination. So I just set it to only use 1MB and 'read-only', but that still doesn't help.

      Anyone have any suggestions? I am pretty sure that it is Squid that is causing the disk access, as stopping the process also stops any disk activity.

      Thanks
      -J
    Your message has been successfully submitted and would be delivered to recipients shortly.