Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Unslung 6.10 amule 2.1.3 connect to Kad

Expand Messages
  • Sébastien Lorquet
    Are you sure UDP sockets have a LISTEN state? They re connectionless, so the best they can do is being bound to a local port, waiting for datagrams :)
    Message 1 of 4 , Apr 2 1:30 PM
    View Source
    • 0 Attachment
      Are you sure UDP sockets have a LISTEN state? They're connectionless, so the best they can do is being bound to a local port, waiting for datagrams :)


      On Thu, Apr 2, 2009 at 10:09 PM, gopher3_8 <gopher38@...> wrote:
      Hello,

      I'm trying to get aMule 2.1.3 running on Unslung 6.10.  I've made the application and it ALMOST runs.  I can launch the app; log into amuleweb; it connects with a high id; I can do a search and get results; but I can't download anything because Kad doesn't connect. Actually, it connects, but says it's firewalled, and then eventually disconnects.  Also, the file that I want to download shows multiple sources at first, but then they disappear (I imagine that they time out).  I can't figure out why.

      I know I've got the ports forwarded correctly on my router.

      I thought it might be the server.met or nodes.dat file, so I took those from my windows laptop (which has eMule and works great on the same router with the same ports) and copied them to the Slug, but that didn't work either.

      I read some posts about ipfiltering sometimes being a problem, so I turned that off and deleted those files. No luck.

      I read some posts about iptables being an issue sometimes, but apparently Unslung doesn't use them (I don't know much about iptables).

      My guess (just a guess) is that it's a udp port issue on the Slug side.  Does anyone have any insights on this?  Or did anyone using aMule see this problem and fix it?  Please let me know how.

      One last thing:  when I do "netstat -l" on the Slug, I see all the ports listed (as 0.0.0.0:4662 etc), and on the TCP ports I see a big "LISTEN" next to it.  For UDP, I see the ports that I gave to aMule, but it doesn't say "LISTEN" next to it (but it doesn't say listen for any of the UDP ports).

      Thanks.



      ------------------------------------

      Yahoo! Groups Links

      <*> To visit your group on the web, go to:
         http://groups.yahoo.com/group/nslu2-linux/

      <*> Your email settings:
         Individual Email | Traditional

      <*> To change settings online go to:
         http://groups.yahoo.com/group/nslu2-linux/join
         (Yahoo! ID required)

      <*> To change settings via email:
         mailto:nslu2-linux-digest@yahoogroups.com
         mailto:nslu2-linux-fullfeatured@yahoogroups.com

      <*> To unsubscribe from this group, send an email to:
         nslu2-linux-unsubscribe@yahoogroups.com

      <*> Your use of Yahoo! Groups is subject to:
         http://docs.yahoo.com/info/terms/


    • gopher3_8
      No, I m not sure. I don t know anything about UDP sockets. So I guess you re saying I can eliminate that as a culprit, which is good to know. Thanks. But I
      Message 2 of 4 , Apr 2 2:43 PM
      View Source
      • 0 Attachment
        No, I'm not sure. I don't know anything about UDP sockets. So I guess you're saying I can eliminate that as a culprit, which is good to know. Thanks.

        But I still have KAD firewalled.

        --- In nslu2-linux@yahoogroups.com, Sébastien Lorquet <squalyl@...> wrote:
        >
        > Are you sure UDP sockets have a LISTEN state? They're connectionless, so the
        > best they can do is being bound to a local port, waiting for datagrams :)
        >
        >
        > On Thu, Apr 2, 2009 at 10:09 PM, gopher3_8 <gopher38@...> wrote:
        >
        > > Hello,
        > >
        > > I'm trying to get aMule 2.1.3 running on Unslung 6.10. I've made the
        > > application and it ALMOST runs. I can launch the app; log into amuleweb; it
        > > connects with a high id; I can do a search and get results; but I can't
        > > download anything because Kad doesn't connect. Actually, it connects, but
        > > says it's firewalled, and then eventually disconnects. Also, the file that
        > > I want to download shows multiple sources at first, but then they disappear
        > > (I imagine that they time out). I can't figure out why.
        > >
        > > I know I've got the ports forwarded correctly on my router.
        > >
        > > I thought it might be the server.met or nodes.dat file, so I took those
        > > from my windows laptop (which has eMule and works great on the same router
        > > with the same ports) and copied them to the Slug, but that didn't work
        > > either.
        > >
        > > I read some posts about ipfiltering sometimes being a problem, so I turned
        > > that off and deleted those files. No luck.
        > >
        > > I read some posts about iptables being an issue sometimes, but apparently
        > > Unslung doesn't use them (I don't know much about iptables).
        > >
        > > My guess (just a guess) is that it's a udp port issue on the Slug side.
        > > Does anyone have any insights on this? Or did anyone using aMule see this
        > > problem and fix it? Please let me know how.
        > >
        > > One last thing: when I do "netstat -l" on the Slug, I see all the ports
        > > listed (as 0.0.0.0:4662 etc), and on the TCP ports I see a big "LISTEN"
        > > next to it. For UDP, I see the ports that I gave to aMule, but it doesn't
        > > say "LISTEN" next to it (but it doesn't say listen for any of the UDP
        > > ports).
        > >
        > > Thanks.
        > >
        > >
        > >
        > > ------------------------------------
        > >
        > > Yahoo! Groups Links
        > >
        > >
        > >
        > >
        >
      • Sébastien Lorquet
        Yes that s what I m saying. Totally random notice, maybe your firewall is not forwarding UDP packets correctly. To be honest I never got KAD working (on
        Message 3 of 4 , Apr 2 10:23 PM
        View Source
        • 0 Attachment
          Yes that's what I'm saying.

          Totally 'random' notice, maybe your firewall is not forwarding UDP packets correctly.
          To be honest I never got KAD working (on windows with emule). But I was high id on emule.
          I've a linksys wrt54g+original firmware

          On Thu, Apr 2, 2009 at 11:43 PM, gopher3_8 <gopher38@...> wrote:
          No, I'm not sure.  I don't know anything about UDP sockets.  So I guess you're saying I can eliminate that as a culprit, which is good to know.  Thanks.

          But I still have KAD firewalled.

          --- In nslu2-linux@yahoogroups.com, Sébastien Lorquet <squalyl@...> wrote:
          >
          > Are you sure UDP sockets have a LISTEN state? They're connectionless, so the
          > best they can do is being bound to a local port, waiting for datagrams :)
          >
          >
          > On Thu, Apr 2, 2009 at 10:09 PM, gopher3_8 <gopher38@...> wrote:
          >
          > > Hello,
          > >
          > > I'm trying to get aMule 2.1.3 running on Unslung 6.10.  I've made the
          > > application and it ALMOST runs.  I can launch the app; log into amuleweb; it
          > > connects with a high id; I can do a search and get results; but I can't
          > > download anything because Kad doesn't connect. Actually, it connects, but
          > > says it's firewalled, and then eventually disconnects.  Also, the file that
          > > I want to download shows multiple sources at first, but then they disappear
          > > (I imagine that they time out).  I can't figure out why.
          > >
          > > I know I've got the ports forwarded correctly on my router.
          > >
          > > I thought it might be the server.met or nodes.dat file, so I took those
          > > from my windows laptop (which has eMule and works great on the same router
          > > with the same ports) and copied them to the Slug, but that didn't work
          > > either.
          > >
          > > I read some posts about ipfiltering sometimes being a problem, so I turned
          > > that off and deleted those files. No luck.
          > >
          > > I read some posts about iptables being an issue sometimes, but apparently
          > > Unslung doesn't use them (I don't know much about iptables).
          > >
          > > My guess (just a guess) is that it's a udp port issue on the Slug side.
          > >  Does anyone have any insights on this?  Or did anyone using aMule see this
          > > problem and fix it?  Please let me know how.
          > >
          > > One last thing:  when I do "netstat -l" on the Slug, I see all the ports
          > > listed (as 0.0.0.0:4662 etc), and on the TCP ports I see a big "LISTEN"
          > > next to it.  For UDP, I see the ports that I gave to aMule, but it doesn't
          > > say "LISTEN" next to it (but it doesn't say listen for any of the UDP
          > > ports).
          > >
          > > Thanks.
          > >
          > >
          > >
          > > ------------------------------------
          > >
          > > Yahoo! Groups Links
          > >
          > >
          > >
          > >
          >




          ------------------------------------

          Yahoo! Groups Links

          <*> To visit your group on the web, go to:
             http://groups.yahoo.com/group/nslu2-linux/

          <*> Your email settings:
             Individual Email | Traditional

          <*> To change settings online go to:
             http://groups.yahoo.com/group/nslu2-linux/join
             (Yahoo! ID required)

          <*> To change settings via email:
             mailto:nslu2-linux-digest@yahoogroups.com
             mailto:nslu2-linux-fullfeatured@yahoogroups.com

          <*> To unsubscribe from this group, send an email to:
             nslu2-linux-unsubscribe@yahoogroups.com

          <*> Your use of Yahoo! Groups is subject to:
             http://docs.yahoo.com/info/terms/


        Your message has been successfully submitted and would be delivered to recipients shortly.