Loading ...
Sorry, an error occurred while loading the content.

Re: SlugOS 5.3-alpha -- need two more field build and install reports

Expand Messages
  • reuter.rudolf
    ... Thanks for the hint Brian. I tried it with the following result: root@LKG649492:~/ipk# opkg install
    Message 1 of 12 , Feb 28 9:05 PM
    • 0 Attachment
      --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@...> wrote:
      >
      > With slugos 5.3-alpha, you should use opkg (/usr/bin/opkg) for OE
      > built packages. Optware still uses ipkg.
      >
      > The error message you got may have something to do with the fact that
      > by default opkg configured /etc/opkg/arch.conf to include nslu2be,
      > while ipkg does not.
      >
      > -Brian
      >
      Thanks for the hint Brian. I tried it with the following result:
      root@LKG649492:~/ipk# opkg install
      ./kernel-module-pl2303_2.6.27.8\+svnr1085-r2_nslu2be.ipk
      Multiple packages (kernel-module-pl2303 and kernel-module-pl2303)
      providing same name marked HOLD or PREFER. Using latest.
      Installing kernel-module-pl2303 (2.6.27.8+svnr1085-r2) to root...
      Collected errors:
      * Package kernel-module-pl2303 md5sum mismatch. Either the opkg or
      the package index are corrupt. Try 'opkg update'.

      Now it becomes even more confusing for me. I thought the local
      downloaded .ipk package installs without external index?

      Regards, Rudolf

      > --- In nslu2-linux@yahoogroups.com, "reuter.rudolf" <reuterru@>
      > wrote:
      > >
      > > --- In nslu2-linux@yahoogroups.com, "Mike (mwester)" <mwester@>
      > wrote:
      > > >
      > > > reuter.rudolf wrote:
      > > >
      > > > > ...If I use the full name of the package the situation does
      > > > > not change:
      > > > > root@LKG649492:~/ipk# ipkg install
      > > > >
      > > > > Clearing state_want and state_flag for pkg=kernel-module-pl2303
      > > > > (arch_priority=0 flag=16 want=2)
      > > > > Nothing to be done
      > > > > An error ocurred, return value: 4.
      > > > > Collected errors:
      > > > > Cannot find package kernel-module-pl2303.
      > > > > Check the spelling or perhaps run 'ipkg update'
      > > >
      > > > Note the "./" at the front of the path -- that's what tells opkg
      > that
      > > > the argument is a local file, and not a package name to be looked
      > up:
      > > >
      > > > ipkg install ./kernel-module-pl2303_2.6.27.8\+svnr1085-
      > r2_nslu2be.ipk
      > > >
      > > > -Mike (mwester)
      > > >
      > > Sorry Mike, I did not realised the "./" in front of the package file
      > > in your posting. I thought it was a line break.
      > > I tried also that and it fails again, hmm?:
      > > root@LKG649492:~/ipk# ipkg install
      > > ./kernel-module-pl2303_2.6.27.8\+svnr1085-r2_nslu2be.ipk
      > > Clearing state_want and state_flag for pkg=kernel-module-pl2303
      > > (arch_priority=0 flag=16 want=2)
      > > Nothing to be done
      > > An error ocurred, return value: 4.
      > > Collected errors:
      > > Cannot find package kernel-module-pl2303.
      > > Check the spelling or perhaps run 'ipkg update'
      > >
      > > Regards, Rudolf
      > >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.