Loading ...
Sorry, an error occurred while loading the content.

ccxstream crashed immediately when XBMC tries to connect(Optware-DDWRT)

Expand Messages
  • rynax@y7mail.com
    I have a router(Asus WL500gP V2) running dd-wrt v24 preSP2 svn 11487 Mega build. Linux DD-WRT 2.4.37 #3109 Wed Jan 21 02:11:32 CET 2009 mips unknown BusyBox
    Message 1 of 3 , Jan 31, 2009
    • 0 Attachment
      I have a router(Asus WL500gP V2) running dd-wrt v24 preSP2 svn 11487
      Mega build.
      Linux DD-WRT 2.4.37 #3109 Wed Jan 21 02:11:32 CET 2009 mips unknown
      BusyBox v1.13.2 (2009-01-21 02:04:32 CET)

      Installed ccxstream from this feed
      http://ipkg.nslu2-linux.org/feeds/op...5-3_mipsel.ipk

      The ccxstream starts ok, but when XBMC(from Windows Vista,wireless)
      tries to connect(using XBMSP protocal), ccxstream crashed immediately.
      (The thread died).

      At the XBMC side, the log shows it can't open/retrive the folder
      content(because ccxstream crashed). I don't see any debug/log info at
      the ccxstream side. Is there a debug/log option for ccxstream?

      I don't know if this problems is caused by dd-wrt v24 preSP2, uclibc
      lib(uclibc-opt - 0.9.28-13 - micro C library for embedded Linux
      systems), Optware build, ccxstream or XBMC. Anyone can help me?

      Add: XBMC can play via smb without problems, the router runs Samba 3.
    • Scott Ruckh
      This is what you said rynax@y7mail.com ... I don t know if it helpful or not, but I can confirm I have ccxstream - 1.0.15-r2 optware package installed on NSLU2
      Message 2 of 3 , Feb 1 10:16 AM
      • 0 Attachment
        This is what you said rynax@...
        > Installed ccxstream from this feed
        > http://ipkg.nslu2-linux.org/feeds/op...5-3_mipsel.ipk
        >
        > The ccxstream starts ok, but when XBMC(from Windows Vista,wireless)
        > tries to connect(using XBMSP protocal), ccxstream crashed immediately.
        > (The thread died).

        I don't know if it helpful or not, but I can confirm I have ccxstream -
        1.0.15-r2 optware package installed on NSLU2 (SlugOS/BE). I have connected
        using XBMC on XBOX, Linux, Mac OS X, and Windows platforms.

        My ccxstream.conf looks like the following:
        #=======================================
        CHECK=YES
        RUNASUSER="ccxstrm"
        LISTENINTERFACE="aaa.bbb.ccc.ddd"
        FOLLOWSYMLINKS=YES
        SERVERCOMMENT="Slug"
        SHARES="videos=/public/videos music=/public/music photos=/public/photos"
        BIN="/usr/sbin/ccxstream"
        DIR="-"
        PIDFILE=/var/run/ccxstream.pid
        PARAMS="-f -F $PIDFILE -r $DIR -u $RUNASUSER"
        if test "$FOLLOWSYMLINKS" = "YES" ; then
        PARAMS="$PARAMS -L"
        fi
        if test "x$REMOTEPASS" != "x" ; then
        PARAMS="$PARAMS -P $REMOTEPASS"
        fi
        if test "x$LISTENINTERFACE" != "x" ; then
        PARAMS="$PARAMS -l $LISTENINTERFACE"
        fi
        for i in $SHARES ; do
        PARAMS="$PARAMS -S $i"
        done
        if test "x$SERVERCOMMENT" = "x" ; then
        SERVERCOMMENT="$(hostname -f)"
        fi
        #=======================================

        My start up init script looks like the following:
        #=======================================
        start() {
        . /etc/ccxstream.conf
        if [ "${CHECK}" = "YES" ] ; then
        echo -n "Starting ccXstream : "
        start-stop-daemon --start --quiet --exec ${BIN} \
        -- ${PARAMS} -C ${SERVERCOMMENT}
        status="$?"
        test ${status} = "0" && echo OK || echo FAILED
        return ${status}
        else
        echo "Please setup /etc/ccxstream.conf before starting ccXstream"
        return 1
        fi
        }
        stop() {
        echo -n "Stopping ccXstream : "
        start-stop-daemon --stop --quiet --pidfile /var/run/ccxstream.pid
        return $?
        }
        case $1 in
        start)
        start
        ;;
        stop)
        stop
        ;;
        restart)
        stop
        start
        ;;
        esac
        #=======================================
      • rynax@y7mail.com
        Thanks, I ll try your config file and see if it works
        Message 3 of 3 , Feb 4 5:50 PM
        • 0 Attachment
          Thanks, I'll try your config file and see if it works
        Your message has been successfully submitted and would be delivered to recipients shortly.