Loading ...
Sorry, an error occurred while loading the content.

Re: Illegal characters when copying files

Expand Messages
  • doll_oliver
    I was also struggling with the charsets and I came up with the ... ditto ... no, started with 2.x?, but at 3.2.6 these days. ... ditto (IMO this refers back to
    Message 1 of 8 , Jan 4, 2009
    • 0 Attachment
      I was also struggling with the charsets and I came up with the
      following settings which work(ed) the best for me:

      --- In nslu2-linux@yahoogroups.com, "rolandkbs" wrote:
      > I'm using Unslung(V2.3R63-uNSLUng-6.8-beta)

      ditto

      > with Samba(3.0.11)

      no, started with 2.x?, but at 3.2.6 these days.

      > [...] the Web-Configuration [...] is 'Western Europe/Latin 1(850)'

      ditto (IMO this refers back to the "dos charset"?)

      > In /etc/samba/smb.conf I have (generated by Unslung) the lines
      > unix charset = CP850
      > dos charset = CP850

      (my /etc/samba/smb.conf is a link to /unslung/smb.conf - and I guess
      for you, too?)

      I use dos charset = CP850 as well but for unix charset = UTF-8.
      With this the files get properly named via smb. Only thing is that the
      files (e.g. äöüß.txt) locally on the SLUG itself look as

      -rwxrw---- 1 od everyone 0 Jan 4 14:38 ├ñ├Â├╝├ƒ.txt

      Never made it to fix this, but as I use my slug as a NAS I don't care
      too much.
      --
      tnx & cheers
      Oliver
    • rincewindcook
      Thanks all for the replies, this problem is now solved, by very simply changing the Language Support in the web gui to Western Europe/Latin 1(850) as
      Message 2 of 8 , Jan 4, 2009
      • 0 Attachment
        Thanks all for the replies, this problem is now solved, by very simply
        changing the Language Support in the web gui to 'Western Europe/Latin
        1(850)' as suggested by Roland.
        The only reason i didn't change this setting in the first place was
        due to the recommendation on this wiki
        http://www.nslu2-linux.org/wiki/Unslung/UnslungLanguageSupport
        which says "If you can use the "USA (437)" setting, do so"
        Thanks again for all your help, particularly Roland and Oliver for
        giving me the fix.




        --- In nslu2-linux@yahoogroups.com, "doll_oliver" <doll_oliver@...> wrote:
        >
        > I was also struggling with the charsets and I came up with the
        > following settings which work(ed) the best for me:
        >
        > --- In nslu2-linux@yahoogroups.com, "rolandkbs" wrote:
        > > I'm using Unslung(V2.3R63-uNSLUng-6.8-beta)
        >
        > ditto
        >
        > > with Samba(3.0.11)
        >
        > no, started with 2.x?, but at 3.2.6 these days.
        >
        > > [...] the Web-Configuration [...] is 'Western Europe/Latin 1(850)'
        >
        > ditto (IMO this refers back to the "dos charset"?)
        >
        > > In /etc/samba/smb.conf I have (generated by Unslung) the lines
        > > unix charset = CP850
        > > dos charset = CP850
        >
        > (my /etc/samba/smb.conf is a link to /unslung/smb.conf - and I guess
        > for you, too?)
        >
        > I use dos charset = CP850 as well but for unix charset = UTF-8.
        > With this the files get properly named via smb. Only thing is that the
        > files (e.g. äöüß.txt) locally on the SLUG itself look as
        >
        > -rwxrw---- 1 od everyone 0 Jan 4 14:38
        ├ñ├Â├╝├ƒ.txt
        >
        > Never made it to fix this, but as I use my slug as a NAS I don't care
        > too much.
        > --
        > tnx & cheers
        > Oliver
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.