Loading ...
Sorry, an error occurred while loading the content.

Illegal characters when copying files

Expand Messages
  • rincewindcook
    When i m backing up my music collection to my slug, I am getting a problem with some of the file names getting corrupted. This mainly involve s the character
    Message 1 of 8 , Jan 2, 2009
    • 0 Attachment
      When i'm backing up my music collection to my slug, I am getting a
      problem with some of the file names getting corrupted. This mainly
      involve's the character ' and some non english characters. So for
      instance the mp3 file
      "08 - (I´d Be A) Legend In My Time.mp3"
      becomes
      "08 - (I_d Be A) Legend In My Time.mp3"
      I can rename this file on the slug no problem, so the problem seems to
      be in the transferring of the file. This happens on both a native and
      non native ext3 drive.
      I can work around this if i have to, but it would be really nice to
      solve or find a fix for it.
      Thanks in advance for any help/suggestion's anyone can offer.
    • rincewindcook
      ... I now think this may be a problem with samba, but being a slug/linux n00b i m not sure what to do next. I am running V2.3R63-uNSLUng-6.10-beta, Unslung to
      Message 2 of 8 , Jan 3, 2009
      • 0 Attachment
        --- In nslu2-linux@yahoogroups.com, "rincewindcook" <pawcook@...> wrote:
        >
        > When i'm backing up my music collection to my slug, I am getting a
        > problem with some of the file names getting corrupted. This mainly
        > involve's the character ' and some non english characters. So for
        > instance the mp3 file
        > "08 - (I´d Be A) Legend In My Time.mp3"
        > becomes
        > "08 - (I_d Be A) Legend In My Time.mp3"
        > I can rename this file on the slug no problem, so the problem seems to
        > be in the transferring of the file. This happens on both a native and
        > non native ext3 drive.
        > I can work around this if i have to, but it would be really nice to
        > solve or find a fix for it.
        > Thanks in advance for any help/suggestion's anyone can offer.
        >

        I now think this may be a problem with samba, but being a slug/linux
        n00b i'm not sure what to do next.
        I am running V2.3R63-uNSLUng-6.10-beta, Unslung to disk2, /dev/sda1
        this includes the default version of samba 3.0.11 and I have selected
        Language support USA(437).
        Is this possibly a matter of either upgrading samba or modifying smb.conf
        If anyone can give me any clues it would be much appreciated.
      • b_lindahl
        ... smb.conf ... I have the same problem with my slug. I m running slugos + optware and samba version 3.0.23c-r0. My problem goes beyond beeing only samba
        Message 3 of 8 , Jan 3, 2009
        • 0 Attachment
          --- In nslu2-linux@yahoogroups.com, "rincewindcook" <pawcook@...> wrote:
          >
          > --- In nslu2-linux@yahoogroups.com, "rincewindcook" <pawcook@> wrote:
          > >
          > > When i'm backing up my music collection to my slug, I am getting a
          > > problem with some of the file names getting corrupted. This mainly
          > > involve's the character ' and some non english characters. So for
          > > instance the mp3 file
          > > "08 - (I´d Be A) Legend In My Time.mp3"
          > > becomes
          > > "08 - (I_d Be A) Legend In My Time.mp3"
          > > I can rename this file on the slug no problem, so the problem seems to
          > > be in the transferring of the file. This happens on both a native and
          > > non native ext3 drive.
          > > I can work around this if i have to, but it would be really nice to
          > > solve or find a fix for it.
          > > Thanks in advance for any help/suggestion's anyone can offer.
          > >
          >
          > I now think this may be a problem with samba, but being a slug/linux
          > n00b i'm not sure what to do next.
          > I am running V2.3R63-uNSLUng-6.10-beta, Unslung to disk2, /dev/sda1
          > this includes the default version of samba 3.0.11 and I have selected
          > Language support USA(437).
          > Is this possibly a matter of either upgrading samba or modifying
          smb.conf
          > If anyone can give me any clues it would be much appreciated.
          >

          I have the same problem with my slug. I'm running slugos + optware and
          samba version 3.0.23c-r0.

          My problem goes beyond beeing only samba related or even a mount with
          wrong keymap. If I create a file/folder (on the device I'm booting
          from) with non-english characters these characters turnes up as
          question marks or underscore when doing a ls. When matching
          file/foldernames with tab completion it matches the same character
          though so it is stored but only show up erronous when listing folder
          content and such. Do you guys have the same issue or does it only
          appear when using samba? Any idea where to start looking for what
          could cause my problem?

          Regards
          Björn
        • Bob Cox
          In article , ... I know nothing about unslung, but your problem looks like a locales issue. You should be able to copy files with
          Message 4 of 8 , Jan 3, 2009
          • 0 Attachment
            In article <gjninc+2q49@...>,
            rincewindcook <pawcook@...> wrote:

            > --- In nslu2-linux@yahoogroups.com, "rincewindcook" <pawcook@...> wrote:
            >>
            >> When i'm backing up my music collection to my slug, I am getting a
            >> problem with some of the file names getting corrupted. This mainly
            >> involve's the character ' and some non english characters. So for
            >> instance the mp3 file
            >> "08 - (I´d Be A) Legend In My Time.mp3"
            >> becomes
            >> "08 - (I_d Be A) Legend In My Time.mp3"
            >> I can rename this file on the slug no problem, so the problem seems to
            >> be in the transferring of the file. This happens on both a native and
            >> non native ext3 drive.
            >> I can work around this if i have to, but it would be really nice to
            >> solve or find a fix for it.
            >> Thanks in advance for any help/suggestion's anyone can offer.
            >>
            >
            > I now think this may be a problem with samba, but being a slug/linux
            > n00b i'm not sure what to do next.
            > I am running V2.3R63-uNSLUng-6.10-beta, Unslung to disk2, /dev/sda1
            > this includes the default version of samba 3.0.11 and I have selected
            > Language support USA(437).
            > Is this possibly a matter of either upgrading samba or modifying smb.conf
            > If anyone can give me any clues it would be much appreciated.

            I know nothing about unslung, but your problem looks like a locales
            issue. You should be able to copy files with names including these
            characters to and from a Samba share. I suggest you google for
            something like 'filenames locales utf-8' and see if you can find any
            clues there.

            --
            Bob Cox. Stoke Gifford, near Bristol, UK.
            Debian on the NSLU2: http://bobcox.com/slug/
            Registered user #445000 with the Linux Counter - http://counter.li.org/
          • rincewindcook
            ... seems to ... smb.conf ... That s what i did Bob and came to the conclusion that the problem is indeed with samba or the config, I just don t know how to
            Message 5 of 8 , Jan 4, 2009
            • 0 Attachment
              --- In nslu2-linux@yahoogroups.com, Bob Cox <bobcox1955@...> wrote:
              >
              > In article <gjninc+2q49@...>,
              > rincewindcook <pawcook@...> wrote:
              >
              > > --- In nslu2-linux@yahoogroups.com, "rincewindcook" <pawcook@> wrote:
              > >>
              > >> When i'm backing up my music collection to my slug, I am getting a
              > >> problem with some of the file names getting corrupted. This mainly
              > >> involve's the character ' and some non english characters. So for
              > >> instance the mp3 file
              > >> "08 - (I´d Be A) Legend In My Time.mp3"
              > >> becomes
              > >> "08 - (I_d Be A) Legend In My Time.mp3"
              > >> I can rename this file on the slug no problem, so the problem
              seems to
              > >> be in the transferring of the file. This happens on both a native and
              > >> non native ext3 drive.
              > >> I can work around this if i have to, but it would be really nice to
              > >> solve or find a fix for it.
              > >> Thanks in advance for any help/suggestion's anyone can offer.
              > >>
              > >
              > > I now think this may be a problem with samba, but being a slug/linux
              > > n00b i'm not sure what to do next.
              > > I am running V2.3R63-uNSLUng-6.10-beta, Unslung to disk2, /dev/sda1
              > > this includes the default version of samba 3.0.11 and I have selected
              > > Language support USA(437).
              > > Is this possibly a matter of either upgrading samba or modifying
              smb.conf
              > > If anyone can give me any clues it would be much appreciated.
              >
              > I know nothing about unslung, but your problem looks like a locales
              > issue. You should be able to copy files with names including these
              > characters to and from a Samba share. I suggest you google for
              > something like 'filenames locales utf-8' and see if you can find any
              > clues there.
              >

              That's what i did Bob and came to the conclusion that the problem is
              indeed with samba or the config, I just don't know how to fix it, yet.
              I see you are running Debian, and I assume you have no such problems
              with your setup, I am thinking it will be beneficial for me in the
              long run to just bite the bullet and switch to Debian, bit worried to
              do that though as I have very limited linux knowledge although the
              support and info on the web is amazing. I notice you are over in Stoke
              Gifford, sometimes it's a small world, I live in Chipping Sodbury.





              > --
              > Bob Cox. Stoke Gifford, near Bristol, UK.
              > Debian on the NSLU2: http://bobcox.com/slug/
              > Registered user #445000 with the Linux Counter - http://counter.li.org/
              >
            • rolandkbs
              ... native and ... selected ... http://counter.li.org/ ... I m using Unslung(V2.3R63-uNSLUng-6.8-beta) with Samba(3.0.11) to backup my mp3-files with all those
              Message 6 of 8 , Jan 4, 2009
              • 0 Attachment
                --- In nslu2-linux@yahoogroups.com, "rincewindcook" <pawcook@...> wrote:
                >
                > --- In nslu2-linux@yahoogroups.com, Bob Cox <bobcox1955@> wrote:
                > >
                > > In article <gjninc+2q49@>,
                > > rincewindcook <pawcook@> wrote:
                > >
                > > > --- In nslu2-linux@yahoogroups.com, "rincewindcook" <pawcook@>
                wrote:
                > > >>
                > > >> When i'm backing up my music collection to my slug, I am getting a
                > > >> problem with some of the file names getting corrupted. This mainly
                > > >> involve's the character ' and some non english characters. So for
                > > >> instance the mp3 file
                > > >> "08 - (I´d Be A) Legend In My Time.mp3"
                > > >> becomes
                > > >> "08 - (I_d Be A) Legend In My Time.mp3"
                > > >> I can rename this file on the slug no problem, so the problem
                > seems to
                > > >> be in the transferring of the file. This happens on both a
                native and
                > > >> non native ext3 drive.
                > > >> I can work around this if i have to, but it would be really nice to
                > > >> solve or find a fix for it.
                > > >> Thanks in advance for any help/suggestion's anyone can offer.
                > > >>
                > > >
                > > > I now think this may be a problem with samba, but being a slug/linux
                > > > n00b i'm not sure what to do next.
                > > > I am running V2.3R63-uNSLUng-6.10-beta, Unslung to disk2, /dev/sda1
                > > > this includes the default version of samba 3.0.11 and I have
                selected
                > > > Language support USA(437).
                > > > Is this possibly a matter of either upgrading samba or modifying
                > smb.conf
                > > > If anyone can give me any clues it would be much appreciated.
                > >
                > > I know nothing about unslung, but your problem looks like a locales
                > > issue. You should be able to copy files with names including these
                > > characters to and from a Samba share. I suggest you google for
                > > something like 'filenames locales utf-8' and see if you can find any
                > > clues there.
                > >
                >
                > That's what i did Bob and came to the conclusion that the problem is
                > indeed with samba or the config, I just don't know how to fix it, yet.
                > I see you are running Debian, and I assume you have no such problems
                > with your setup, I am thinking it will be beneficial for me in the
                > long run to just bite the bullet and switch to Debian, bit worried to
                > do that though as I have very limited linux knowledge although the
                > support and info on the web is amazing. I notice you are over in Stoke
                > Gifford, sometimes it's a small world, I live in Chipping Sodbury.
                >
                >
                >
                >
                >
                > > --
                > > Bob Cox. Stoke Gifford, near Bristol, UK.
                > > Debian on the NSLU2: http://bobcox.com/slug/
                > > Registered user #445000 with the Linux Counter -
                http://counter.li.org/
                > >
                >
                I'm using Unslung(V2.3R63-uNSLUng-6.8-beta) with Samba(3.0.11) to
                backup my mp3-files with all those special characters (äöü' etc.)
                without any problem.
                My setting in the Web-Configuration (Administration -> System ->
                Language Support) is 'Western Europe/Latin 1(850)'.
                In /etc/samba/smb.conf I have (generated by Unslung) the lines
                unix charset = CP850
                dos charset = CP850

                Roland
              • doll_oliver
                I was also struggling with the charsets and I came up with the ... ditto ... no, started with 2.x?, but at 3.2.6 these days. ... ditto (IMO this refers back to
                Message 7 of 8 , Jan 4, 2009
                • 0 Attachment
                  I was also struggling with the charsets and I came up with the
                  following settings which work(ed) the best for me:

                  --- In nslu2-linux@yahoogroups.com, "rolandkbs" wrote:
                  > I'm using Unslung(V2.3R63-uNSLUng-6.8-beta)

                  ditto

                  > with Samba(3.0.11)

                  no, started with 2.x?, but at 3.2.6 these days.

                  > [...] the Web-Configuration [...] is 'Western Europe/Latin 1(850)'

                  ditto (IMO this refers back to the "dos charset"?)

                  > In /etc/samba/smb.conf I have (generated by Unslung) the lines
                  > unix charset = CP850
                  > dos charset = CP850

                  (my /etc/samba/smb.conf is a link to /unslung/smb.conf - and I guess
                  for you, too?)

                  I use dos charset = CP850 as well but for unix charset = UTF-8.
                  With this the files get properly named via smb. Only thing is that the
                  files (e.g. äöüß.txt) locally on the SLUG itself look as

                  -rwxrw---- 1 od everyone 0 Jan 4 14:38 ├ñ├Â├╝├ƒ.txt

                  Never made it to fix this, but as I use my slug as a NAS I don't care
                  too much.
                  --
                  tnx & cheers
                  Oliver
                • rincewindcook
                  Thanks all for the replies, this problem is now solved, by very simply changing the Language Support in the web gui to Western Europe/Latin 1(850) as
                  Message 8 of 8 , Jan 4, 2009
                  • 0 Attachment
                    Thanks all for the replies, this problem is now solved, by very simply
                    changing the Language Support in the web gui to 'Western Europe/Latin
                    1(850)' as suggested by Roland.
                    The only reason i didn't change this setting in the first place was
                    due to the recommendation on this wiki
                    http://www.nslu2-linux.org/wiki/Unslung/UnslungLanguageSupport
                    which says "If you can use the "USA (437)" setting, do so"
                    Thanks again for all your help, particularly Roland and Oliver for
                    giving me the fix.




                    --- In nslu2-linux@yahoogroups.com, "doll_oliver" <doll_oliver@...> wrote:
                    >
                    > I was also struggling with the charsets and I came up with the
                    > following settings which work(ed) the best for me:
                    >
                    > --- In nslu2-linux@yahoogroups.com, "rolandkbs" wrote:
                    > > I'm using Unslung(V2.3R63-uNSLUng-6.8-beta)
                    >
                    > ditto
                    >
                    > > with Samba(3.0.11)
                    >
                    > no, started with 2.x?, but at 3.2.6 these days.
                    >
                    > > [...] the Web-Configuration [...] is 'Western Europe/Latin 1(850)'
                    >
                    > ditto (IMO this refers back to the "dos charset"?)
                    >
                    > > In /etc/samba/smb.conf I have (generated by Unslung) the lines
                    > > unix charset = CP850
                    > > dos charset = CP850
                    >
                    > (my /etc/samba/smb.conf is a link to /unslung/smb.conf - and I guess
                    > for you, too?)
                    >
                    > I use dos charset = CP850 as well but for unix charset = UTF-8.
                    > With this the files get properly named via smb. Only thing is that the
                    > files (e.g. äöüß.txt) locally on the SLUG itself look as
                    >
                    > -rwxrw---- 1 od everyone 0 Jan 4 14:38
                    ├ñ├Â├╝├ƒ.txt
                    >
                    > Never made it to fix this, but as I use my slug as a NAS I don't care
                    > too much.
                    > --
                    > tnx & cheers
                    > Oliver
                    >
                  Your message has been successfully submitted and would be delivered to recipients shortly.