Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Debian

Expand Messages
  • Rod Whitby
    ... The answers to these two questions are the same as for any other Debian desktop machine with two USB ports. -- Rod
    Message 1 of 11 , Jan 2, 2009
    • 0 Attachment
      minimatica wrote:
      > Hi guys,
      > I'm new about debian on nslu2 so the first question ;)
      >
      > If I plug a pendrive on nslu2, debian don't mount it(even if I power
      > on the nslu2 after plugged the pen), how to?
      >
      > I noticed that I can switch from disk1 or disk2 and debian work
      > always...what port have I to use the disk1 or disk2 for the debian?

      The answers to these two questions are the same as for any other Debian
      desktop machine with two USB ports.

      -- Rod
    • Martin Michlmayr
      ... By default, Debian doesn t automatically mount new usb sticks or drives you connect. You either have to mount them manually or install some software that
      Message 2 of 11 , Jan 3, 2009
      • 0 Attachment
        * minimatica <ripetizioni@...> [2009-01-02 11:50]:
        > If I plug a pendrive on nslu2, debian don't mount it(even if I power
        > on the nslu2 after plugged the pen), how to?

        By default, Debian doesn't automatically mount new usb sticks or
        drives you connect. You either have to mount them manually or install
        some software that will automatically do it. Unfortunately I cannot
        recall the name of that software.

        > I noticed that I can switch from disk1 or disk2 and debian work
        > always...what port have I to use the disk1 or disk2 for the debian?

        I'm not sure I understand the question. If you only have one disk, it
        doesn't matter whether you connect it to disk1 or disk2. If you have
        multiple disks that are connected when you boot, you should change
        fstab to use UUID or labels anyway, otherwise your machine probably
        won't boot. The wiki has more info on this.
        --
        Martin Michlmayr
        http://www.cyrius.com/
      • minimatica
        ... TNX, Martin, now I have my ideas little clearer...but...I have not my pendrive mounted on my nslu2. I tried mountusb but did not work for me. Is there a
        Message 3 of 11 , Jan 7, 2009
        • 0 Attachment
          --- In nslu2-linux@yahoogroups.com, Martin Michlmayr <tbm@...> wrote:

          > multiple disks that are connected when you boot, you should change
          > fstab to use UUID or labels anyway, otherwise your machine probably
          > won't boot. The wiki has more info on this.
          > --
          > Martin Michlmayr
          > http://www.cyrius.com/
          >

          TNX, Martin, now I have my ideas little clearer...but...I have not my
          pendrive mounted on my nslu2. I tried "mountusb" but did not work for me.
          Is there a "how to" to automount pendrive, or disks, on nslu2? Or cold
          anyone explain me how to automount?

          TNX in advance!
        • Gordon Farquharson
          ... 1. Power up your NSLU2 without your USB drive attached. 2. Log in as root (or switch to the root user using su , or use sudo ). 3. At the command prompt,
          Message 4 of 11 , Jan 7, 2009
          • 0 Attachment
            On Wed, Jan 7, 2009 at 01:05, minimatica <ripetizioni@...> wrote:

            > TNX, Martin, now I have my ideas little clearer...but...I have not my
            > pendrive mounted on my nslu2. I tried "mountusb" but did not work for me.
            > Is there a "how to" to automount pendrive, or disks, on nslu2? Or cold
            > anyone explain me how to automount?

            1. Power up your NSLU2 without your USB drive attached.
            2. Log in as root (or switch to the root user using 'su', or use 'sudo').
            3. At the command prompt, enter 'tail -f /var/log/messages'.
            4. Plug in your USB drive.

            Some new log messages should appear in /var/log/messages.

            Look for something like

            Jan 7 07:10:09 LKG7102D7 kernel: [42949918.990000] scsi 2:0:0:0:
            Direct-Access M-SysT5 Dell Memory Key 5.00 PQ: 0 ANSI: 0 CCS
            Jan 7 07:10:09 LKG7102D7 kernel: [42949919.020000] sd 2:0:0:0: [sdb]
            499711 512-byte hardware sectors (256 MB)
            Jan 7 07:10:09 LKG7102D7 kernel: [42949919.030000] sd 2:0:0:0: [sdb]
            Write Protect is off
            Jan 7 07:10:09 LKG7102D7 kernel: [42949919.060000] sd 2:0:0:0: [sdb]
            499711 512-byte hardware sectors (256 MB)
            Jan 7 07:10:09 LKG7102D7 kernel: [42949919.070000] sd 2:0:0:0: [sdb]
            Write Protect is off
            Jan 7 07:10:09 LKG7102D7 kernel: [42949919.090000] sdb: sdb1
            Jan 7 07:10:09 LKG7102D7 kernel: [42949919.110000] sd 2:0:0:0: [sdb]
            Attached SCSI removable disk

            The device attached is /dev/sdb, and the following line in the output
            lists the partitions on the drive (in this example, only sdb1 exists).

            Jan 7 07:10:09 LKG7102D7 kernel: [42949919.090000] sdb: sdb1

            5. mount /dev/sdb1

            Gordon

            --
            Gordon Farquharson
            GnuPG Key ID: 32D6D676
          • minimatica
            ... if I try to mount I have this message: mount: can t find /dev/sdb1 in /etc/fstab or /etc/mtab Solutions?
            Message 5 of 11 , Jan 8, 2009
            • 0 Attachment
              --- In nslu2-linux@yahoogroups.com, "Gordon Farquharson"
              <gordonfarquharson@...> wrote:

              >
              > 5. mount /dev/sdb1
              >
              if I try to mount I have this message:
              "mount: can't find /dev/sdb1 in /etc/fstab or /etc/mtab"

              Solutions?
            • minimatica
              ... Ok, I had to mount it to a folder ;) But, now, why if I turn on my Debian-slug with two usb disk it won start? It seems that it do not recogniz the right
              Message 6 of 11 , Jan 8, 2009
              • 0 Attachment
                --- In nslu2-linux@yahoogroups.com, "minimatica" <ripetizioni@...> wrote:
                >
                > --- In nslu2-linux@yahoogroups.com, "Gordon Farquharson"
                > <gordonfarquharson@> wrote:
                >
                > >
                > > 5. mount /dev/sdb1
                > >
                > if I try to mount I have this message:
                > "mount: can't find /dev/sdb1 in /etc/fstab or /etc/mtab"
                >
                > Solutions?
                >
                Ok, I had to mount it to a folder ;)

                But, now, why if I turn on my Debian-slug with two usb disk it won'
                start? It seems that it do not recogniz the right disk to start and it
                hangs. Solutions?
              • Martin Michlmayr
                ... Unplug the 2nd disk. -- Martin Michlmayr http://www.cyrius.com/
                Message 7 of 11 , Jan 8, 2009
                • 0 Attachment
                  * minimatica <ripetizioni@...> [2009-01-08 08:37]:
                  > But, now, why if I turn on my Debian-slug with two usb disk it won'
                  > start? It seems that it do not recogniz the right disk to start and
                  > it hangs. Solutions?

                  Unplug the 2nd disk.

                  --
                  Martin Michlmayr
                  http://www.cyrius.com/
                • bloedmann999
                  ... Well unplugging disk 2 worked for me OK, this problem is documented in various places. Sees like Debian doesn t like any changes being made to fstab. Any
                  Message 8 of 11 , Jan 8, 2009
                  • 0 Attachment
                    --- In nslu2-linux@yahoogroups.com, Martin Michlmayr <tbm@...> wrote:
                    >
                    > * minimatica <ripetizioni@...> [2009-01-08 08:37]:
                    > > But, now, why if I turn on my Debian-slug with two usb disk it won'
                    > > start? It seems that it do not recogniz the right disk to start and
                    > > it hangs. Solutions?
                    >
                    > Unplug the 2nd disk.
                    >
                    > --
                    > Martin Michlmayr
                    > http://www.cyrius.com/
                    >
                    Well unplugging disk 2 worked for me OK, this problem is documented in
                    various places. Sees like Debian doesn't like any changes being made
                    to fstab. Any idea what the cause is though?

                    Maybe a startup script to mount the disk without changing fstab would
                    be a workaround?

                    Cheers Brian
                  • Ian Barton
                    ... You can also mount the disk in fstab using it s UUID instead of the device name. You can get the disks UUID using: vol_id -u /dev/sdX Replace SDX with your
                    Message 9 of 11 , Jan 8, 2009
                    • 0 Attachment
                      > * minimatica <ripetizioni@...> [2009-01-08 08:37]:
                      >> But, now, why if I turn on my Debian-slug with two usb disk it won'
                      >> start? It seems that it do not recogniz the right disk to start and
                      >> it hangs. Solutions?
                      >
                      > Unplug the 2nd disk.
                      >

                      You can also mount the disk in fstab using it's UUID instead of the
                      device name. You can get the disks UUID using:

                      vol_id -u /dev/sdX

                      Replace SDX with your device name. Your fstab will then look like:

                      # /dev/sda1
                      UUID=f84ec594-d486-4025-b958-1b1135fbac13 / ext3
                      relatime,errors=remount-ro 0 1

                      Ian.
                    • Martin Michlmayr
                      ... Read section The slug fails to reboot with 2 drives connected at http://www.nslu2-linux.org/wiki/Debian/TroubleShooting It explains the problem and a
                      Message 10 of 11 , Jan 8, 2009
                      • 0 Attachment
                        * bloedmann999 <Brian_Dorling@...> [2009-01-08 11:09]:
                        > Well unplugging disk 2 worked for me OK, this problem is documented in
                        > various places. Sees like Debian doesn't like any changes being made
                        > to fstab. Any idea what the cause is though?

                        Read section "The slug fails to reboot with 2 drives connected" at
                        http://www.nslu2-linux.org/wiki/Debian/TroubleShooting
                        It explains the problem and a solution.

                        --
                        Martin Michlmayr
                        http://www.cyrius.com/
                      Your message has been successfully submitted and would be delivered to recipients shortly.