Loading ...
Sorry, an error occurred while loading the content.

Re: zd1211 on slugOS be: posted to wrong group reposting

Expand Messages
  • prupertplum
    Hi root@snug:~$ ifconfig -a eth0 Link encap:Ethernet HWaddr 00:1D:7E:B4:3D:39 inet addr:192.168.1.129 Bcast:192.168.1.255 Mask:255.255.255.0 UP
    Message 1 of 6 , Dec 7, 2008
    • 0 Attachment
      Hi

      root@snug:~$ ifconfig -a
      eth0 Link encap:Ethernet HWaddr 00:1D:7E:B4:3D:39
      inet addr:192.168.1.129 Bcast:192.168.1.255 Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:1394617 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2791 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:100
      RX bytes:318927883 (304.1 MiB) TX bytes:400115 (390.7 KiB)

      lo Link encap:Local Loopback
      inet addr:127.0.0.1 Mask:255.0.0.0
      UP LOOPBACK RUNNING MTU:16436 Metric:1
      RX packets:110 errors:0 dropped:0 overruns:0 frame:0
      TX packets:110 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:12240 (11.9 KiB) TX bytes:12240 (11.9 KiB)

      root@snug:~$ iwconfig
      lo no wireless extensions.

      eth0 no wireless extensions.

      and /etc/network/interfaces shows:

      # /etc/network/interfaces
      # configuration file for ifup(8), ifdown(8)
      #
      # The loopback interface
      auto lo
      iface lo inet loopback
      #
      # The interface used by default during boot
      auto eth0
      # Automatically generated from /etc/default/sysconf
      # address, netmask and gateway are ignored for 'dhcp'
      # but required for 'static'
      iface eth0 inet dhcp
      address 192.168.1.77

      iface wlan0 inet dhcp
      pre-up /sbin/ifconfig $IFACE up
      pre-up cp /etc/resolv.conf /tmp/r
      wpa-conf /etc/wpa_supplicant.conf
      wpa-driver wext
      wireless-key secret
      wireless-essid plumternet
      up cp /tmp/r /etc/resolv.conf


      auto eth1
      iface eth1 inet dhcp
      pre-up /sbin/ifconfig $IFACE up
      pre-up cp /etc/resolv.conf /tmp/r
      wpa-conf /etc/wpa_supplicant.conf
      wpa-driver wext
      wireless-key secret
      wireless-essid plumternet
      up cp /tmp/r /etc/resolv.conf

      so, device isn't being registered correctly maybe?

      --- In nslu2-linux@yahoogroups.com, "Mike (mwester)" <mwester@...> wrote:
      >
      > prupertplum wrote:...
      > > Here are the results of various ifconfig commands after plugging in
      > > the device:
      > >
      > > root@snug:/lib/modules/2.6.21.7/kernel/drivers/net/wireless/zd1211rw$
      > > ifup wlan0SIOCGIFFLAGS: No such device
      > > root@snug:/lib/modules/2.6.21.7/kernel/drivers/net/wireless/zd1211rw$
      > > ifup eth1 SIOCGIFFLAGS: No such device
      > > root@snug:/lib/modules/2.6.21.7/kernel/drivers/net/wireless/zd1211rw$
      > > ifconfig wlan0
      > > ifconfig: wlan0: error fetching interface information: Device not
      found
      > > root@snug:/lib/modules/2.6.21.7/kernel/drivers/net/wireless/zd1211rw$
      >
      > "ifconfig -a" will list all the interfaces present on the systems - what
      > is the output from that command? Also, what is the output from
      > "iwconfig" (you may have to install wireless-tools to get that command)?
      >
      > Mike (mwester)
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.