Loading ...
Sorry, an error occurred while loading the content.

Slug on a lan, no FQDN, want smtp

Expand Messages
  • canfieldjohnw
    Hi everybody - first post here... Just discovered the Slug group. I have fooled around with Linux off and on since the .9 kernel and have recently been active
    Message 1 of 6 , Oct 29, 2008
    • 0 Attachment
      Hi everybody - first post here... Just discovered the Slug group.

      I have fooled around with Linux off and on since the .9 kernel and
      have recently been active again with Debian Etch on my slug. Had a
      lot of relearning to do and I'm slowly coming back up to speed.
      Anyway, I run a weather program (wview) on my slug
      (weather.janeandjohn.org) and have been tweaking the slug for a few
      months.

      I've spent some number of hours searching and reading (and playing) in
      a quest of solving my quandary, but at this point I'm in the need of
      some more resourceful and experienced users.

      Thought it would be nice to have the ability to mail the logs to me
      since I normally don't log into the slug unless something is wrong
      with the weather update. To that end, I installed the package ssmpt
      since I only need a very basic simple smtp capability. On the install
      of ssmtp, I noticed apt removed exim4. I have been out of it for so
      long, I didn't even realize exim was apparently a replacement for
      sendmail. ssmtp was very simple to use, but I never got it to
      actually connect to the specified mailhub.

      I'm thinking there is a domain name issue for the slug since it
      doesn't have a FQDN and that is hosing up ssmtp somehow. (Then I read
      that ssmtp is essentially abandoned and some recommend msmtp.)

      Then I removed ssmtp and installed exim4 back. After that installed,
      I can no longer use the 'mail' command.. don't know what the deal is
      with that. There is an exim conf file BTW. So now it appears that I
      have broken even the formerly usable mail command for localhost mail.

      If anybody has smtp running on a slug (Debian) with no FQDN, what
      package are you using? What did you set your hostname to? I tried a
      couple bogus hostnames, but ssmtp still couldn't access the mailhub.
      Then there is the chance the hostname has nothing to do with ssmtp not
      going out to the mailhub. I do have tnftp work on the slug, so we can
      and do connect to the world.

      I'm pretty much out of ideas here, so any help is sincerely appreciated.

      --John--
      janeandjohn.org
    • bloedmann999
      ... Hi, without going too deep, I am using Nail on my Slugs. Works perfectly. Maybe you could try that. Cheers Brian
      Message 2 of 6 , Oct 31, 2008
      • 0 Attachment
        --- In nslu2-linux@yahoogroups.com, "canfieldjohnw" <bucket@...> wrote:
        >
        > Hi everybody - first post here... Just discovered the Slug group.
        >
        > I have fooled around with Linux off and on since the .9 kernel and
        > have recently been active again with Debian Etch on my slug. Had a
        > lot of relearning to do and I'm slowly coming back up to speed.
        > Anyway, I run a weather program (wview) on my slug
        > (weather.janeandjohn.org) and have been tweaking the slug for a few
        > months.
        >
        > I've spent some number of hours searching and reading (and playing) in
        > a quest of solving my quandary, but at this point I'm in the need of
        > some more resourceful and experienced users.
        >
        > Thought it would be nice to have the ability to mail the logs to me
        > since I normally don't log into the slug unless something is wrong
        > with the weather update. To that end, I installed the package ssmpt
        > since I only need a very basic simple smtp capability. On the install
        > of ssmtp, I noticed apt removed exim4. I have been out of it for so
        > long, I didn't even realize exim was apparently a replacement for
        > sendmail. ssmtp was very simple to use, but I never got it to
        > actually connect to the specified mailhub.
        >
        > I'm thinking there is a domain name issue for the slug since it
        > doesn't have a FQDN and that is hosing up ssmtp somehow. (Then I read
        > that ssmtp is essentially abandoned and some recommend msmtp.)
        >
        > Then I removed ssmtp and installed exim4 back. After that installed,
        > I can no longer use the 'mail' command.. don't know what the deal is
        > with that. There is an exim conf file BTW. So now it appears that I
        > have broken even the formerly usable mail command for localhost mail.
        >
        > If anybody has smtp running on a slug (Debian) with no FQDN, what
        > package are you using? What did you set your hostname to? I tried a
        > couple bogus hostnames, but ssmtp still couldn't access the mailhub.
        > Then there is the chance the hostname has nothing to do with ssmtp not
        > going out to the mailhub. I do have tnftp work on the slug, so we can
        > and do connect to the world.
        >
        > I'm pretty much out of ideas here, so any help is sincerely appreciated.
        >
        > --John--
        > janeandjohn.org
        >
        Hi,
        without going too deep, I am using Nail on my Slugs. Works perfectly.
        Maybe you could try that.

        Cheers Brian
      • canfieldjohnw
        Thanks for the reply Brian :-) What is in your /etc/hosts file? John ... appreciated.
        Message 3 of 6 , Nov 1, 2008
        • 0 Attachment
          Thanks for the reply Brian :-) What is in your /etc/hosts file?

          John

          --- In nslu2-linux@yahoogroups.com, "bloedmann999" <Brian_Dorling@...>
          wrote:
          >
          > --- In nslu2-linux@yahoogroups.com, "canfieldjohnw" <bucket@> wrote:
          > >
          > > Hi everybody - first post here... Just discovered the Slug group.
          > >
          > > I have fooled around with Linux off and on since the .9 kernel and
          > > have recently been active again with Debian Etch on my slug. Had a
          > > lot of relearning to do and I'm slowly coming back up to speed.
          > > Anyway, I run a weather program (wview) on my slug
          > > (weather.janeandjohn.org) and have been tweaking the slug for a few
          > > months.
          > >
          > > I've spent some number of hours searching and reading (and playing) in
          > > a quest of solving my quandary, but at this point I'm in the need of
          > > some more resourceful and experienced users.
          > >
          > > Thought it would be nice to have the ability to mail the logs to me
          > > since I normally don't log into the slug unless something is wrong
          > > with the weather update. To that end, I installed the package ssmpt
          > > since I only need a very basic simple smtp capability. On the install
          > > of ssmtp, I noticed apt removed exim4. I have been out of it for so
          > > long, I didn't even realize exim was apparently a replacement for
          > > sendmail. ssmtp was very simple to use, but I never got it to
          > > actually connect to the specified mailhub.
          > >
          > > I'm thinking there is a domain name issue for the slug since it
          > > doesn't have a FQDN and that is hosing up ssmtp somehow. (Then I read
          > > that ssmtp is essentially abandoned and some recommend msmtp.)
          > >
          > > Then I removed ssmtp and installed exim4 back. After that installed,
          > > I can no longer use the 'mail' command.. don't know what the deal is
          > > with that. There is an exim conf file BTW. So now it appears that I
          > > have broken even the formerly usable mail command for localhost mail.
          > >
          > > If anybody has smtp running on a slug (Debian) with no FQDN, what
          > > package are you using? What did you set your hostname to? I tried a
          > > couple bogus hostnames, but ssmtp still couldn't access the mailhub.
          > > Then there is the chance the hostname has nothing to do with ssmtp not
          > > going out to the mailhub. I do have tnftp work on the slug, so we can
          > > and do connect to the world.
          > >
          > > I'm pretty much out of ideas here, so any help is sincerely
          appreciated.
          > >
          > > --John--
          > > janeandjohn.org
          > >
          > Hi,
          > without going too deep, I am using Nail on my Slugs. Works perfectly.
          > Maybe you could try that.
          >
          > Cheers Brian
          >
        • bloedmann999
          ... playing) in ... install ... I read ... installed, ... that I ... mail. ... tried a ... mailhub. ... ssmtp not ... we can ... John, /etc/hosts 127.0.0.1
          Message 4 of 6 , Nov 1, 2008
          • 0 Attachment
            --- In nslu2-linux@yahoogroups.com, "canfieldjohnw" <bucket@...> wrote:
            >
            > Thanks for the reply Brian :-) What is in your /etc/hosts file?
            >
            > John
            >
            > --- In nslu2-linux@yahoogroups.com, "bloedmann999" <Brian_Dorling@>
            > wrote:
            > >
            > > --- In nslu2-linux@yahoogroups.com, "canfieldjohnw" <bucket@> wrote:
            > > >
            > > > Hi everybody - first post here... Just discovered the Slug group.
            > > >
            > > > I have fooled around with Linux off and on since the .9 kernel and
            > > > have recently been active again with Debian Etch on my slug. Had a
            > > > lot of relearning to do and I'm slowly coming back up to speed.
            > > > Anyway, I run a weather program (wview) on my slug
            > > > (weather.janeandjohn.org) and have been tweaking the slug for a few
            > > > months.
            > > >
            > > > I've spent some number of hours searching and reading (and
            playing) in
            > > > a quest of solving my quandary, but at this point I'm in the need of
            > > > some more resourceful and experienced users.
            > > >
            > > > Thought it would be nice to have the ability to mail the logs to me
            > > > since I normally don't log into the slug unless something is wrong
            > > > with the weather update. To that end, I installed the package ssmpt
            > > > since I only need a very basic simple smtp capability. On the
            install
            > > > of ssmtp, I noticed apt removed exim4. I have been out of it for so
            > > > long, I didn't even realize exim was apparently a replacement for
            > > > sendmail. ssmtp was very simple to use, but I never got it to
            > > > actually connect to the specified mailhub.
            > > >
            > > > I'm thinking there is a domain name issue for the slug since it
            > > > doesn't have a FQDN and that is hosing up ssmtp somehow. (Then
            I read
            > > > that ssmtp is essentially abandoned and some recommend msmtp.)
            > > >
            > > > Then I removed ssmtp and installed exim4 back. After that
            installed,
            > > > I can no longer use the 'mail' command.. don't know what the deal is
            > > > with that. There is an exim conf file BTW. So now it appears
            that I
            > > > have broken even the formerly usable mail command for localhost
            mail.
            > > >
            > > > If anybody has smtp running on a slug (Debian) with no FQDN, what
            > > > package are you using? What did you set your hostname to? I
            tried a
            > > > couple bogus hostnames, but ssmtp still couldn't access the
            mailhub.
            > > > Then there is the chance the hostname has nothing to do with
            ssmtp not
            > > > going out to the mailhub. I do have tnftp work on the slug, so
            we can
            > > > and do connect to the world.
            > > >
            > > > I'm pretty much out of ideas here, so any help is sincerely
            > appreciated.
            > > >
            > > > --John--
            > > > janeandjohn.org
            > > >
            > > Hi,
            > > without going too deep, I am using Nail on my Slugs. Works perfectly.
            > > Maybe you could try that.
            > >
            > > Cheers Brian
            > >
            >
            John,

            /etc/hosts
            127.0.0.1 localhost

            127.0.1.1 slug2.home Slug2



            # The following lines are desirable for IPv6 capable hosts

            ::1 ip6-localhost ip6-loopback

            fe00::0 ip6-localnet

            ff00::0 ip6-mcastprefix

            ff02::1 ip6-allnodes

            ff02::2 ip6-allrouters

            ff02::3 ip6-allhosts


            and /root/.mailrc
            set smtp=smtpmail.tonline.de:25

            set from="root@slug1"

            set smtp-auth=login

            set smtp-auth-user=***********@...

            set smtp-auth-password=******

            set sendwait

            Sorry about the formatting.
            Cheers Brian
          • canfieldjohnw
            Brian - thanks very much! John ... --snip--
            Message 5 of 6 , Nov 1, 2008
            • 0 Attachment
              Brian - thanks very much!

              John

              --- In nslu2-linux@yahoogroups.com, "bloedmann999" <Brian_Dorling@...>
              wrote:
              >
              > --- In nslu2-linux@yahoogroups.com, "canfieldjohnw" <bucket@> wrote:
              > >
              > > Thanks for the reply Brian :-) What is in your /etc/hosts file?
              --snip--
              >
              > /etc/hosts
              > 127.0.0.1 localhost
              >
              > 127.0.1.1 slug2.home Slug2
              >
              >
              >
              > # The following lines are desirable for IPv6 capable hosts
              >
              > ::1 ip6-localhost ip6-loopback
              >
              > fe00::0 ip6-localnet
              >
              > ff00::0 ip6-mcastprefix
              >
              > ff02::1 ip6-allnodes
              >
              > ff02::2 ip6-allrouters
              >
              > ff02::3 ip6-allhosts
              >
              >
              > and /root/.mailrc
              > set smtp=smtpmail.tonline.de:25
              >
              > set from="root@slug1"
              >
              > set smtp-auth=login
              >
              > set smtp-auth-user=***********@...
              >
              > set smtp-auth-password=******
              >
              > set sendwait
              >
              > Sorry about the formatting.
              > Cheers Brian
              >
            • canfieldjohnw
              I reinstalled ssmtp, messed around some more with ssmtp.conf and got it going. Now I m getting root mail mailed to my primary email account (hooray I think.)
              Message 6 of 6 , Nov 2, 2008
              • 0 Attachment
                I reinstalled ssmtp, messed around some more with ssmtp.conf and got
                it going. Now I'm getting root mail mailed to my primary email
                account (hooray I think.)

                The trick seemed to be putting the login and password in the .conf
                file. Then I had a reverse DNS lookup failure (progress!!) which I
                solved by setting the host name in the .conf file to match my ISP.

                What a deal - more email ;-)

                John

                --- In nslu2-linux@yahoogroups.com, "bloedmann999" <Brian_Dorling@...>
                wrote:
                >
                > --- In nslu2-linux@yahoogroups.com, "canfieldjohnw" <bucket@> wrote:
                > >
                > > Hi everybody - first post here... Just discovered the Slug group.
                > >
                > > I have fooled around with Linux off and on since the .9 kernel and
                > > have recently been active again with Debian Etch on my slug. Had a
                > > lot of relearning to do and I'm slowly coming back up to speed.
                > > Anyway, I run a weather program (wview) on my slug
                > > (weather.janeandjohn.org) and have been tweaking the slug for a few
                > > months.
                > >
                > > I've spent some number of hours searching and reading (and playing) in
                > > a quest of solving my quandary, but at this point I'm in the need of
                > > some more resourceful and experienced users.
                > >
                > > Thought it would be nice to have the ability to mail the logs to me
                > > since I normally don't log into the slug unless something is wrong
                > > with the weather update. To that end, I installed the package ssmpt
                > > since I only need a very basic simple smtp capability. On the install
                > > of ssmtp, I noticed apt removed exim4. I have been out of it for so
                > > long, I didn't even realize exim was apparently a replacement for
                > > sendmail. ssmtp was very simple to use, but I never got it to
                > > actually connect to the specified mailhub.
                > >
                > > I'm thinking there is a domain name issue for the slug since it
                > > doesn't have a FQDN and that is hosing up ssmtp somehow. (Then I read
                > > that ssmtp is essentially abandoned and some recommend msmtp.)
                > >
                > > Then I removed ssmtp and installed exim4 back. After that installed,
                > > I can no longer use the 'mail' command.. don't know what the deal is
                > > with that. There is an exim conf file BTW. So now it appears that I
                > > have broken even the formerly usable mail command for localhost mail.
                > >
                > > If anybody has smtp running on a slug (Debian) with no FQDN, what
                > > package are you using? What did you set your hostname to? I tried a
                > > couple bogus hostnames, but ssmtp still couldn't access the mailhub.
                > > Then there is the chance the hostname has nothing to do with ssmtp not
                > > going out to the mailhub. I do have tnftp work on the slug, so we can
                > > and do connect to the world.
                > >
                > > I'm pretty much out of ideas here, so any help is sincerely
                appreciated.
                > >
                > > --John--
                > > janeandjohn.org
                > >
                > Hi,
                > without going too deep, I am using Nail on my Slugs. Works perfectly.
                > Maybe you could try that.
                >
                > Cheers Brian
                >
              Your message has been successfully submitted and would be delivered to recipients shortly.