Loading ...
Sorry, an error occurred while loading the content.

Re: putty no longer talks to my slug

Expand Messages
  • corky_the_bung
    This turned out to be a USB caddy issue. I bought a new USB HDD and unslung to it. Has been working fine for over a week now. The old caddy was displaying
    Message 1 of 6 , Sep 21, 2008
    • 0 Attachment
      This turned out to be a USB caddy issue. I bought a new USB HDD and
      unslung to it. Has been working fine for over a week now. The old
      caddy was displaying intermittent behavior (when I re-unslung to it it
      would appear to work, but only for a few hours). I removed the disk
      drive from inside it and it has been working fine when plugged
      directly inside my PC.

      Thanks for all the advice.


      --- In nslu2-linux@yahoogroups.com, Robert Hammond <rob.hammond@...>
      > In message <g949nq+ud24@...>, corky_the_bung
      > <geoff.a.emerson@...> writes
      > >--- In nslu2-linux@yahoogroups.com, "Mike (mwester)" <mwester@> wrote:
      > >>
      > >> corky_the_bung wrote:
      > >> > Hi,
      > >> >
      > >> > My unslung (Unslung-6.8-beta) Slug had been working fine until
      a few
      > >> > days ago. I have been using it as a file server for my home network
      > >> > for over a year.
      > >> >
      > >> > I determined that I needed to re-flash the image as I couldn't
      > >> > to the Slug via putty and the web interface was not working. My XP
      > >> > installation was unable to see the files in the shares which were
      > >> > previously viewable. By plugging the USB HDD directly into my
      > >> > PC I could see the files in the ext3 partitions on the USB HDD so I
      > >> > thought it was a fairly safe bet to assume that the flash was
      > >>
      > >> Probably not; the flash is not used very much when you have
      unslung the
      > >> device; it switches to the external hard drive very shortly after it
      > >> boots, and runs the entire Linksys gui and boot process from the hard
      > >> drive. So chances are that whatever was wrong could have been
      fixed on
      > >> the hard drive... you probably would have been much better off
      to have
      > >> tried to fix up whatever was wrong, rather than reflashing -- unless
      > >> your intent was to reformat the hard drive and start all over again.
      > >>
      > >> > I used upslug2 from my ubuntu installation to reflash
      > >> > Unslung-6.8-beta. All went well.
      > >>
      > >> Ok, good - but did do the "unsling" step? If not, then you aren't
      > >> really unslung; you're still running from the internal flash.
      > >>
      > >> > I can now see the files in the shares via XP. So good progress.
      > >> >
      > >> > However I still can't login via putty (network error: connection
      > >> > refused) and the web interface still doesn't work (times out).
      > >>
      > >> I suspect you are still running from internal flash, so whatever you
      > >> used to have installed is not. As for why you can't use the web
      > >> interface, it sounds like it's just a simple network issue. The
      > >> will be using whatever IP configuration you gave it last, unless
      > >> reset that to factory defaults as part of the procedures you've done
      > >> recently.
      > >>
      > >> > Any ideas how I can restore the putty access would be greatly
      > >appreciated.
      > >>
      > >> The first step is to gain control of the NSLU2. Remove the disk
      > >> drive(s) and all USB devices, and store them somewhere -- boot
      the NSLU2
      > >> and follow the various articles on the wiki to gain access to it (try
      > >> the default IP address, check your router to see if it gave it a DHCP
      > >> address, reset the device to Linksys defaults following the Linksys
      > >> reset button procedure, etc).
      > >>
      > >> Once you can reach the web GUI, configure the device (timezone,
      > >> date/time, and most importantly network settings). Then enable
      > >> in the normal way, and confirm that you can telnet into it.
      > >>
      > >> Now comes the fun part. You have both data and an old
      installation of
      > >> Unslung on the drive. You need to do the "unsling" step described in
      > >> the wiki and README files to switch the device over from booting
      > >> internally to booting from the external drive.
      > >>
      > >> But "unsling" won't work -- it'll detect that the drive already has a
      > >> copy of the data, and refuse to unsling. However, it should tell you
      > >> what to do in order to succeed (I think you have to delete a file
      on the
      > >> hard drive or something -- it's in the upgrading pages for Unslung on
      > >> the wiki too). Once you do that, you'll have an odd mixture of
      the old
      > >> stuff, and a new install. Reboot, and see what happens. It may just
      > >> start to work, and all will be good. It may be that you are
      right back
      > >> where you used to be -- also good, because if that happens you
      can then
      > >> troubleshoot what went wrong in the first place and fix it. Or
      it may
      > >> not boot at all from the external disk, and you'll have to carefully
      > >> wipe out everything on that disk (except for the data you put on it;
      > >> keep that), and start from scratch once again.
      > >>
      > >> Mike (mwester)
      > >>
      > >
      > >Thank you for the advice so far.
      > >
      > >OK some progress. The inability to connect to the web interface was
      > >due to a proxy server issue in my browser. I had configured it to use
      > >a manual proxy (webcache.virginmedia.com) to avoid issues I see with
      > >ebay. Put it back to auto and I can see the web interface. Of course I
      > >didn't discover this until after I had reset my router to factory
      > >default. Such is life :-)
      > >
      > If using a manual set proxy, click on the advanced button and add the
      > following into the Exception box. All should then work.
      > 192.168.*;10.*
      > --
      > Robert Hammond
      > PGP:0x154144DA
    Your message has been successfully submitted and would be delivered to recipients shortly.