Loading ...
Sorry, an error occurred while loading the content.

bash on the wl500g and libiconv

Expand Messages
  • Marcel Nijenhof
    Hi, The optware version of bash for the wl500g misses a dependency to libiconv. $ bash bash: can t load library libiconv.so.2 $ ipkg -t /opt/tmp/ install
    Message 1 of 1 , Sep 19, 2008
    • 0 Attachment
      Hi,

      The optware version of bash for the wl500g misses a dependency to
      libiconv.


      $ bash
      bash: can't load library 'libiconv.so.2'

      $ ipkg -t /opt/tmp/ install libiconv
      Installing libiconv (1.11-2) to root...
      Downloading
      http://ipkg.nslu2-linux.org/feeds/unslung/wl500g/libiconv_1.11-2_mipsel.ipk
      Configuring libiconv
      Successfully terminated.

      After that bash runs.

      The dependency is target depended. I don't need it on a unslung
      device.

      I have found the following code in "tcsh.mk":
      ifeq (libiconv, $(filter libiconv, $(PACKAGES)))
      TCSH_DEPENDS=libiconv
      else
      TCSH_DEPENDS=
      endif

      Maybe we should add something like that to bash as well.


      --
      Marcel Nijenhof
      Optware package developer
      nslu2@...
    Your message has been successfully submitted and would be delivered to recipients shortly.