Loading ...
Sorry, an error occurred while loading the content.

[Bug 18] New - Unable to use OE packages

Expand Messages
  • slugbug@nslu2-linux.org
    ============================================================================ THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY INSTEAD
    Message 1 of 1 , Nov 5, 2004
    • 0 Attachment
      ============================================================================
      THIS MESSAGE WAS GENERATED BY THE BUGTRACKER SOFTWARE PLEASE DO NOT REPLY

      INSTEAD FOLLOW BUG'S URL BELOW IN ORDER TO DETAIL BUG:
      ============================================================================
      Bug #: 18 (http://slugbug.nslu2-linux.org/bug.php?op=show&bugid=18)
      Reported By: perlguru@...
      ----------------------------------------------------------------------------
      Summary: Unable to use OE packages
      URL: http://www.nslu2-linux.org/wiki/OpenEmbedded/UnslungPackageProblems
      Product: Alpha Testing
      Version: Specify in Description
      Component: unslung
      Site: All
      Status: Assigned
      Resolution: None
      Severity: Unassigned
      OS/Version: Unslung
      Database: None
      Priority: 3 - Medium
      Assigned To: nslu2-linux@yahoogroups.com
      ============================================================================
      COMMENTS

      ----- Posted by perlguru at 1:27 PM on 2004-11-05 -----
      While trying to create the usbutils package from OE, I expirienced the
      following troubles:

      first step:
      #> ipkg install
      usbutils_0.11-r0_armeb.ipk
      Installing usbutils (0.11-r0) to
      root...
      ERROR: Cannot satisfy the following dependencies for
      usbutils:
      nslu2-linksys-libs (>= 2.3r25)
      Configuring
      libgcc
      ldconfig: No such file or directory
      postinst script
      returned status 127
      ERROR: libgcc.postinst returned 127
      An
      error ocurred, return value: 1.

      OK, let try to install libgcc:

      #> ipkg install libgcc_3.4.2-r0_armeb.ipk
      Installing libgcc
      (3.4.2-r0) to root...
      Package libgcc wants to install file
      /lib/libgcc_s.so.1
      But that file is already provided by package
      libgcc
      An error ocurred, return value: 1.

      No luck there :(,
      forcing it:
      #> ipkg install libgcc_3.4.2-r0_armeb.ipk
      -force-overwrite
      Installing libgcc (3.4.2-r0) to root...

      Configuring libgcc
      ldconfig: No such file or directory

      postinst script returned status 127
      ERROR: libgcc.postinst returned
      127

      No luck. Since i'm not an OE expert/guru I ask for your input.
      Please help to
      sort out why we still cannot use OE packages for unslung
      2.x
    Your message has been successfully submitted and would be delivered to recipients shortly.