Loading ...
Sorry, an error occurred while loading the content.
 

Re: [nslu2-linux] Formatting problems when unslinging with 1GB USB2 key

Expand Messages
  • roland.gallinera@mcicoach.com
    I also had problems formatting a drive in uNSLUng... My NSLU seems to be hanging or not accepting incoming connections, which I assume was because of my
    Message 1 of 8 , Jun 13, 2008
      I also had problems formatting a drive in uNSLUng...

      My NSLU seems to be hanging or not accepting incoming connections, which I assume was because of my installation of Samba, Apache, Asterisk, thttpd, etc... so I proceded to do redboot and reinstall unslung firmware. My mistake was I didn't remove the 4GB USB Flash drive and my 500GB USB HDD drive upon reboot, so I had problem signing in. I thought it was because of the config in the USB Flash drive (plugged in Disk 1 port) so I went to the NSLU web interface and proceded to format DISK 1. It took a long time, and I was beginning to worry... a few more minutes later I realized that it was formatting my 500GB drive instead of the 4GB USB Flash drive..

      The web interface indicated that DISK 1 was a 4GB drive while the DISK 2 was the 500GB drive... how come it formatted the 500GB????

      Also anyone knows of a good utility to UNFORMAT my 500GB drive? I had lots of data in there.... I've tried Disk Internals, but it only recovered some useless files....






      nslu2-linux@yahoogroups.com wrote on 06/13/2008 11:04:31 AM:

      > Moreo Davide wrote:
      > ...
      > > Vendor: S31B0711  Model: USB DISK        
       Rev: 1100
      > >
      > >  
      > >
      > > But this time, every time I try to format the key in EXT3, by
      using the
      > > web page of the Linksys, I always receive the following error
      message:
      > >
      > > “Disk 2 isn’t HDD, cannot format it!”
      > >
      > > And I can’t go on the “unslinging” process. I’m sure the
      browser cache
      > > is empty and cleaned and the NSLU2 bootstrapped properly.
      >
      > This message is commonly associated with the stock Linksys firmware,
      > which refuses to format anything smaller than 10 GB in size.  The
      > Unslung firmware has disabled this check, so you should not be seeing
      > that message.  Are you using the Unslung firmware to format,
      or the
      > Linksys firmware to format?
      >
      > > I also tried several times starting both from a formatted (FAT16/32)
      key
      > > and a non formatted key, but none of them work. No way! In the
      meantime
      > > I had no problems to repeating the unslinging with the 512MB
      key…it
      > > works! I’m using Windows XP Professional and Internet Explorer
      7.0.
      > >
      > > What’s wrong with my 1GB key
      >
      > No idea... you haven't provided enough information!  When you
      plug the
      > key in, what messages appear in the output from the "dmesg"
      command?
      > What is the output from the "mount" command?  Also,
      have you checked
      > some of the things on the wiki -- for instance, are you sure that
      your
      > 1GB key is not a U3 device?
      >
      > > Should I move to the Debian firmware for
      > > native C/C++ development purposes?
      >
      > Now this is an interesting question.  Did you review the description
      of
      > the firmwares when you downloaded to ensure that the one you downloaded
      > will meet your needs?
      >
      > Linksys' firmware is a NAS application that uses parts of an older
      Linux
      > environment.  Unslung is Linksys' firmware opened up so that
      you can add
      > software to it.  Now you are indeed able to add a C compiler,
      and you
      > can do software development on the device (limited by the abilities
      of
      > the hardware, of course), but it is not, strictly speaking, a proper
      > Linux environment -- meaning that you just won't find all the system
      > files in the standard places, and they may not behave the way one
      would
      > expect.  For basic C development, this may not be an issue for
      you.  But
      > if the code you are working on is intended to run on a standard
      > environment, or uses newer kernel interfaces, you may need to consider
      > the use of a standard Linux environment on the NSLU2, such as SlugOS
      or
      > perhaps even Debian.
      >
      > Mike (mwester)
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.