Loading ...
Sorry, an error occurred while loading the content.

Re: UnsatisfiedLinkError: Native library `javanet' not found

Expand Messages
  • abhinav
    I too have exactly the same problem.Anybody please help Thank you ... org.soda.dpws.internal.LocalIPAddressImpl. (LocalIPAddressImpl.java:63) ...
    Message 1 of 4 , May 22, 2008
    • 0 Attachment
      I too have exactly the same problem.Anybody please help

      Thank you
      --- In nslu2-linux@yahoogroups.com, "tirolepietre" <tirolepietre@...>
      wrote:
      >
      > I have exactly the same problem. Did any of you experience the same
      > situation and found an effective solution?
      > Thank you
      >
      > --- In nslu2-linux@yahoogroups.com, "friedrich.kemper"
      > <friedrich.kemper@> wrote:
      > >
      > > Hello,
      > >
      > > when i try to run a java prog i get this follow error output:
      > >
      > > java.lang.UnsatisfiedLinkError: Native library `javanet' not found (as
      > > file `libjavanet.so') in gnu.classpath.boot.library.path and
      > > java.library.path
      > > at java.lang.Runtime.loadLibrary(Runtime.java:763)
      > > at java.lang.System.loadLibrary(System.java:662)
      > > at java.net.VMInetAddress.<clinit>(VMInetAddress.java:50)
      > > at java.net.InetAddress.<clinit>(InetAddress.java:77)
      > > at
      > >
      >
      org.soda.dpws.internal.LocalIPAddressImpl.<init>(LocalIPAddressImpl.java:63)
      > > at
      > >
      org.soda.dpws.DPWSNetworks.getDefaulLocalIPAddress(DPWSNetworks.java:58)
      > > at org.soda.dpws.registry.Registry.<init>(Registry.java:151)
      > > at org.soda.dpws.registry.Registry.<init>(Registry.java:87)
      > > at Lights.LightsServer.<init>(LightsServer.java:77)
      > > at Lights.LightsServer.main(LightsServer.java:71)
      > >
      > > i start my programm with this command:
      > >
      > > jamvm -Dgnu.classpath.boot.library.path=/opt/lib/classpath/ -cp
      > > $CLASSPATH Lights.LightsServer
      > >
      > > in the directory /opt/lib/classpath i found the libjavanet.so (it is a
      > > link to the file /opt/lib/classpath/libjavanet.so.0.0.0,
      > >
      > > what is the problem? when i run the programm under the cvm-VM it
      works.
      > >
      > > best regards
      > >
      >
    • lightbit
      Hi, have you tried the SableVM? I ve successfully used sockets with this VM. Some installation remarks: Before installing the package sablevm remove the
      Message 2 of 4 , Jun 1, 2008
      • 0 Attachment
        Hi,

        have you tried the SableVM? I've successfully used sockets with this
        VM.

        Some installation remarks: Before installing the package sablevm
        remove the package classpath. Ensure that the packages popt and zlib
        are installed. Because of missing dependencies these packages are not
        automatically installed.

        You have one drawback with the SableVM: It complies only to J2SE 1.4.
        Therefore tell your java compiler to generate class files only for
        this version.

        Mathias

        --- In nslu2-linux@yahoogroups.com,
        "abhinav" <abhinavsrivastava2004@...> wrote:
        >
        > I too have exactly the same problem.Anybody please help
        >
        > Thank you
        > --- In nslu2-linux@yahoogroups.com, "tirolepietre" <tirolepietre@>
        > wrote:
        > >
        > > I have exactly the same problem. Did any of you experience the
        same
        > > situation and found an effective solution?
        > > Thank you
        > >
        > > --- In nslu2-linux@yahoogroups.com, "friedrich.kemper"
        > > <friedrich.kemper@> wrote:
        > > >
        > > > Hello,
        > > >
        > > > when i try to run a java prog i get this follow error output:
        > > >
        > > > java.lang.UnsatisfiedLinkError: Native library `javanet' not
        found (as
        > > > file `libjavanet.so') in gnu.classpath.boot.library.path and
        > > > java.library.path
        > > > at java.lang.Runtime.loadLibrary(Runtime.java:763)
        > > > at java.lang.System.loadLibrary(System.java:662)
        > > > at java.net.VMInetAddress.<clinit>(VMInetAddress.java:50)
        > > > at java.net.InetAddress.<clinit>(InetAddress.java:77)
        > > > at
        > > >
        > >
        >
        org.soda.dpws.internal.LocalIPAddressImpl.<init>(LocalIPAddressImpl.java:63)
        > > > at
        > > >
        >
        org.soda.dpws.DPWSNetworks.getDefaulLocalIPAddress(DPWSNetworks.java:58)
        > > > at org.soda.dpws.registry.Registry.<init>(Registry.java:151)
        > > > at org.soda.dpws.registry.Registry.<init>(Registry.java:87)
        > > > at Lights.LightsServer.<init>(LightsServer.java:77)
        > > > at Lights.LightsServer.main(LightsServer.java:71)
        > > >
        > > > i start my programm with this command:
        > > >
        > > > jamvm -Dgnu.classpath.boot.library.path=/opt/lib/classpath/ -cp
        > > > $CLASSPATH Lights.LightsServer
        > > >
        > > > in the directory /opt/lib/classpath i found the libjavanet.so
        (it is a
        > > > link to the file /opt/lib/classpath/libjavanet.so.0.0.0,
        > > >
        > > > what is the problem? when i run the programm under the cvm-VM it
        > works.
        > > >
        > > > best regards
        > > >
        > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.