Loading ...
Sorry, an error occurred while loading the content.

Spinup Problems with maxtor One Tuch 4 on Debian

Expand Messages
  • cahaag
    Hi folks, My NSLU2 was working fine with a Trekstor Disk attached ( in fact it is a WD drive. The Spindown of the drive was managed with a spindown script
    Message 1 of 2 , Mar 2, 2008
    • 0 Attachment
      Hi folks,

      My NSLU2 was working fine with a Trekstor Disk attached ( in fact it
      is a WD drive. The Spindown of the drive was managed with a spindown
      script using the sg_start util and it worked perfectly...until I
      changed the drive to a Maxtor One Toch 4.

      The Maxtor drives are known to have a built in Power feature which
      spins the drive down by its own.
      This works as expected but when the disk should wake up the NSLU2 is
      not able to get it back to spin.....
      I did some research in the net and found the following document :

      http://www.nslu2-linux.org/wiki/FAQ/DealWithAutoSpinDownOnSeagateFreeAgent

      I implemented the recommended 'allow_restart' parameter and it seemed
      to work.
      The disk spins down after the specified time and spins up when there
      is  a read or write request. But in the message file I can see the
      following entries each time the device is accessed after it has been
      set to standby:

      Mar  2 22:58:43 NSLU2 kernel: sd 4:0:0:0: Device not ready: <6>:
      Current: sense key=0x2
      Mar  2 22:58:43 NSLU2 kernel:     ASC=0x4 ASCQ=0x2
      Mar  2 22:58:43 NSLU2 kernel: end_request: I/O error, dev sdc, sector xyz


      and the device goest into Read Only Mode, as I am  not able to write
      any data to it:

      NSLU2:/etc# cp hosts /shares
      cp: cannot create regular file `/shares/hosts': Read-only file system


      Does anyone have an idea how to get around this annoying behaviour of
      the Maxtor/Seagate drives ?

      greetings
      Carsten

    • Marc Boris
      ... http://www.nslu2-linux.org/wiki/FAQ/DealWithAutoSpinDownOnSeagateFreeAge ... I had the same behavior with a seagate drive (aka Maxtor) on an Ubuntu system
      Message 2 of 2 , Mar 3, 2008
      • 0 Attachment
        --- In nslu2-linux@yahoogroups.com, "cahaag" <cahaag@...> wrote:
        >
        > Hi folks,
        >
        > My NSLU2 was working fine with a Trekstor Disk attached ( in fact it
        > is a WD drive. The Spindown of the drive was managed with a spindown
        > script using the sg_start util and it worked perfectly...until I
        > changed the drive to a Maxtor One Toch 4.
        >
        > The Maxtor drives are known to have a built in Power feature which
        > spins the drive down by its own.
        > This works as expected but when the disk should wake up the NSLU2 is
        > not able to get it back to spin.....
        > I did some research in the net and found the following document :
        >
        >
        http://www.nslu2-linux.org/wiki/FAQ/DealWithAutoSpinDownOnSeagateFreeAge\
        > nt
        >
        > I implemented the recommended 'allow_restart' parameter and it seemed
        > to work.
        > The disk spins down after the specified time and spins up when there
        > is a read or write request. But in the message file I can see the
        > following entries each time the device is accessed after it has been
        > set to standby:
        >
        > Mar 2 22:58:43 NSLU2 kernel: sd 4:0:0:0: Device not ready: <6>:
        > Current: sense key=0x2
        > Mar 2 22:58:43 NSLU2 kernel: ASC=0x4 ASCQ=0x2
        > Mar 2 22:58:43 NSLU2 kernel: end_request: I/O error, dev sdc, sector
        > xyz
        >
        > and the device goest into Read Only Mode, as I am not able to write
        > any data to it:
        >
        > NSLU2:/etc# cp hosts /shares
        > cp: cannot create regular file `/shares/hosts': Read-only file system
        >
        > Does anyone have an idea how to get around this annoying behaviour of
        > the Maxtor/Seagate drives ?
        >
        > greetings
        > Carsten
        >

        I had the same behavior with a seagate drive (aka Maxtor) on an Ubuntu
        system using USB2.0. The temp solution was: mount -o remount,rw
        /dev/<xyz> or an umount and mount (can not remember exactly, sorry)
        A better solution is not to use spindown feature at all because
        nowadays the lifetime of drives is not really dep. on the spinning
        time. Starting and stopping is even more stress for the drive than to
        keep spinning. As long as there are no other reasons to suspend it I'd
        recommend disabling the spindown entirely with e.g. the Maxtor Manager
        program.
        -- Marc
      Your message has been successfully submitted and would be delivered to recipients shortly.