Loading ...
Sorry, an error occurred while loading the content.
 

Mounted filesystem mounts as RW, but keeps changing to RO

Expand Messages
  • mneub
    OK, after running unslung for a couple of years, my hard drive died. I built the new system with SlugOS last week running off a new Maxtor 1 touch. I ve done a
    Message 1 of 9 , Feb 3, 2008
      OK, after running unslung for a couple of years, my hard drive died. I built the new system with SlugOS last week running off a new Maxtor 1 touch. I've done a bunch of searching, but I'm either not getting the right keywords in (likely), or this has never happened to anybody (unlikely). Here's the problem:

      My mount were I put my web pages keeps going to read only. It's the only one of the four on the Maxtor that has this issue The mount starts fine, after reboot it comes up
      /dev/sdb2 on /var/web type ext3 (rw,data=ordered)

      but after a few hours, it ends up being
      /dev/sdb2 on /var/web type ext3 (ro,data=ordered)


      I have my own version of bashpodder running...so several times a day, it checks for new podcasts, and downloads them locally (different mount). It then copies and renames any downloads to a directory under /var/web, so I can download them if I'm not at home. I also have a cron job running several find commands to update permissions thru /var/web. All the cron jobs run as root, as does bashpodder.

      I have my /etc/fstab set up like this
      /dev/sdb2 /var/web  ext3 rw,suid,dev,exec,auto,nouser,async     1  3

      I did this after having the same problem with
      /dev/sdb2 /var/web  ext3 defaults     1  3

      I moved the location of the web files to another file system. Same thing happened to the new mount point!

      I came the conclusion that it was thttpd doing this. So I removed it and installed cherokee. Same thing. Realizing I've been running thttpd and cherokee as root, I set it up to run as nobody, figuring only root could change it to read only. Still does it.

      While I'm comfortable in the UNIX shell, I don't have root at my everyday job, so the fstab is probably the issue, as it's what I know about the least.

      To make my files downloaded by bashpodder available to the webserver, I obviously need to keep that mount up as read-write. Hopefully someone here can see what I'm doing wrong and help me out. Thanks in advance!
    • John
      ... Have you checked the log files for messages about disk errors? You might need first to turn logging on since, out of the box, slugos is quite minimal.
      Message 2 of 9 , Feb 3, 2008
        On Sun, Feb 03, 2008 at 06:01:03PM -0000, mneub wrote:
        > My mount were I put my web pages keeps going to read only. It's the
        > only one of the four on the Maxtor that has this issue The mount starts
        > fine, after reboot it comes up
        > /dev/sdb2 on /var/web type ext3 (rw,data=ordered)
        > but after a few hours, it ends up being
        > /dev/sdb2 on /var/web type ext3 (ro,data=ordered)

        Have you checked the log files for messages about disk errors?

        You might need first to turn logging on since, out of the box,
        slugos is quite minimal.

        --John
      • tonymy01
        Ok, this is driving me insane and I am now resorting to this newsgroup as googling NSLU2 more doesn t get me what I want (obviously) and the NSLU2 wiki
        Message 3 of 9 , Feb 3, 2008

          Ok, this is driving me insane and I am now resorting to this newsgroup as googling “NSLU2 more” doesn’t get me what I want (obviously) and the NSLU2 wiki doesn’t help.

          I want to page long files, so do a cat filename |more (or simply more filename)  but the more applet doesn’t appear to be in busybox anymore.   I can see a symlink to /opt/bin/busybox to more, but when I type “busybox” by itself, more isn’t in the list (nor is it in the stock Linksys busybox in /bin).   I removed the symlink and reinstalled busybox and sure enough it no longer installs a link to “more” anymore either.

          Where did it go, and where can I get it now?   I did a scan of all the unslung packages available and none stand out as providing what I need either (I have many many packages installed, I thought “maybe coreutils has it and I lost the coreutils-more application” but reinstalling that didn’t help either).

          Regards

          Tonymy01

          --

          .


        • Bogdan Banica
          Tonymy01 - I recall the same struggle to find it - to me it worked like this: ipkg install util-linux ln -s /opt/bin/util-linux-more /opt/bin/more Cheers.. Bog
          Message 4 of 9 , Feb 3, 2008

            Tonymy01 - I recall the same struggle to find it - to me it worked like this:

             

            ipkg install util-linux

            ln -s /opt/bin/util-linux-more /opt/bin/more

             

             

            Cheers.. Bog

             

             


            From: nslu2-linux@yahoogroups.com [mailto:nslu2-linux@yahoogroups.com] On Behalf Of tonymy01
            Sent: Monday, February 04, 2008 3:31 PM
            To: nslu2-linux@yahoogroups.com
            Subject: [nslu2-linux] "more" applet missing

             

            Ok, this is driving me insane and I am now resorting to this newsgroup as googling “NSLU2 more” doesn’t get me what I want (obviously) and the NSLU2 wiki doesn’t help.

            I want to page long files, so do a cat filename |more (or simply more filename)  but the more applet doesn’t appear to be in busybox anymore.   I can see a symlink to /opt/bin/busybox to more, but when I type “busybox” by itself, more isn’t in the list (nor is it in the stock Linksys busybox in /bin).   I removed the symlink and reinstalled busybox and sure enough it no longer installs a link to “more” anymore either.

            Where did it go, and where can I get it now?   I did a scan of all the unslung packages available and none stand out as providing what I need either (I have many many packages installed, I thought “maybe coreutils has it and I lost the coreutils-more application” but reinstalling that didn’t help either).

            Regards

            Tonymy01

            --

            .

            Web Bug from http://geo.yahoo.com/serv?s=97359714/grpId=13216923/grpspId=1705004750/msgId=20969/stime=1202076455/nc1=4507179/nc2=4025338/nc3=5202322

          • Mike (mwester)
            This may be a symptom of a disk or filesystem problem. Check the logs (/var/log/messages and dmesg). Mike (mwester) ... From: mneub To:
            Message 5 of 9 , Feb 3, 2008
              This may be a symptom of a disk or filesystem problem. Check the logs (/var/log/messages and dmesg).
              Mike (mwester)


              ----- Original Message -----
              From: "mneub" <mneub@...>
              To: <nslu2-linux@yahoogroups.com>
              Sent: Sunday, February 03, 2008 12:01 PM
              Subject: [nslu2-linux] Mounted filesystem mounts as RW, but keeps changing to RO


              OK, after running unslung for a couple of years, my hard drive died. I
              built the new system with SlugOS last week running off a new Maxtor 1
              touch. I've done a bunch of searching, but I'm either not getting the
              right keywords in (likely), or this has never happened to anybody
              (unlikely). Here's the problem:

              My mount were I put my web pages keeps going to read only. It's the only
              one of the four on the Maxtor that has this issue The mount starts fine,
              after reboot it comes up
              /dev/sdb2 on /var/web type ext3 (rw,data=ordered)

              but after a few hours, it ends up being
              /dev/sdb2 on /var/web type ext3 (ro,data=ordered)


              I have my own version of bashpodder running...so several times a day, it
              checks for new podcasts, and downloads them locally (different mount).
              It then copies and renames any downloads to a directory under /var/web,
              so I can download them if I'm not at home. I also have a cron job
              running several find commands to update permissions thru /var/web. All
              the cron jobs run as root, as does bashpodder.

              I have my /etc/fstab set up like this
              /dev/sdb2 /var/web ext3 rw,suid,dev,exec,auto,nouser,async 1 3

              I did this after having the same problem with
              /dev/sdb2 /var/web ext3 defaults 1 3

              I moved the location of the web files to another file system. Same thing
              happened to the new mount point!

              I came the conclusion that it was thttpd doing this. So I removed it and
              installed cherokee. Same thing. Realizing I've been running thttpd and
              cherokee as root, I set it up to run as nobody, figuring only root could
              change it to read only. Still does it.

              While I'm comfortable in the UNIX shell, I don't have root at my
              everyday job, so the fstab is probably the issue, as it's what I know
              about the least.

              To make my files downloaded by bashpodder available to the webserver, I
              obviously need to keep that mount up as read-write. Hopefully someone
              here can see what I'm doing wrong and help me out. Thanks in advance!
            • Bob Cox
              In article , ... Just a thought, but I wonder if the 3 in the sixth field of your /etc/fstab entries is right? From the man page:
              Message 6 of 9 , Feb 3, 2008
                In article <fo4vgv+aqrb@...>,
                mneub <mneub@...> wrote:

                > I have my /etc/fstab set up like this
                > /dev/sdb2 /var/web ext3 rw,suid,dev,exec,auto,nouser,async 1 3
                >
                > I did this after having the same problem with
                > /dev/sdb2 /var/web ext3 defaults 1 3
                >
                > I moved the location of the web files to another file system. Same thing
                > happened to the new mount point!

                Just a thought, but I wonder if the "3" in the sixth field of your
                /etc/fstab entries is right?

                From the man page:

                "The sixth field, (fs_passno), is used by the fsck(8) program to
                determine the order in which filesystem checks are done at reboot time.
                The root filesystem should be specified with a fs_passno of 1, and
                other filesystems should have a fs_passno of 2. Filesystems
                within a drive will be checked sequentially, but filesystems on
                different drives will be checked at the same time to utilize parallelism
                available in the hardware. If the sixth field is not present or zero,
                a value of zero is returned and fsck will assume that the filesystem
                does not need to be checked."

                Your "3" may be being interpreted as a "0" which could mean the
                filesystem is not being checked by fsck.

                --
                Bob Cox. Stoke Gifford, near Bristol, UK.
                Registered user #445000 with the Linux Counter: http://counter.li.org/
                Debian on NSLU2 Slug: http://bobcox.com/slug/
              • tonymy01
                Excellent advice, I did a ipkg list|grep blah where blah was nearly every keyword I could think of, and didn t catch that I didn t have that one installed.
                Message 7 of 9 , Feb 6, 2008

                  Excellent advice, I did a ipkg list|grep “blah” where blah was nearly every keyword I could think of, and didn’t catch that I didn’t have that one installed.

                  The install actually setup the symbolic links, so didn’t need to do the 2nd bit.

                  Thanks, and regards,

                  Tony

                  From: nslu2-linux@yahoogroups.com [mailto:nslu2-linux@yahoogroups.com] On Behalf Of Bogdan Banica
                  Sent: Monday, 4 February 2008 15:36
                  To: nslu2-linux@yahoogroups.com
                  Subject: RE: [nslu2-linux] "more" applet missing

                   

                  Tonymy01 - I recall the same struggle to find it - to me it worked like this:

                   

                  ipkg install util-linux

                  ln -s /opt/bin/util-linux-more /opt/bin/more

                   

                   

                  Cheers.. Bog

                   

                   


                  From: nslu2-linux@yahoogroups.com [mailto:nslu2-linux@yahoogroups.com] On Behalf Of tonymy01
                  Sent: Monday, February 04, 2008 3:31 PM
                  To: nslu2-linux@yahoogroups.com
                  Subject: [nslu2-linux] "more" applet missing

                   

                  Ok, this is driving me insane and I am now resorting to this newsgroup as googling “NSLU2 more” doesn’t get me what I want (obviously) and the NSLU2 wiki doesn’t help.

                  I want to page long files, so do a cat filename |more (or simply more filename)  but the more applet doesn’t appear to be in busybox anymore.   I can see a symlink to /opt/bin/busybox to more, but when I type “busybox” by itself, more isn’t in the list (nor is it in the stock Linksys busybox in /bin).   I removed the symlink and reinstalled busybox and sure enough it no longer installs a link to “more” anymore either.

                  Where did it go, and where can I get it now?   I did a scan of all the unslung packages available and none stand out as providing what I need either (I have many many packages installed, I thought “maybe coreutils has it and I lost the coreutils-more application” but reinstalling that didn’t help either).

                  Regards

                  Tonymy01

                  --

                  .

                  Web Bug from http://geo.yahoo.com/serv?s=97359714/grpId=13216923/grpspId=1705004750/msgId=20969/stime=1202076455/nc1=4507179/nc2=4025338/nc3=5202322


                • John
                  Is there a reason you prefer more to the more commonly used less ? (ipkg install less)
                  Message 8 of 9 , Feb 6, 2008
                    Is there a reason you prefer "more" to the more commonly
                    used "less"? (ipkg install less)
                  • mneub
                    ... Thanks for the heads up...duh! I setup the log dir and it was clear...when google would parse my website during the night (when my cron jobs weren t
                    Message 9 of 9 , Feb 9, 2008
                      > Have you checked the log files for messages about disk errors?
                      >
                      > You might need first to turn logging on since, out of the box,
                      > slugos is quite minimal.

                      Thanks for the heads up...duh! I setup the log dir and it was
                      clear...when google would parse my website during the night (when my
                      cron jobs weren't running), the disk wouldn't respond and it would
                      mount it as read only.

                      By setting the allow_restart to 1
                      (http://www.nslu2-linux.org/wiki/FAQ/DealWithAutoSpinDownOnSeagateFreeAgent)
                      all seems to be fine now. I guess I can be comfortable in the fact my
                      new drive at least spins down when not in use.
                    Your message has been successfully submitted and would be delivered to recipients shortly.