Loading ...
Sorry, an error occurred while loading the content.

Debian: OOM: locale-gen

Expand Messages
  • markusingendahl
    Hi, it s not possible, to create the de_DE.UTF8 locale on my slug due to an Out Of Memory error. My slug isn t fattened (that means 32 MB RAM) and I have
    Message 1 of 3 , Jan 27, 2008
    • 0 Attachment
      Hi,

      it's not possible, to create the de_DE.UTF8 locale on my slug due to
      an Out Of Memory error.

      My slug isn't fattened (that means 32 MB RAM) and I have nearly one GB
      of swap (checked it ;-))

      Currently I cannot use any German Umlauts in my shell.

      Help is highly appreciated.

      Thanks in advance
      Markus :-)
    • Markus Ingendahl
      Hi, I managed to get it up and running after 3 hours! The reason: I followed the following guide to prepare to run Debian from a flash drive:
      Message 2 of 3 , Jan 27, 2008
      • 0 Attachment
        Hi,

        I managed to get it up and running after 3 hours!

        The reason: I followed the following guide to prepare to run Debian from
        a flash drive:
        http://www.cyrius.com/debian/nslu2/linux-on-flash.html

        That's what caused to OOM.
        I just skipped these "optimizations" and no OOM any more.

        Any idea why?

        Markus


        markusingendahl schrieb:
        >
        > Hi,
        >
        > it's not possible, to create the de_DE.UTF8 locale on my slug due to
        > an Out Of Memory error.
        >
        > My slug isn't fattened (that means 32 MB RAM) and I have nearly one GB
        > of swap (checked it ;-))
        >
        > Currently I cannot use any German Umlauts in my shell.
        >
        > Help is highly appreciated.
        >
        > Thanks in advance
        > Markus :-)
        >
        >
      • Adam Ward
        ... I had a similar problem when trying to install debian with a 256 MB swap. I ended up increasing it to 1 GB, with which it finally worked. There s a post
        Message 3 of 3 , Feb 1 3:56 PM
        • 0 Attachment
          On Monday 28 January 2008 04:40:31 Markus Ingendahl wrote:
          > Hi,
          >
          > I managed to get it up and running after 3 hours!
          >
          > The reason: I followed the following guide to prepare to run Debian from
          > a flash drive:
          > http://www.cyrius.com/debian/nslu2/linux-on-flash.html
          >
          > That's what caused to OOM.
          > I just skipped these "optimizations" and no OOM any more.
          >
          > Any idea why?
          >

          I had a similar problem when trying to install debian with a 256 MB swap.
          I ended up increasing it to 1 GB, with which it finally worked.

          There's a post about the linux kernel overcommitting it's swap (check my
          thread from a few days ago - there's a link to the issue). I think this is
          what's happening..

          One of the optimisations given on the cyrius page is reducing the swap usage,
          which I can see being a problem on the slug because there's not much memory
          anyway.
        Your message has been successfully submitted and would be delivered to recipients shortly.