Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] how to Install lighttpd, fastcgi, PHP4.2 on the unslung nslu2 linux so i can

Expand Messages
  • knowvb
    Hi Brendan, thanks for your help and imput here. I can execut step a and steb b but when i execut step c i get the error below... # find
    Message 1 of 30 , Jan 26, 2008
    View Source
    • 0 Attachment
      Hi Brendan, thanks for your help and imput here.

      I can execut step a and steb b but when i execut step c i get the error
      below...


      # find /opt/share/www/lighttpd -type d -exec chmod 2755 {} \; -print
      BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary

      No help available.

      #

      Im not sure what this means.

      many thanks
      k


      Brendan Reid wrote:
      >
      > steve and I are telling you to do the same things......
      >
      > try this (which is almost the same as steve's command)
      >
      > a) change the ownership of the files to be served up by the web server
      >
      > chown -R nobody:everyone /home/yourwebdir
      >
      > check the documentation if owner "nobody" and group "everyone" is right
      > for
      > your webserver
      > sometimes "root" and "root" are better
      >
      > b) set ALL files to have permissions 644 (rw-r--r--)
      >
      > chmod -R 0644 /home/yourwebdir
      >
      > c) set ALL directories to executable
      >
      > find /home/yourwebdir -type d -exec chmod 2755 {} \; -print
      >
      > If this works then you can automate it for the future by putting in a
      > script
      > to make it easier to run every time you change files/dirs in your web
      > pages
      >
      > bren
      >
      >

      --
      View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15115765.html
      Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
    • Brendan Reid
      OK steve my unslung has BusyBox v0.60.4 so their must be a change. don t worry just do it manually as a test chmod 2755 /home/yourwebfiles repeat manually for
      Message 2 of 30 , Jan 26, 2008
      View Source
      • 0 Attachment
        OK steve

        my unslung has BusyBox v0.60.4 so their must be a change.
        don't worry just do it manually as a test

        chmod 2755 /home/yourwebfiles
        repeat manually for all folders below this one

        if that still doesnt work then its time to examine if your web application is pulling files (eg templates or themes) from another folder

        if you revisit my script above you will see that is what i was doing

        hope that helps

        bren

        On 27/01/2008, knowvb <andyhartleyuk@...> wrote:


        Hi Brendan, thanks for your help and imput here.

        I can execut step a and steb b but when i execut step c i get the error
        below...

        # find /opt/share/www/lighttpd -type d -exec chmod 2755 {} \; -print
        BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary

        No help available.

        #

        Im not sure what this means.

        many thanks
        k

        Brendan Reid wrote:
        >

        > steve and I are telling you to do the same things......
        >
        > try this (which is almost the same as steve's command)
        >
        > a) change the ownership of the files to be served up by the web server
        >
        > chown -R nobody:everyone /home/yourwebdir
        >
        > check the documentation if owner "nobody" and group "everyone" is right
        > for
        > your webserver
        > sometimes "root" and "root" are better
        >
        > b) set ALL files to have permissions 644 (rw-r--r--)
        >
        > chmod -R 0644 /home/yourwebdir
        >
        > c) set ALL directories to executable
        >
        > find /home/yourwebdir -type d -exec chmod 2755 {} \; -print
        >
        > If this works then you can automate it for the future by putting in a
        > script
        > to make it easier to run every time you change files/dirs in your web
        > pages
        >
        > bren
        >
        >

        --
        View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15115765.html
        Sent from the Nslu2 - Linux mailing list archive at Nabble.com.


      • Brendan Reid
        and I assume you are aware of ls -l to show you results of your permissions and owner changes..... bren
        Message 3 of 30 , Jan 26, 2008
        View Source
        • 0 Attachment
          and I assume you are aware of

          ls -l

          to show you results of your permissions and owner changes.....

          bren
        • sdm485
          Probably close now. There is a typo in Brendan s script. Try (c) without the 2 in 2755. Just 755. The commands chown and chmod are fundamental to manipulating
          Message 4 of 30 , Jan 26, 2008
          View Source
          • 0 Attachment
            Probably close now. There is a typo in Brendan's script. Try (c)
            without the 2 in 2755. Just 755.

            The commands chown and chmod are fundamental to manipulating the
            security system and worth becoming familiar with.

            If it still doesn't work then, as root:

            chown 755 /opt/share/www/lighttpd -R

            Don't expose your server beyond your local network until you have
            confirmed the proper permissions for lighttpd. I am sure Brendan's
            suggestion is the better one with regard to security.

            Steve



            --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@...> wrote:
            >
            >
            > Hi Brendan, thanks for your help and imput here.
            >
            > I can execut step a and steb b but when i execut step c i get the
            error
            > below...
            >
            >
            > # find /opt/share/www/lighttpd -type d -exec chmod 2755 {} \; -print
            > BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary
            >
            > No help available.
            >
            > #
            >
            > Im not sure what this means.
            >
            > many thanks
            > k
            >
            >
            > Brendan Reid wrote:
            > >
            > > steve and I are telling you to do the same things......
            > >
            > > try this (which is almost the same as steve's command)
            > >
            > > a) change the ownership of the files to be served up by the web
            server
            > >
            > > chown -R nobody:everyone /home/yourwebdir
            > >
            > > check the documentation if owner "nobody" and group "everyone" is
            right
            > > for
            > > your webserver
            > > sometimes "root" and "root" are better
            > >
            > > b) set ALL files to have permissions 644 (rw-r--r--)
            > >
            > > chmod -R 0644 /home/yourwebdir
            > >
            > > c) set ALL directories to executable
            > >
            > > find /home/yourwebdir -type d -exec chmod 2755 {} \; -print
            > >
            > > If this works then you can automate it for the future by putting
            in a
            > > script
            > > to make it easier to run every time you change files/dirs in your
            web
            > > pages
            > >
            > > bren
            > >
            > >
            >
            > --
            > View this message in context: http://www.nabble.com/how-to-Install-
            lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-
            this.......-tp15101230p15115765.html
            > Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
            >
          • sdm485
            I am wrong about the typo; sorry Brendan. I will take a refresher on chmod. Steve ... print ... is ... putting ... your ... Install- ... use-
            Message 5 of 30 , Jan 26, 2008
            View Source
            • 0 Attachment
              I am wrong about the typo; sorry Brendan. I will take a refresher on
              chmod.
              Steve

              --- In nslu2-linux@yahoogroups.com, "sdm485" <steve@...> wrote:
              >
              > Probably close now. There is a typo in Brendan's script. Try (c)
              > without the 2 in 2755. Just 755.
              >
              > The commands chown and chmod are fundamental to manipulating the
              > security system and worth becoming familiar with.
              >
              > If it still doesn't work then, as root:
              >
              > chown 755 /opt/share/www/lighttpd -R
              >
              > Don't expose your server beyond your local network until you have
              > confirmed the proper permissions for lighttpd. I am sure Brendan's
              > suggestion is the better one with regard to security.
              >
              > Steve
              >
              >
              >
              > --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@> wrote:
              > >
              > >
              > > Hi Brendan, thanks for your help and imput here.
              > >
              > > I can execut step a and steb b but when i execut step c i get the
              > error
              > > below...
              > >
              > >
              > > # find /opt/share/www/lighttpd -type d -exec chmod 2755 {} \; -
              print
              > > BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary
              > >
              > > No help available.
              > >
              > > #
              > >
              > > Im not sure what this means.
              > >
              > > many thanks
              > > k
              > >
              > >
              > > Brendan Reid wrote:
              > > >
              > > > steve and I are telling you to do the same things......
              > > >
              > > > try this (which is almost the same as steve's command)
              > > >
              > > > a) change the ownership of the files to be served up by the web
              > server
              > > >
              > > > chown -R nobody:everyone /home/yourwebdir
              > > >
              > > > check the documentation if owner "nobody" and group "everyone"
              is
              > right
              > > > for
              > > > your webserver
              > > > sometimes "root" and "root" are better
              > > >
              > > > b) set ALL files to have permissions 644 (rw-r--r--)
              > > >
              > > > chmod -R 0644 /home/yourwebdir
              > > >
              > > > c) set ALL directories to executable
              > > >
              > > > find /home/yourwebdir -type d -exec chmod 2755 {} \; -print
              > > >
              > > > If this works then you can automate it for the future by
              putting
              > in a
              > > > script
              > > > to make it easier to run every time you change files/dirs in
              your
              > web
              > > > pages
              > > >
              > > > bren
              > > >
              > > >
              > >
              > > --
              > > View this message in context: http://www.nabble.com/how-to-
              Install-
              > lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-
              use-
              > this.......-tp15101230p15115765.html
              > > Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
              > >
              >
            • Scott Ruckh
              This is what you said sdm485 ... you might try this instead: find /opt/share/www/lighttpd -type d -print0 | xargs -0 chmod 2755 If it executes it would be
              Message 6 of 30 , Jan 26, 2008
              View Source
              • 0 Attachment
                This is what you said sdm485
                > I am wrong about the typo; sorry Brendan. I will take a refresher on
                > chmod.
                > Steve
                >
                > --- In nslu2-linux@yahoogroups.com, "sdm485" <steve@...> wrote:
                >>
                >> Probably close now. There is a typo in Brendan's script. Try (c)
                >> without the 2 in 2755. Just 755.
                >>
                >> The commands chown and chmod are fundamental to manipulating the
                >> security system and worth becoming familiar with.
                >>
                >> If it still doesn't work then, as root:
                >>
                >> chown 755 /opt/share/www/lighttpd -R
                >>
                >> Don't expose your server beyond your local network until you have
                >> confirmed the proper permissions for lighttpd. I am sure Brendan's
                >> suggestion is the better one with regard to security.
                >>
                >> Steve
                >>
                >>
                >>
                >> --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@> wrote:
                >> > # find /opt/share/www/lighttpd -type d -exec chmod 2755 {} \; -
                > print
                >> > BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary
                >> >


                you might try this instead:
                find /opt/share/www/lighttpd -type d -print0 | xargs -0 chmod 2755

                If it executes it would be faster. It works on my Unslung NSLU2 but I may
                have different find and xargs installed. I don't necessarily agree with
                the settings, but it is a different approach to what was originally
                posted.

                Based on OP I did install Musicbrowser to see what it is all about. I can
                confirm that it runs fine on an Unslung NSLU2 with lighttpd.
              • Scott Ruckh
                This is what you said Scott Ruckh ... By the way there are no other sub-directories with musicbrowser so the exercise of changing the permissions on
                Message 7 of 30 , Jan 26, 2008
                View Source
                • 0 Attachment
                  This is what you said Scott Ruckh
                  >
                  >
                  > This is what you said sdm485
                  >> I am wrong about the typo; sorry Brendan. I will take a refresher on
                  >> chmod.
                  >> Steve
                  >>
                  >> --- In nslu2-linux@yahoogroups.com, "sdm485" <steve@...> wrote:
                  >>>
                  >>> Probably close now. There is a typo in Brendan's script. Try (c)
                  >>> without the 2 in 2755. Just 755.
                  >>>
                  >>> The commands chown and chmod are fundamental to manipulating the
                  >>> security system and worth becoming familiar with.
                  >>>
                  >>> If it still doesn't work then, as root:
                  >>>
                  >>> chown 755 /opt/share/www/lighttpd -R
                  >>>
                  >>> Don't expose your server beyond your local network until you have
                  >>> confirmed the proper permissions for lighttpd. I am sure Brendan's
                  >>> suggestion is the better one with regard to security.
                  >>>
                  >>> Steve
                  >>>
                  >>>
                  >>>
                  >>> --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@> wrote:
                  >>> > # find /opt/share/www/lighttpd -type d -exec chmod 2755 {} \; -
                  >> print
                  >>> > BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary
                  >>> >
                  >
                  >
                  > you might try this instead:
                  > find /opt/share/www/lighttpd -type d -print0 | xargs -0 chmod 2755
                  >
                  > If it executes it would be faster. It works on my Unslung NSLU2 but I may
                  > have different find and xargs installed. I don't necessarily agree with
                  > the settings, but it is a different approach to what was originally
                  > posted.
                  >
                  > Based on OP I did install Musicbrowser to see what it is all about. I can
                  > confirm that it runs fine on an Unslung NSLU2 with lighttpd.

                  By the way there are no other sub-directories with musicbrowser so the
                  exercise of changing the permissions on sub-directories is not even
                  necessary.
                • Brendan Reid
                  the original script (i am no chmod or chown expert) is here http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver a fair way down the page if you have
                  Message 8 of 30 , Jan 26, 2008
                  View Source
                  • 0 Attachment
                    the original script (i am no chmod or chown expert) is here
                    http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver
                    a fair way down the page

                    if you have any *.cgi see what it says at the bottom of the script section

                    Scott's alternative looks good but I don't think speed is the main thing here!

                    Note that the permissions pattern i suggest is for thttpd and not for lighttpd - feel free to suggest alt Scott

                    Check lighttpd docs for suggested permissions in case they are different - I was under impression same for most webservers but might be wrong

                    bren
                  • knowvb
                    Guys thanks for all your help here. Still pulling my hair out here with no luck. I tried find /opt/share/www/lighttpd -type d -print0 | xargs -0 chmod 2755 but
                    Message 9 of 30 , Jan 27, 2008
                    View Source
                    • 0 Attachment
                      Guys thanks for all your help here.

                      Still pulling my hair out here with no luck.
                      I tried
                      find /opt/share/www/lighttpd -type d -print0 | xargs -0 chmod 2755

                      but got the following error...
                      -sh: xargs: not found
                      BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary

                      No help available.

                      Lets assume i start everything from a newly installed unslung system which
                      is unslinged. Nothing else has been done. it is a completly new installed
                      unslung system. I telnet into the slug with username root and password
                      ********

                      These are the steps i am following......

                      1/
                      install lighttpd with the command: ipkg install lighttpd

                      2/
                      install php-fcgi with command: ipkg install php-fcgi

                      3/
                      edit the lighttpd.conf file in the /opt/etc/lighttpd directory.
                      Remove the '#' on the line "mod_fastcgi" to enable the module. Make a
                      note of the server.document-root value so you know where to put the
                      files. Make sure that the 'server.port' is the one you want.
                      The server.document root value is /opt/share/www/lighttpd and the port is
                      8081.

                      4/
                      make sure the fastcgi.server is setup right. The following is what was
                      suggested and then below is what i have. I used vi and then ZZ to save and
                      exit.
                      suggested......
                      #### fastcgi module
                      ## read fastcgi.txt for more info
                      fastcgi.server = ( ".php" =>
                      ( "localhost" =>
                      (
                      "socket" => "/tmp/php-fastcgi.socket",
                      "bin-path" => "/opt/bin/php-fcgi"
                      )
                      )
                      )



                      what i have........

                      #### fastcgi module
                      ## read fastcgi.txt for more info
                      #fastcgi.server = ( ".php" =>
                      # ( "localhost" =>
                      # (
                      # "socket" => "/tmp/php-fastcgi.socket",
                      # "bin-path" => "/opt/bin/php-fcgi"
                      # )
                      # )
                      # )



                      5/
                      I test this set up by using firefox and ie on a windows machine by
                      navigating to the slugs local ip address. eg. http://192.168.0.3:8081 and a
                      message appears saying lighttpd server is running.

                      6/
                      I then delete the files in the directory /opt/share/www/lighttpd and then
                      put all the files from the music browser unziped file into this folder. This
                      includes the index.php for music browser. If i then use firefox or ie to
                      navigate to http://192.168.0.3:8081 and get the 403 - Forbidden error

                      7/
                      arrrrrrrgggg!

                      8/
                      try all the suggestions in this forum thread regarding permissions.

                      9/
                      arrrrrrrgggggg!



                      on the music browser website is says a verified instalation on the slug is
                      with lighttpd, fastcgi, PHP4.2
                      Perhaps its a dumb question but i can see i have only ipkg installed
                      lighttpd and php-fcgi. Is php-fcgi php4.2?
                      When i do a test on the initial install of lighttpd and navigate to the
                      index.html file, the it appaear successfull. Is this anything to do with the
                      index.html file having these permissions?....
                      -rw-r--r-- 1 root root 135 Jan 26 15:38 index.html


                      I know im a noob here and realy appreciate all the help. This is a fresh
                      installed unslung system so hopefuly this should make things a little
                      easier.

                      Many thanks

                      k


                      Scott Ruckh wrote:
                      >
                      >
                      >
                      > This is what you said sdm485
                      >> I am wrong about the typo; sorry Brendan. I will take a refresher on
                      >> chmod.
                      >> Steve
                      >>
                      >> --- In nslu2-linux@yahoogroups.com, "sdm485" <steve@...> wrote:
                      >>>
                      >>> Probably close now. There is a typo in Brendan's script. Try (c)
                      >>> without the 2 in 2755. Just 755.
                      >>>
                      >>> The commands chown and chmod are fundamental to manipulating the
                      >>> security system and worth becoming familiar with.
                      >>>
                      >>> If it still doesn't work then, as root:
                      >>>
                      >>> chown 755 /opt/share/www/lighttpd -R
                      >>>
                      >>> Don't expose your server beyond your local network until you have
                      >>> confirmed the proper permissions for lighttpd. I am sure Brendan's
                      >>> suggestion is the better one with regard to security.
                      >>>
                      >>> Steve
                      >>>
                      >>>
                      >>>
                      >>> --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@> wrote:
                      >>> > # find /opt/share/www/lighttpd -type d -exec chmod 2755 {} \; -
                      >> print
                      >>> > BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary
                      >>> >
                      >
                      >
                      > you might try this instead:
                      > find /opt/share/www/lighttpd -type d -print0 | xargs -0 chmod 2755
                      >
                      > If it executes it would be faster. It works on my Unslung NSLU2 but I may
                      > have different find and xargs installed. I don't necessarily agree with
                      > the settings, but it is a different approach to what was originally
                      > posted.
                      >
                      > Based on OP I did install Musicbrowser to see what it is all about. I can
                      > confirm that it runs fine on an Unslung NSLU2 with lighttpd.
                      >
                      >
                      >

                      --
                      View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15121105.html
                      Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                    • Scott Ruckh
                      This is what you said knowvb ... by default when you unzipped musicbrowser it would have created a sub-directory called musicbrowser. You want to make sure
                      Message 10 of 30 , Jan 27, 2008
                      View Source
                      • 0 Attachment
                        This is what you said knowvb
                        >
                        > Guys thanks for all your help here.
                        >
                        > Still pulling my hair out here with no luck.
                        > I tried
                        > find /opt/share/www/lighttpd -type d -print0 | xargs -0 chmod 2755
                        >
                        > but got the following error...
                        > -sh: xargs: not found
                        > BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary
                        >
                        > No help available.
                        >
                        > Lets assume i start everything from a newly installed unslung system which
                        > is unslinged. Nothing else has been done. it is a completly new installed
                        > unslung system. I telnet into the slug with username root and password
                        > ********
                        >
                        > These are the steps i am following......
                        >
                        > 1/
                        > install lighttpd with the command: ipkg install lighttpd
                        >
                        > 2/
                        > install php-fcgi with command: ipkg install php-fcgi
                        >
                        > 3/
                        > edit the lighttpd.conf file in the /opt/etc/lighttpd directory.
                        > Remove the '#' on the line "mod_fastcgi" to enable the module. Make a
                        > note of the server.document-root value so you know where to put the
                        > files. Make sure that the 'server.port' is the one you want.
                        > The server.document root value is /opt/share/www/lighttpd and the port is
                        > 8081.
                        >
                        > 4/
                        > make sure the fastcgi.server is setup right. The following is what was
                        > suggested and then below is what i have. I used vi and then ZZ to save and
                        > exit.
                        > suggested......
                        > #### fastcgi module
                        > ## read fastcgi.txt for more info
                        > fastcgi.server = ( ".php" =>
                        > ( "localhost" =>
                        > (
                        > "socket" => "/tmp/php-fastcgi.socket",
                        > "bin-path" => "/opt/bin/php-fcgi"
                        > )
                        > )
                        > )
                        >
                        >
                        >
                        > what i have........
                        >
                        > #### fastcgi module
                        > ## read fastcgi.txt for more info
                        > #fastcgi.server = ( ".php" =>
                        > # ( "localhost" =>
                        > # (
                        > # "socket" => "/tmp/php-fastcgi.socket",
                        > # "bin-path" => "/opt/bin/php-fcgi"
                        > # )
                        > # )
                        > # )
                        >
                        >
                        >
                        > 5/
                        > I test this set up by using firefox and ie on a windows machine by
                        > navigating to the slugs local ip address. eg. http://192.168.0.3:8081 and
                        > a
                        > message appears saying lighttpd server is running.
                        >
                        > 6/
                        > I then delete the files in the directory /opt/share/www/lighttpd and then
                        > put all the files from the music browser unziped file into this folder.
                        > This
                        > includes the index.php for music browser. If i then use firefox or ie to
                        > navigate to http://192.168.0.3:8081 and get the 403 - Forbidden error
                        >
                        > 7/
                        > arrrrrrrgggg!
                        >
                        > 8/
                        > try all the suggestions in this forum thread regarding permissions.
                        >
                        > 9/
                        > arrrrrrrgggggg!
                        >


                        by default when you unzipped musicbrowser it would have created a
                        sub-directory called musicbrowser.

                        You want to make sure that the user running lighttpd has permisions to
                        read the files in the musicbrowser directory including the musicbrowser
                        directory itself (see previous posts on how do to this). Again forget
                        about the find commands instructions as they are not needed because the
                        musicbrowser directory contains no sub-directories.

                        modify the index.php file (for musicbrowser) as the musicbrowser
                        documentation suggests.

                        Then the URL you need to use is:

                        http://192.168.0.3:8081/musicbrowser/

                        You get the 403 error because you deleted the default files that are in
                        /opt/share/www/lighttpd directory and there is nothing to serve up with
                        the URL that you are using.
                      • knowvb
                        Hi Scott, thanks for the quick reply. I am actualy unzipping on the windows machine. I then copy all these files through the window network share into /public
                        Message 11 of 30 , Jan 27, 2008
                        View Source
                        • 0 Attachment
                          Hi Scott, thanks for the quick reply.

                          I am actualy unzipping on the windows machine.
                          I then copy all these files through the window network share into /public on
                          the slug.

                          I then telnet into the slug and type
                          cp /public /opt/share/www/lighttpd

                          this effectivly copies all the unzipped music browser files in /public to
                          the /opt/share/www/lighttpd.

                          I do this because i do not know how to unzip on the slug itself.

                          Could this be where i am going wrong?

                          many thanks again.
                          k



                          Scott Ruckh wrote:
                          >
                          > This is what you said knowvb
                          >>
                          >> Guys thanks for all your help here.
                          >>
                          >> Still pulling my hair out here with no luck.
                          >> I tried
                          >> find /opt/share/www/lighttpd -type d -print0 | xargs -0 chmod 2755
                          >>
                          >> but got the following error...
                          >> -sh: xargs: not found
                          >> BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary
                          >>
                          >> No help available.
                          >>
                          >> Lets assume i start everything from a newly installed unslung system
                          >> which
                          >> is unslinged. Nothing else has been done. it is a completly new installed
                          >> unslung system. I telnet into the slug with username root and password
                          >> ********
                          >>
                          >> These are the steps i am following......
                          >>
                          >> 1/
                          >> install lighttpd with the command: ipkg install lighttpd
                          >>
                          >> 2/
                          >> install php-fcgi with command: ipkg install php-fcgi
                          >>
                          >> 3/
                          >> edit the lighttpd.conf file in the /opt/etc/lighttpd directory.
                          >> Remove the '#' on the line "mod_fastcgi" to enable the module. Make a
                          >> note of the server.document-root value so you know where to put the
                          >> files. Make sure that the 'server.port' is the one you want.
                          >> The server.document root value is /opt/share/www/lighttpd and the port is
                          >> 8081.
                          >>
                          >> 4/
                          >> make sure the fastcgi.server is setup right. The following is what was
                          >> suggested and then below is what i have. I used vi and then ZZ to save
                          >> and
                          >> exit.
                          >> suggested......
                          >> #### fastcgi module
                          >> ## read fastcgi.txt for more info
                          >> fastcgi.server = ( ".php" =>
                          >> ( "localhost" =>
                          >> (
                          >> "socket" => "/tmp/php-fastcgi.socket",
                          >> "bin-path" => "/opt/bin/php-fcgi"
                          >> )
                          >> )
                          >> )
                          >>
                          >>
                          >>
                          >> what i have........
                          >>
                          >> #### fastcgi module
                          >> ## read fastcgi.txt for more info
                          >> #fastcgi.server = ( ".php" =>
                          >> # ( "localhost" =>
                          >> # (
                          >> # "socket" =>
                          >> "/tmp/php-fastcgi.socket",
                          >> # "bin-path" => "/opt/bin/php-fcgi"
                          >> # )
                          >> # )
                          >> # )
                          >>
                          >>
                          >>
                          >> 5/
                          >> I test this set up by using firefox and ie on a windows machine by
                          >> navigating to the slugs local ip address. eg. http://192.168.0.3:8081 and
                          >> a
                          >> message appears saying lighttpd server is running.
                          >>
                          >> 6/
                          >> I then delete the files in the directory /opt/share/www/lighttpd and then
                          >> put all the files from the music browser unziped file into this folder.
                          >> This
                          >> includes the index.php for music browser. If i then use firefox or ie to
                          >> navigate to http://192.168.0.3:8081 and get the 403 - Forbidden error
                          >>
                          >> 7/
                          >> arrrrrrrgggg!
                          >>
                          >> 8/
                          >> try all the suggestions in this forum thread regarding permissions.
                          >>
                          >> 9/
                          >> arrrrrrrgggggg!
                          >>
                          >
                          >
                          > by default when you unzipped musicbrowser it would have created a
                          > sub-directory called musicbrowser.
                          >
                          > You want to make sure that the user running lighttpd has permisions to
                          > read the files in the musicbrowser directory including the musicbrowser
                          > directory itself (see previous posts on how do to this). Again forget
                          > about the find commands instructions as they are not needed because the
                          > musicbrowser directory contains no sub-directories.
                          >
                          > modify the index.php file (for musicbrowser) as the musicbrowser
                          > documentation suggests.
                          >
                          > Then the URL you need to use is:
                          >
                          > http://192.168.0.3:8081/musicbrowser/
                          >
                          > You get the 403 error because you deleted the default files that are in
                          > /opt/share/www/lighttpd directory and there is nothing to serve up with
                          > the URL that you are using.
                          >
                          >

                          --
                          View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15121542.html
                          Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                        • Scott Ruckh
                          This is what you said knowvb ... ipkg install unzip copy zip file to /opt/share/www/lighttpd unzip musicbrowser.zip change permissions on musicbrowser
                          Message 12 of 30 , Jan 27, 2008
                          View Source
                          • 0 Attachment
                            This is what you said knowvb
                            >
                            > Hi Scott, thanks for the quick reply.
                            >
                            > I am actualy unzipping on the windows machine.
                            > I then copy all these files through the window network share into /public
                            > on
                            > the slug.
                            >
                            > I then telnet into the slug and type
                            > cp /public /opt/share/www/lighttpd
                            >
                            > this effectivly copies all the unzipped music browser files in /public to
                            > the /opt/share/www/lighttpd.
                            >
                            > I do this because i do not know how to unzip on the slug itself.
                            >
                            > Could this be where i am going wrong?
                            >

                            ipkg install unzip
                            copy zip file to /opt/share/www/lighttpd
                            unzip musicbrowser.zip
                            change permissions on musicbrowser directory.

                            I would show you my configuration, but I think it would just be more
                            confusing as I am not using /opt/share/www/lighttpd as my "root" and have
                            set up virtual hosts.
                          • knowvb
                            Thanks Scott. Ive just done a clean unsling so i will start with all the steps again using your unzip method. I know you mentioned about the instructions
                            Message 13 of 30 , Jan 27, 2008
                            View Source
                            • 0 Attachment
                              Thanks Scott.

                              Ive just done a clean unsling so i will start with all the steps again using
                              your unzip method.

                              I know you mentioned about the instructions earlier to set up permissions
                              but im still uncleal about these. After i use your unzip method, could you
                              confirm what i need to do for permissions please?

                              many thanks
                              k

                              Scott Ruckh wrote:
                              >
                              >
                              >
                              > This is what you said knowvb
                              >>
                              >> Hi Scott, thanks for the quick reply.
                              >>
                              >> I am actualy unzipping on the windows machine.
                              >> I then copy all these files through the window network share into /public
                              >> on
                              >> the slug.
                              >>
                              >> I then telnet into the slug and type
                              >> cp /public /opt/share/www/lighttpd
                              >>
                              >> this effectivly copies all the unzipped music browser files in /public to
                              >> the /opt/share/www/lighttpd.
                              >>
                              >> I do this because i do not know how to unzip on the slug itself.
                              >>
                              >> Could this be where i am going wrong?
                              >>
                              >
                              > ipkg install unzip
                              > copy zip file to /opt/share/www/lighttpd
                              > unzip musicbrowser.zip
                              > change permissions on musicbrowser directory.
                              >
                              > I would show you my configuration, but I think it would just be more
                              > confusing as I am not using /opt/share/www/lighttpd as my "root" and have
                              > set up virtual hosts.
                              >
                              >

                              --
                              View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15122140.html
                              Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                            • sdm485
                              I just tried the installation method and discovered that musicbrowser will not work if the files themselves are in /opt/share/www/lighttpd. However they will
                              Message 14 of 30 , Jan 27, 2008
                              View Source
                              • 0 Attachment
                                I just tried the installation method and discovered that musicbrowser
                                will not work if the files themselves are in /opt/share/www/lighttpd.
                                However they will if the files are in
                                /opt/share/www/lighttpd/musicbrowser/. In your case if you did
                                http://192.168.0.3/ you would get 404 not found (no index.html). If
                                you put in: http://192.168.0.3/musicbrowser/ you would get it. If you
                                have to do http://192.168.0.3/musicbrowser/index.php to get it, it is
                                a lighttpd configuration issue.

                                The default permissions on the musicbrowser folder is 755 and the
                                files 744 which is fine. I am running as root. No changes to
                                permissions or ownership.

                                Steve


                                --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@...> wrote:
                                >
                                >
                                > Thanks Scott.
                                >
                                > Ive just done a clean unsling so i will start with all the steps
                                again using
                                > your unzip method.
                                >
                                > I know you mentioned about the instructions earlier to set up
                                permissions
                                > but im still uncleal about these. After i use your unzip method,
                                could you
                                > confirm what i need to do for permissions please?
                                >
                                > many thanks
                                > k
                                >
                                > Scott Ruckh wrote:
                                > >
                                > >
                                > >
                                > > This is what you said knowvb
                                > >>
                                > >> Hi Scott, thanks for the quick reply.
                                > >>
                                > >> I am actualy unzipping on the windows machine.
                                > >> I then copy all these files through the window network share into
                                /public
                                > >> on
                                > >> the slug.
                                > >>
                                > >> I then telnet into the slug and type
                                > >> cp /public /opt/share/www/lighttpd
                                > >>
                                > >> this effectivly copies all the unzipped music browser files in
                                /public to
                                > >> the /opt/share/www/lighttpd.
                                > >>
                                > >> I do this because i do not know how to unzip on the slug itself.
                                > >>
                                > >> Could this be where i am going wrong?
                                > >>
                                > >
                                > > ipkg install unzip
                                > > copy zip file to /opt/share/www/lighttpd
                                > > unzip musicbrowser.zip
                                > > change permissions on musicbrowser directory.
                                > >
                                > > I would show you my configuration, but I think it would just be more
                                > > confusing as I am not using /opt/share/www/lighttpd as my "root"
                                and have
                                > > set up virtual hosts.
                                > >
                                > >
                                >
                                > --
                                > View this message in context:
                                http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15122140.html
                                > Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                >
                              • knowvb
                                Thanks steve. i ll bear that in mind. Im having problems a little earlier this time in my step by step directions. I think the lighttpd web server will not
                                Message 15 of 30 , Jan 27, 2008
                                View Source
                                • 0 Attachment
                                  Thanks steve. i'll bear that in mind.

                                  Im having problems a little earlier this time in my step by step directions.
                                  I think the lighttpd web server will not start. when i type #
                                  /opt/etc/init.d/S80lighttpd

                                  The following error occurs....

                                  Starting web server: lighttpd
                                  /opt/sbin/lighttpd: error while loading shared libraries: libssl.so.0.9.7:
                                  canno
                                  t open shared object file: No such file or directory
                                  #

                                  Any ideas? Obviously a file cannot be found but i have no idea beyond that
                                  apart from to format the unsling and start again.

                                  many thanks
                                  k


                                  sdm485 wrote:
                                  >
                                  > I just tried the installation method and discovered that musicbrowser
                                  > will not work if the files themselves are in /opt/share/www/lighttpd.
                                  > However they will if the files are in
                                  > /opt/share/www/lighttpd/musicbrowser/. In your case if you did
                                  > http://192.168.0.3/ you would get 404 not found (no index.html). If
                                  > you put in: http://192.168.0.3/musicbrowser/ you would get it. If you
                                  > have to do http://192.168.0.3/musicbrowser/index.php to get it, it is
                                  > a lighttpd configuration issue.
                                  >
                                  > The default permissions on the musicbrowser folder is 755 and the
                                  > files 744 which is fine. I am running as root. No changes to
                                  > permissions or ownership.
                                  >
                                  > Steve
                                  >
                                  >
                                  > --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@...> wrote:
                                  >>
                                  >>
                                  >> Thanks Scott.
                                  >>
                                  >> Ive just done a clean unsling so i will start with all the steps
                                  > again using
                                  >> your unzip method.
                                  >>
                                  >> I know you mentioned about the instructions earlier to set up
                                  > permissions
                                  >> but im still uncleal about these. After i use your unzip method,
                                  > could you
                                  >> confirm what i need to do for permissions please?
                                  >>
                                  >> many thanks
                                  >> k
                                  >>
                                  >> Scott Ruckh wrote:
                                  >> >
                                  >> >
                                  >> >
                                  >> > This is what you said knowvb
                                  >> >>
                                  >> >> Hi Scott, thanks for the quick reply.
                                  >> >>
                                  >> >> I am actualy unzipping on the windows machine.
                                  >> >> I then copy all these files through the window network share into
                                  > /public
                                  >> >> on
                                  >> >> the slug.
                                  >> >>
                                  >> >> I then telnet into the slug and type
                                  >> >> cp /public /opt/share/www/lighttpd
                                  >> >>
                                  >> >> this effectivly copies all the unzipped music browser files in
                                  > /public to
                                  >> >> the /opt/share/www/lighttpd.
                                  >> >>
                                  >> >> I do this because i do not know how to unzip on the slug itself.
                                  >> >>
                                  >> >> Could this be where i am going wrong?
                                  >> >>
                                  >> >
                                  >> > ipkg install unzip
                                  >> > copy zip file to /opt/share/www/lighttpd
                                  >> > unzip musicbrowser.zip
                                  >> > change permissions on musicbrowser directory.
                                  >> >
                                  >> > I would show you my configuration, but I think it would just be more
                                  >> > confusing as I am not using /opt/share/www/lighttpd as my "root"
                                  > and have
                                  >> > set up virtual hosts.
                                  >> >
                                  >> >
                                  >>
                                  >> --
                                  >> View this message in context:
                                  > http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15122140.html
                                  >> Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                  >>
                                  >
                                  >
                                  >
                                  >

                                  --
                                  View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15122706.html
                                  Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                • knowvb
                                  Ok, ive sorted the last error. i typed ipkg install openssl this has now allowed lighttpd to start. I ll continue with the other steps now and see how i go.
                                  Message 16 of 30 , Jan 27, 2008
                                  View Source
                                  • 0 Attachment
                                    Ok, ive sorted the last error. i typed
                                    ipkg install openssl

                                    this has now allowed lighttpd to start.

                                    I'll continue with the other steps now and see how i go.

                                    regards
                                    k

                                    knowvb wrote:
                                    >
                                    > Thanks steve. i'll bear that in mind.
                                    >
                                    > Im having problems a little earlier this time in my step by step
                                    > directions.
                                    > I think the lighttpd web server will not start. when i type #
                                    > /opt/etc/init.d/S80lighttpd
                                    >
                                    > The following error occurs....
                                    >
                                    > Starting web server: lighttpd
                                    > /opt/sbin/lighttpd: error while loading shared libraries: libssl.so.0.9.7:
                                    > canno
                                    > t open shared object file: No such file or directory
                                    > #
                                    >
                                    > Any ideas? Obviously a file cannot be found but i have no idea beyond that
                                    > apart from to format the unsling and start again.
                                    >
                                    > many thanks
                                    > k
                                    >
                                    >
                                    > sdm485 wrote:
                                    >>
                                    >> I just tried the installation method and discovered that musicbrowser
                                    >> will not work if the files themselves are in /opt/share/www/lighttpd.
                                    >> However they will if the files are in
                                    >> /opt/share/www/lighttpd/musicbrowser/. In your case if you did
                                    >> http://192.168.0.3/ you would get 404 not found (no index.html). If
                                    >> you put in: http://192.168.0.3/musicbrowser/ you would get it. If you
                                    >> have to do http://192.168.0.3/musicbrowser/index.php to get it, it is
                                    >> a lighttpd configuration issue.
                                    >>
                                    >> The default permissions on the musicbrowser folder is 755 and the
                                    >> files 744 which is fine. I am running as root. No changes to
                                    >> permissions or ownership.
                                    >>
                                    >> Steve
                                    >>
                                    >>
                                    >> --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@...> wrote:
                                    >>>
                                    >>>
                                    >>> Thanks Scott.
                                    >>>
                                    >>> Ive just done a clean unsling so i will start with all the steps
                                    >> again using
                                    >>> your unzip method.
                                    >>>
                                    >>> I know you mentioned about the instructions earlier to set up
                                    >> permissions
                                    >>> but im still uncleal about these. After i use your unzip method,
                                    >> could you
                                    >>> confirm what i need to do for permissions please?
                                    >>>
                                    >>> many thanks
                                    >>> k
                                    >>>
                                    >>> Scott Ruckh wrote:
                                    >>> >
                                    >>> >
                                    >>> >
                                    >>> > This is what you said knowvb
                                    >>> >>
                                    >>> >> Hi Scott, thanks for the quick reply.
                                    >>> >>
                                    >>> >> I am actualy unzipping on the windows machine.
                                    >>> >> I then copy all these files through the window network share into
                                    >> /public
                                    >>> >> on
                                    >>> >> the slug.
                                    >>> >>
                                    >>> >> I then telnet into the slug and type
                                    >>> >> cp /public /opt/share/www/lighttpd
                                    >>> >>
                                    >>> >> this effectivly copies all the unzipped music browser files in
                                    >> /public to
                                    >>> >> the /opt/share/www/lighttpd.
                                    >>> >>
                                    >>> >> I do this because i do not know how to unzip on the slug itself.
                                    >>> >>
                                    >>> >> Could this be where i am going wrong?
                                    >>> >>
                                    >>> >
                                    >>> > ipkg install unzip
                                    >>> > copy zip file to /opt/share/www/lighttpd
                                    >>> > unzip musicbrowser.zip
                                    >>> > change permissions on musicbrowser directory.
                                    >>> >
                                    >>> > I would show you my configuration, but I think it would just be more
                                    >>> > confusing as I am not using /opt/share/www/lighttpd as my "root"
                                    >> and have
                                    >>> > set up virtual hosts.
                                    >>> >
                                    >>> >
                                    >>>
                                    >>> --
                                    >>> View this message in context:
                                    >> http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15122140.html
                                    >>> Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                    >>>
                                    >>
                                    >>
                                    >>
                                    >>
                                    >
                                    >

                                    --
                                    View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15123889.html
                                    Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                  • knowvb
                                    Thans for everyones help here. I seem to be getting a little further now. Im feeling rather numb here because i realised one of the problems wa that i didnt
                                    Message 17 of 30 , Jan 27, 2008
                                    View Source
                                    • 0 Attachment
                                      Thans for everyones help here. I seem to be getting a little further now.

                                      Im feeling rather numb here because i realised one of the problems wa that i
                                      didnt enale for fast cgi in lighttpd.conf by removing the #'s.

                                      Anyway, moving on.
                                      after removing the #'s i then restarted lighttpd but got the following
                                      error.....

                                      Starting web server: lighttpd
                                      /opt/sbin/lighttpd: error while loading shared libraries: libssl.so.0.9.7:
                                      canno
                                      t open shared object file: No such file or directory
                                      #

                                      I sorted this problem by ipkg install openssl.

                                      I then restarted lighttpd with no errors.

                                      I then navigated to 192.168.0.3 on the web browser in windows and got a 500
                                      internal server error.

                                      I then tried to start manual the php-fcgi by typing.....
                                      /opt/bin/php-fcgi

                                      but got the following error message......

                                      # /opt/bin/php-fcgi
                                      PHP Warning: PHP Startup: Unable to load dynamic library
                                      '/opt/lib/php/extensio
                                      ns/bz2.so' - libbz2.so.1.0: cannot open shared object file: No such file or
                                      dire
                                      ctory in Unknown on line 0
                                      PHP Warning: PHP Startup: Unable to load dynamic library
                                      '/opt/lib/php/extensio
                                      ns/dba.so' - libdb-4.2.so: cannot open shared object file: No such file or
                                      direc
                                      tory in Unknown on line 0
                                      PHP Warning: PHP Startup: Unable to load dynamic library
                                      '/opt/lib/php/extensio
                                      ns/xsl.so' - libexslt.so.0: cannot open shared object file: No such file or
                                      dire
                                      ctory in Unknown on line 0

                                      could this be part of the problem?

                                      many thanks again.
                                      k


                                      sdm485 wrote:
                                      >
                                      > I just tried the installation method and discovered that musicbrowser
                                      > will not work if the files themselves are in /opt/share/www/lighttpd.
                                      > However they will if the files are in
                                      > /opt/share/www/lighttpd/musicbrowser/. In your case if you did
                                      > http://192.168.0.3/ you would get 404 not found (no index.html). If
                                      > you put in: http://192.168.0.3/musicbrowser/ you would get it. If you
                                      > have to do http://192.168.0.3/musicbrowser/index.php to get it, it is
                                      > a lighttpd configuration issue.
                                      >
                                      > The default permissions on the musicbrowser folder is 755 and the
                                      > files 744 which is fine. I am running as root. No changes to
                                      > permissions or ownership.
                                      >
                                      > Steve
                                      >
                                      >
                                      > --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@...> wrote:
                                      >>
                                      >>
                                      >> Thanks Scott.
                                      >>
                                      >> Ive just done a clean unsling so i will start with all the steps
                                      > again using
                                      >> your unzip method.
                                      >>
                                      >> I know you mentioned about the instructions earlier to set up
                                      > permissions
                                      >> but im still uncleal about these. After i use your unzip method,
                                      > could you
                                      >> confirm what i need to do for permissions please?
                                      >>
                                      >> many thanks
                                      >> k
                                      >>
                                      >> Scott Ruckh wrote:
                                      >> >
                                      >> >
                                      >> >
                                      >> > This is what you said knowvb
                                      >> >>
                                      >> >> Hi Scott, thanks for the quick reply.
                                      >> >>
                                      >> >> I am actualy unzipping on the windows machine.
                                      >> >> I then copy all these files through the window network share into
                                      > /public
                                      >> >> on
                                      >> >> the slug.
                                      >> >>
                                      >> >> I then telnet into the slug and type
                                      >> >> cp /public /opt/share/www/lighttpd
                                      >> >>
                                      >> >> this effectivly copies all the unzipped music browser files in
                                      > /public to
                                      >> >> the /opt/share/www/lighttpd.
                                      >> >>
                                      >> >> I do this because i do not know how to unzip on the slug itself.
                                      >> >>
                                      >> >> Could this be where i am going wrong?
                                      >> >>
                                      >> >
                                      >> > ipkg install unzip
                                      >> > copy zip file to /opt/share/www/lighttpd
                                      >> > unzip musicbrowser.zip
                                      >> > change permissions on musicbrowser directory.
                                      >> >
                                      >> > I would show you my configuration, but I think it would just be more
                                      >> > confusing as I am not using /opt/share/www/lighttpd as my "root"
                                      > and have
                                      >> > set up virtual hosts.
                                      >> >
                                      >> >
                                      >>
                                      >> --
                                      >> View this message in context:
                                      > http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15122140.html
                                      >> Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                      >>
                                      >
                                      >
                                      >
                                      >

                                      --
                                      View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15124963.html
                                      Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                    • knowvb
                                      SOLVED!! and WORKING!!! To overcome the last error i simply forced a reinstall of php php-fcgi by typing.... ipkg install php php-fcgi -force-reinstall i can
                                      Message 18 of 30 , Jan 27, 2008
                                      View Source
                                      • 0 Attachment
                                        SOLVED!! and WORKING!!!

                                        To overcome the last error i simply forced a reinstall of php php-fcgi by
                                        typing....
                                        ipkg install php php-fcgi -force-reinstall

                                        i can now access the index.php for music browser.

                                        Thankyou all for your time and patience.

                                        Im now thinking of being more adventurus by looking at other music library
                                        php scripts but i guess i need to get my head round sql databases with php.

                                        thanks again
                                        k

                                        knowvb wrote:
                                        >
                                        > Thans for everyones help here. I seem to be getting a little further now.
                                        >
                                        > Im feeling rather numb here because i realised one of the problems wa that
                                        > i didnt enale for fast cgi in lighttpd.conf by removing the #'s.
                                        >
                                        > Anyway, moving on.
                                        > after removing the #'s i then restarted lighttpd but got the following
                                        > error.....
                                        >
                                        > Starting web server: lighttpd
                                        > /opt/sbin/lighttpd: error while loading shared libraries: libssl.so.0.9.7:
                                        > canno
                                        > t open shared object file: No such file or directory
                                        > #
                                        >
                                        > I sorted this problem by ipkg install openssl.
                                        >
                                        > I then restarted lighttpd with no errors.
                                        >
                                        > I then navigated to 192.168.0.3 on the web browser in windows and got a
                                        > 500 internal server error.
                                        >
                                        > I then tried to start manual the php-fcgi by typing.....
                                        > /opt/bin/php-fcgi
                                        >
                                        > but got the following error message......
                                        >
                                        > # /opt/bin/php-fcgi
                                        > PHP Warning: PHP Startup: Unable to load dynamic library
                                        > '/opt/lib/php/extensio
                                        > ns/bz2.so' - libbz2.so.1.0: cannot open shared object file: No such file
                                        > or dire
                                        > ctory in Unknown on line 0
                                        > PHP Warning: PHP Startup: Unable to load dynamic library
                                        > '/opt/lib/php/extensio
                                        > ns/dba.so' - libdb-4.2.so: cannot open shared object file: No such file or
                                        > direc
                                        > tory in Unknown on line 0
                                        > PHP Warning: PHP Startup: Unable to load dynamic library
                                        > '/opt/lib/php/extensio
                                        > ns/xsl.so' - libexslt.so.0: cannot open shared object file: No such file
                                        > or dire
                                        > ctory in Unknown on line 0
                                        >
                                        > could this be part of the problem?
                                        >
                                        > many thanks again.
                                        > k
                                        >
                                        >
                                        > sdm485 wrote:
                                        >>
                                        >> I just tried the installation method and discovered that musicbrowser
                                        >> will not work if the files themselves are in /opt/share/www/lighttpd.
                                        >> However they will if the files are in
                                        >> /opt/share/www/lighttpd/musicbrowser/. In your case if you did
                                        >> http://192.168.0.3/ you would get 404 not found (no index.html). If
                                        >> you put in: http://192.168.0.3/musicbrowser/ you would get it. If you
                                        >> have to do http://192.168.0.3/musicbrowser/index.php to get it, it is
                                        >> a lighttpd configuration issue.
                                        >>
                                        >> The default permissions on the musicbrowser folder is 755 and the
                                        >> files 744 which is fine. I am running as root. No changes to
                                        >> permissions or ownership.
                                        >>
                                        >> Steve
                                        >>
                                        >>
                                        >> --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@...> wrote:
                                        >>>
                                        >>>
                                        >>> Thanks Scott.
                                        >>>
                                        >>> Ive just done a clean unsling so i will start with all the steps
                                        >> again using
                                        >>> your unzip method.
                                        >>>
                                        >>> I know you mentioned about the instructions earlier to set up
                                        >> permissions
                                        >>> but im still uncleal about these. After i use your unzip method,
                                        >> could you
                                        >>> confirm what i need to do for permissions please?
                                        >>>
                                        >>> many thanks
                                        >>> k
                                        >>>
                                        >>> Scott Ruckh wrote:
                                        >>> >
                                        >>> >
                                        >>> >
                                        >>> > This is what you said knowvb
                                        >>> >>
                                        >>> >> Hi Scott, thanks for the quick reply.
                                        >>> >>
                                        >>> >> I am actualy unzipping on the windows machine.
                                        >>> >> I then copy all these files through the window network share into
                                        >> /public
                                        >>> >> on
                                        >>> >> the slug.
                                        >>> >>
                                        >>> >> I then telnet into the slug and type
                                        >>> >> cp /public /opt/share/www/lighttpd
                                        >>> >>
                                        >>> >> this effectivly copies all the unzipped music browser files in
                                        >> /public to
                                        >>> >> the /opt/share/www/lighttpd.
                                        >>> >>
                                        >>> >> I do this because i do not know how to unzip on the slug itself.
                                        >>> >>
                                        >>> >> Could this be where i am going wrong?
                                        >>> >>
                                        >>> >
                                        >>> > ipkg install unzip
                                        >>> > copy zip file to /opt/share/www/lighttpd
                                        >>> > unzip musicbrowser.zip
                                        >>> > change permissions on musicbrowser directory.
                                        >>> >
                                        >>> > I would show you my configuration, but I think it would just be more
                                        >>> > confusing as I am not using /opt/share/www/lighttpd as my "root"
                                        >> and have
                                        >>> > set up virtual hosts.
                                        >>> >
                                        >>> >
                                        >>>
                                        >>> --
                                        >>> View this message in context:
                                        >> http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15122140.html
                                        >>> Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                        >>>
                                        >>
                                        >>
                                        >>
                                        >>
                                        >
                                        >

                                        --
                                        View this message in context: http://www.nabble.com/how-to-Install-lighttpd%2C-fastcgi%2C-PHP4.2-on-the-unslung-nslu2-linux-so-i-can-use-this.......-tp15101230p15125585.html
                                        Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
                                      • Scott Ruckh
                                        This is what you said Scott Ruckh ... You can also check out, ampache, http://www.ampache.org/ . It is a fairly cool way to serve up your music files. It is
                                        Message 19 of 30 , Jan 28, 2008
                                        View Source
                                        • 0 Attachment
                                          This is what you said Scott Ruckh
                                          > This is what you said Scott Ruckh
                                          >>
                                          >>
                                          >> This is what you said sdm485
                                          >>> I am wrong about the typo; sorry Brendan. I will take a refresher on
                                          >>> chmod.
                                          >>> Steve
                                          >>>
                                          >>> --- In nslu2-linux@yahoogroups.com, "sdm485" <steve@...> wrote:
                                          >>>>
                                          >>>> Probably close now. There is a typo in Brendan's script. Try (c)
                                          >>>> without the 2 in 2755. Just 755.
                                          >>>>
                                          >>>> The commands chown and chmod are fundamental to manipulating the
                                          >>>> security system and worth becoming familiar with.
                                          >>>>
                                          >>>> If it still doesn't work then, as root:
                                          >>>>
                                          >>>> chown 755 /opt/share/www/lighttpd -R
                                          >>>>
                                          >>>> Don't expose your server beyond your local network until you have
                                          >>>> confirmed the proper permissions for lighttpd. I am sure Brendan's
                                          >>>> suggestion is the better one with regard to security.
                                          >>>>
                                          >>>> Steve
                                          >>>>
                                          >>>>
                                          >>>>
                                          >>>> --- In nslu2-linux@yahoogroups.com, knowvb <andyhartleyuk@> wrote:
                                          >>>> > # find /opt/share/www/lighttpd -type d -exec chmod 2755 {} \; -
                                          >>> print
                                          >>>> > BusyBox v1.3.1 (2007-12-29 03:38:35 UTC) multi-call binary
                                          >>>> >
                                          >>
                                          >>
                                          You can also check out, ampache, http://www.ampache.org/ . It is a fairly
                                          cool way to serve up your music files. It is quite a bit more
                                          sophisticated then musicbrowser.

                                          It requires MySQL. I don't run MySQL server on the NSLU2 so I don't have
                                          to worry about the extra resources that running MySQL server on the NSLU2
                                          would consume. I instead have another server running MySQL.

                                          Anyway, just another option for those who are looking at Web Front Ends to
                                          their music collections that are stored on their NSLU2 device.
                                        Your message has been successfully submitted and would be delivered to recipients shortly.