Loading ...
Sorry, an error occurred while loading the content.

How to install MySql server on the uNSLUng NSLU2

Expand Messages
  • douglourey
    Please direct me to instructions on installing MySql on my uNSLUng NSLU2. Lean-mean SQL machine! This setup will be behind a firewall - LAN access only.
    Message 1 of 3 , Jan 10, 2008
    • 0 Attachment
      Please direct me to instructions on installing MySql on my uNSLUng
      NSLU2.
      Lean-mean SQL machine! This setup will be behind a firewall - LAN
      access only. Clients will be Windows 2k, xp, using ODBC. No php or web
      applications. This will be a production system.
      I'm guessing these are the steps, but I don't want to do anything
      unnecessary.

      # ipkg update
      # ipkg install zlib
      # ipkg install ncurses
      # ipkg install openssl
      # ipkg install readline
      # ipkg install libstdc++
      # ipkg install mysql
      Thank you.
    • douglourey
      SOLVED - I can use MySql Administrator on Windows 2000 to manage MySql installed on my NSLU2. This is what I did. Installed uNSLUng firmware
      Message 2 of 3 , Jan 10, 2008
      • 0 Attachment
        SOLVED - I can use MySql Administrator on Windows 2000 to manage
        MySql installed on my NSLU2.
        This is what I did.

        Installed uNSLUng firmware Unslung-6.8-beta.bin and unsling disk2
        TELNET INTO uNSLUng NSLU2
        # ipkg update
        # ipkg install mysql

        RESET MYSQL ROOT PASSWORD
        # /opt/etc/init.d/S70mysqld stop
        # /opt/bin/mysqld_safe --skip-grant-tables
        OPEN A NEW TELNET WINDOW
        # /opt/bin/mysql -u root
        mysql> use mysql;
        mysql> update user set Password=PASSWORD('newpassword') where
        User='root';
        mysql> exit
        # /opt/etc/init.d/S70mysqld stop
        # rm -f ~/.mysql_history
        # /opt/etc/init.d/S70mysqld start

        ENABLE REMOTE ACCESS - COMMENT skip-networking and GRANT PRIVILIGES
        # vi /opt/etc/my.cnf
        #skip-networking
        <Esc> :wq <Enter>
        # /opt/bin/mysql -u root
        mysql> use mysql;
        mysql> GRANT ALL PRIVILIGES ON *.* TO root@'192.168.100.101'
        IDENTIFIED By 'newpassword';
        mysql> exit
      • douglourey
        Solved in my previous post. I m using MS Access frontend with MySql on NSLU2 backend. Here are the additional steps I took to make this work. After getting
        Message 3 of 3 , Jan 10, 2008
        • 0 Attachment
          Solved in my previous post.
          I'm using MS Access frontend with MySql on NSLU2 backend.
          Here are the additional steps I took to make this work.

          After getting MySql up and running on the NSLU2, I installed MySql
          Administrator 1.1.8 (mysql-administrator-1.1.8-win32.msi) on my
          Windows 2000 workstation and connected to MySql on the NSLU2 to
          create a user account for Access named 'admin' with no password. MS
          Access uses 'admin' as its default username when connecting to ODBC
          databases, so this helps. Note that I'm not using any security for
          this project, it's not needed. I also created a new schema
          named 'est' and gave user 'admin' full rights to it.

          Installed mysql-connector-odbc-3.51.12-win32.msi on my workstation
          and created an ODBC connection through Start-Settings-Control Panel-
          Administrative Tools-Data Sources(ODBC)
          System DSN
          Data Source Name: est
          Server: NSLU2
          User: admin
          Password: <blank>
          Database: est
          Flags
          Don't Optimize Column Width
          Return Matching Rows
          Chang BIGINT Columns To Int

          I launched MS Access and opened the database est.mdb, right-mouse
          clicked on my table named 'estimate' and selected 'Export'.
          Save as type: ODBC Databases()
          Click OK
          Machine Data Sources (tab)
          Data Source Name: est

          The table structure and data exported to MySql

          I then launched MySql Administrator and modified the new table 'est'
          changing the field [RecordID] to autoincrement, and [TimeStamp] to
          TIMESTAMP field type. Note these fields already existed in Access.
          I added a PRIMARY index using [RecordID].

          Back in the MS Access est.mdb file, I renamed the old table estimate,
          and attached the new MySql table. On the form that uses this table,
          I added a SaveRecord to OnEnter event. This eliminates the #Deleted#
          error.
        Your message has been successfully submitted and would be delivered to recipients shortly.