Loading ...
Sorry, an error occurred while loading the content.

Re: Files dissapear or get corrupted (unslug 6.8+fat32 drive)

Expand Messages
  • cmelikian
    ... According to http://www.debianhelp.co.uk/fstab.htm defaults - Use default settings. Equivalent to rw,suid,dev,exec,auto,nouser,async. So it does do async
    Message 1 of 10 , Dec 11, 2007
    • 0 Attachment
      --- In nslu2-linux@yahoogroups.com, "on4cet" <on4cet@...> wrote:
      >
      > Hmmm,
      >
      > Could that be a problem ? I looked up a fstab from my previous
      > debian install :
      >
      > # /etc/fstab: static file system information.
      > #
      > # <file system> <mount point> <type>
      > <options> <dump> <pass>
      > #
      > # Disk 1 USB Stick 1 Gb
      > proc /proc proc
      > defaults 0 0
      > /dev/disk/by-label/root / ext3
      > defaults,errors=remount-ro,noatime 0 1
      > /dev/disk/by-label/swapstick none swap
      > sw 0 0
      > /dev/disk/by-label/swapstick /media/usb0 auto
      > rw,user,noauto 0 0
      > /dev/disk/by-label/root /media/usb1 auto
      > rw,user,noauto,noatime 0 0
      > #
      > # Disk 2 WD Mybook 320GB
      > /dev/disk/by-label/mybookdata /data ext3
      > defaults,noatime 1 2
      > /dev/disk/by-label/swapmybook none swap
      > sw 0 0
      > /dev/disk/by-label/swapmybook /media/usb2 auto
      > rw,user,noauto,noatime 0 0
      > /dev/disk/by-label/mybookdata /media/usb3 auto
      > rw,user,noauto,noatime 0 0
      >
      >
      >
      > If you don't specify 'sync', will it default to async then ? Maybe
      > that could be a problem !
      >
      > I'm running unslung at the moment, but i'll try this one for sure !
      >
      > Bart
      >
      >
      >
      > --- In nslu2-linux@yahoogroups.com, "cmelikian" <chris.melikian@>
      > wrote:
      > >
      > > I had a corrupted drive as well using Unslung 6.8 beta.
      > >
      > > I've now moved to Debian and had no problems.
      > >
      > > Have you looked at the mount options for the filesystems? I have a
      > > really bad feeling that the async option was used in my
      > configuration
      > > and the delayed writes were not being written to the filesystem
      > > causing corruption. I have now set the option to sync and all is
      > fine
      > > so far.
      > >
      >

      According to

      http://www.debianhelp.co.uk/fstab.htm

      "defaults - Use default settings. Equivalent to
      rw,suid,dev,exec,auto,nouser,async."

      So it does do async by default.

      Could that be it solved then?
    • ian_jefferyes
      I am just wanting to following up on this and ask whether making this change solved the problem with corrupt files. If so, could you please state exactly what
      Message 2 of 10 , Feb 15, 2008
      • 0 Attachment
        I am just wanting to following up on this and ask whether making this
        change solved the problem with corrupt files.

        If so, could you please state exactly what the line needs to be as I
        am very unfamiliar with all this.

        My current settings show:

        #/dev/ram0 / ext2 defaults
        1 1
        #none /proc proc defaults
        0 0
        #none /dev/pts devpts
        gid=5,mode=620 0 0
        /dev/sda1 /share/flash/data ext3 defaults,usrquota 1
        /dev/sda2 /share/flash/conf ext3 defaults 1 1
        /dev/sda3 swap swap defaults 0 0

        What should they be changed to?

        Cheers

        Ian


        --- In nslu2-linux@yahoogroups.com, "cmelikian" <chris.melikian@...>
        wrote:
        >
        > --- In nslu2-linux@yahoogroups.com, "on4cet" <on4cet@> wrote:
        > >
        > > Hmmm,
        > >
        > > Could that be a problem ? I looked up a fstab from my previous
        > > debian install :
        > >
        > > # /etc/fstab: static file system information.
        > > #
        > > # <file system> <mount point> <type>
        > > <options> <dump> <pass>
        > > #
        > > # Disk 1 USB Stick 1 Gb
        > > proc /proc proc
        > > defaults 0 0
        > > /dev/disk/by-label/root / ext3
        > > defaults,errors=remount-ro,noatime 0 1
        > > /dev/disk/by-label/swapstick none swap
        > > sw 0 0
        > > /dev/disk/by-label/swapstick /media/usb0 auto
        > > rw,user,noauto 0 0
        > > /dev/disk/by-label/root /media/usb1 auto
        > > rw,user,noauto,noatime 0 0
        > > #
        > > # Disk 2 WD Mybook 320GB
        > > /dev/disk/by-label/mybookdata /data ext3
        > > defaults,noatime 1 2
        > > /dev/disk/by-label/swapmybook none swap
        > > sw 0 0
        > > /dev/disk/by-label/swapmybook /media/usb2 auto
        > > rw,user,noauto,noatime 0 0
        > > /dev/disk/by-label/mybookdata /media/usb3 auto
        > > rw,user,noauto,noatime 0 0
        > >
        > >
        > >
        > > If you don't specify 'sync', will it default to async then ? Maybe
        > > that could be a problem !
        > >
        > > I'm running unslung at the moment, but i'll try this one for sure !
        > >
        > > Bart
        > >
        > >
        > >
        > > --- In nslu2-linux@yahoogroups.com, "cmelikian" <chris.melikian@>
        > > wrote:
        > > >
        > > > I had a corrupted drive as well using Unslung 6.8 beta.
        > > >
        > > > I've now moved to Debian and had no problems.
        > > >
        > > > Have you looked at the mount options for the filesystems? I have a
        > > > really bad feeling that the async option was used in my
        > > configuration
        > > > and the delayed writes were not being written to the filesystem
        > > > causing corruption. I have now set the option to sync and all is
        > > fine
        > > > so far.
        > > >
        > >
        >
        > According to
        >
        > http://www.debianhelp.co.uk/fstab.htm
        >
        > "defaults - Use default settings. Equivalent to
        > rw,suid,dev,exec,auto,nouser,async."
        >
        > So it does do async by default.
        >
        > Could that be it solved then?
        >
      • gopher3_8
        I second this request. I have exactly the same fstab as Ian. Thanks much. ... 1 ... 1
        Message 3 of 10 , Feb 16, 2008
        • 0 Attachment
          I second this request. I have exactly the same fstab as Ian. Thanks
          much.

          --- In nslu2-linux@yahoogroups.com, "ian_jefferyes" <nslu2@...> wrote:
          >
          > I am just wanting to following up on this and ask whether making this
          > change solved the problem with corrupt files.
          >
          > If so, could you please state exactly what the line needs to be as I
          > am very unfamiliar with all this.
          >
          > My current settings show:
          >
          > #/dev/ram0 / ext2 defaults
          > 1 1
          > #none /proc proc defaults
          > 0 0
          > #none /dev/pts devpts
          > gid=5,mode=620 0 0
          > /dev/sda1 /share/flash/data ext3 defaults,usrquota
          1
          > /dev/sda2 /share/flash/conf ext3 defaults 1
          1
          > /dev/sda3 swap swap defaults 0 0
          >
          > What should they be changed to?
          >
          > Cheers
          >
          > Ian
          >
          >
          > --- In nslu2-linux@yahoogroups.com, "cmelikian" <chris.melikian@>
          > wrote:
          > >
          > > --- In nslu2-linux@yahoogroups.com, "on4cet" <on4cet@> wrote:
          > > >
          > > > Hmmm,
          > > >
          > > > Could that be a problem ? I looked up a fstab from my previous
          > > > debian install :
          > > >
          > > > # /etc/fstab: static file system information.
          > > > #
          > > > # <file system> <mount point> <type>
          > > > <options> <dump> <pass>
          > > > #
          > > > # Disk 1 USB Stick 1 Gb
          > > > proc /proc proc
          > > > defaults 0 0
          > > > /dev/disk/by-label/root / ext3
          > > > defaults,errors=remount-ro,noatime 0 1
          > > > /dev/disk/by-label/swapstick none swap
          > > > sw 0 0
          > > > /dev/disk/by-label/swapstick /media/usb0 auto
          > > > rw,user,noauto 0 0
          > > > /dev/disk/by-label/root /media/usb1 auto
          > > > rw,user,noauto,noatime 0 0
          > > > #
          > > > # Disk 2 WD Mybook 320GB
          > > > /dev/disk/by-label/mybookdata /data ext3
          > > > defaults,noatime 1 2
          > > > /dev/disk/by-label/swapmybook none swap
          > > > sw 0 0
          > > > /dev/disk/by-label/swapmybook /media/usb2 auto
          > > > rw,user,noauto,noatime 0 0
          > > > /dev/disk/by-label/mybookdata /media/usb3 auto
          > > > rw,user,noauto,noatime 0 0
          > > >
          > > >
          > > >
          > > > If you don't specify 'sync', will it default to async then ? Maybe
          > > > that could be a problem !
          > > >
          > > > I'm running unslung at the moment, but i'll try this one for sure !
          > > >
          > > > Bart
          > > >
          > > >
          > > >
          > > > --- In nslu2-linux@yahoogroups.com, "cmelikian" <chris.melikian@>
          > > > wrote:
          > > > >
          > > > > I had a corrupted drive as well using Unslung 6.8 beta.
          > > > >
          > > > > I've now moved to Debian and had no problems.
          > > > >
          > > > > Have you looked at the mount options for the filesystems? I have a
          > > > > really bad feeling that the async option was used in my
          > > > configuration
          > > > > and the delayed writes were not being written to the filesystem
          > > > > causing corruption. I have now set the option to sync and all is
          > > > fine
          > > > > so far.
          > > > >
          > > >
          > >
          > > According to
          > >
          > > http://www.debianhelp.co.uk/fstab.htm
          > >
          > > "defaults - Use default settings. Equivalent to
          > > rw,suid,dev,exec,auto,nouser,async."
          > >
          > > So it does do async by default.
          > >
          > > Could that be it solved then?
          > >
          >
        • gopher3_8
          I was just looking at some info on fstab (I don t know much about Linux, but I m learning :) ), and I don t think that we want to try the sync command there.
          Message 4 of 10 , Feb 16, 2008
          • 0 Attachment
            I was just looking at some info on fstab (I don't know much about
            Linux, but I'm learning :) ), and I don't think that we want to try
            the "sync" command there. If you do "mount", you can see another line
            with the fat hd:

            /dev/sdb1 on /share/hdd/data/HDD_1_1_1 type vfat (rw)


            This is the one that you and I want to try with sync, but if it's not
            mounted in fstab, where is it mounted? Huumm ... Anyone?
          • gopher3_8
            By the way, in response to the question below, I thought I d give my backup solution. I bought two 2G usb sticks when I bought the Slug, since all my other
            Message 5 of 10 , Feb 16, 2008
            • 0 Attachment
              By the way, in response to the question below, I thought I'd give my
              backup solution. I bought two 2G usb sticks when I bought the Slug,
              since all my other systems are windows. Before I make any substantial
              changes to the Slug, I back up everything on the one stick to the
              other (reformat disk 1 using slug and then copy entire flash with dd
              command). If I don't like the changes, I can go back to using the
              other flash stick with no problems. One thing that I thought was
              interesting is that, even though they are both 2G, they have a very
              slight size difference. My local BestBuy didn't have two identical
              sticks that day, so I bought two different brands, not knowing that
              one of them had this U3 thing on it, which caused problems at first.
              I had to remove that partition, but I think that you can't remove
              everything, because when I dd from the stick that had U3 on it to the
              normal one, dd copies to the end. Vice versa, it runs out of space at
              the end. When I looked, the U3 stick was about 8M smaller, even
              though they both say 2G. I'm attributing that to something left over
              from U3, but maybe I'm wrong. Anyway, it doesn't seem to affect
              anything, because, after copying, I can swap the two sticks on usb 2
              of the Slug and reboot without any problems.


              > By the way, I asked before but never got someone to answer ; Has
              > someone ever made an image of the ext3 root filesystem and put it back,
              > and off course got a working slug again after that ?
              > I'm so sick of reinstalling everything so many times again and again ...
            • Paul Coolwind
              ... I do it all the time. Either with a dd or with a tar, or with cpio. All of them work fine of course. It s normal that different sticks have different
              Message 6 of 10 , Feb 16, 2008
              • 0 Attachment
                >
                >> By the way, I asked before but never got someone to answer ; Has
                >> someone ever made an image of the ext3 root filesystem and put it back,
                >> and off course got a working slug again after that ?
                >> I'm so sick of reinstalling everything so many times again and again ...
                >

                I do it all the time. Either with a "dd" or with a tar, or with cpio. All
                of them work fine of course.

                It's normal that different sticks have different sizes, don't care about it.
                The U3 issue is not a problem too, once you disable that feature (and the
                virtual CD partition disappear).

                But I experienced a flash disk fault after two months of regular usage,
                which was pretty strange since the fsck and all the possible tools did not
                detect any problem.

                ciao
                Paolo
              Your message has been successfully submitted and would be delivered to recipients shortly.