Loading ...
Sorry, an error occurred while loading the content.

thttpd does not translate index page

Expand Messages
  • nllittle2003
    When I point firefox to the slug s thttp server I am getting the raw html instead of a translated page. I followed the steps in the simplehomewebsite howto
    Message 1 of 4 , Nov 1, 2007
    • 0 Attachment
      When I point firefox to the slug's thttp server I am getting the raw
      html instead of a translated page.

      I followed the steps in the simplehomewebsite howto
      http://www.nslu2-linux.org/wiki/HowTo/SimpleHomeWebsite) on the NSLU2
      wiki. I rebooted my slug and every thing came up. I pointed firefox to
      the IP address using port 81 and the page was displayed. The only
      problem is its the raw html code not the translated result.

      Any suggestions?
    • nllittle2003
      Yes we do stupid things some times! On a reboot every thing is working fine now. --operator head space Neil
      Message 2 of 4 , Nov 1, 2007
      • 0 Attachment
        Yes we do stupid things some times!
        On a reboot every thing is working fine now.
        --operator head space
        Neil

        --- In nslu2-linux@yahoogroups.com, "nllittle2003" <nllittle@...> wrote:
        >
        > When I point firefox to the slug's thttp server I am getting the raw
        > html instead of a translated page.
        >
        > I followed the steps in the simplehomewebsite howto
        > http://www.nslu2-linux.org/wiki/HowTo/SimpleHomeWebsite) on the NSLU2
        > wiki. I rebooted my slug and every thing came up. I pointed firefox to
        > the IP address using port 81 and the page was displayed. The only
        > problem is its the raw html code not the translated result.
        >
        > Any suggestions?
        >
      • Brendan Reid
        hi nlittle, I don t have any firm answers but maybe below is stuff for you to chew on. hope it helps. 1) I used an alternative route to create a copy of thttpd
        Message 3 of 4 , Nov 2, 2007
        • 0 Attachment
          hi nlittle,

          I don't have any firm answers but maybe below is stuff for you to chew on.   hope it helps.

          1) I used an alternative route to create a copy of thttpd (called mythttpd) as here - works great for me
          http://www.nslu2-linux.org/wiki/HowTo/UseTheThttpdWebserver

          2) frustrations in my setup were all around file permissions - webservers are picky and this would be worth trying at your end
          I adapted a script as below to sort this which I can run each time I add modified pages to the slug

          -------------------------------------------------------------------------------------------------------------------
          #! /bin/sh
          # to set file permissions for webserver html files

          # 1. Start by globaly setting all files and directories with owner and group set to root.
          # Note that some users prefer to use different user and groups
          # to improve server security, such as nobody and everyone
          chown -R nobody:everyone /opt/share/www

          # 2. Then globaly chmod all files and directories to permission 644
          chmod -R 0655 /opt/share/www

          #
          # 3. Then chmod all Directories to permission 2755
          find /opt/share/www -type d -exec chmod 2755 {} \; -print
          --------------------------------------------------------------------------

          bren


          On 01/11/2007, nllittle2003 <nllittle@...> wrote:

          When I point firefox to the slug's thttp server I am getting the raw
          html instead of a translated page.

          I followed the steps in the simplehomewebsite howto
          http://www.nslu2-linux.org/wiki/HowTo/SimpleHomeWebsite) on the NSLU2
          wiki. I rebooted my slug and every thing came up. I pointed firefox to
          the IP address using port 81 and the page was displayed. The only
          problem is its the raw html code not the translated result.

          Any suggestions?


        • Neil L. Little
          hi bren, Thanks for the information. I m gonna digest it and implement the permissions for sure. I have seem some weird stuff happen before just because
          Message 4 of 4 , Nov 3, 2007
          • 0 Attachment
            hi bren,

            Thanks for the information. I'm gonna digest it and implement the
            permissions for sure. I have seem some weird stuff happen before
            just because permissions weren't exactly right.

            I created a profile in /etc, set paths and such then I rebooted
            the slug again.

            I flushed my browser cache (firefox) and once again
            pointed the browser at the server. Now every thing is happy.
            Thanks for the help.
            Neil

            hi nlittle,

            I don't have any firm answers but maybe below is stuff for you to chew on.
            hope it helps.

            1) I used an alternative route to create a copy of thttpd (called mythttpd)
            as here - works great for me
            http://www.nslu2- linux.org/ wiki/HowTo/ UseTheThttpdWebs erver

            2) frustrations in my setup were all around file permissions - webservers
            are picky and this would be worth trying at your end
            I adapted a script as below to sort this which I can run each time I add
            modified pages to the slug

            ------------
            --------- --------- --------- --------- --------- -
            #! /bin/sh
            # to set file permissions for webserver html files

            # 1. Start by globaly setting all files and directories with owner and group
            set to root.
            # Note that some users prefer to use different user and groups
            # to improve server security, such as nobody and everyone
            chown -R nobody:everyone /opt/share/www

            # 2. Then globaly chmod all files and directories to permission 644
            chmod -R 0655 /opt/share/www

            #
            # 3. Then chmod all Directories to permission 2755
            find /opt/share/www -type d -exec chmod 2755 {} \; -print
            ------------ --------- --------- --------- --------- --------- -

            bren

            On 01/11/2007, nllittle2003 <nllittle@embarqmail .com> wrote:
            >
            > When I point firefox to the slug's thttp server I am getting the raw
            > html instead of a translated page.
            >
            > I followed the steps in the simplehomewebsite howto
            > http://www.nslu2- linux.org/ wiki/HowTo/ SimpleHomeWebsit e) on the NSLU2
            > wiki. I rebooted my slug and every thing came up. I pointed firefox to
            > the IP address using port 81 and the page was displayed. The only
            > problem is its the raw html code not the translated result.
            >
            > Any suggestions?
            >
            >
            >
          Your message has been successfully submitted and would be delivered to recipients shortly.