Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Upslug2 and WMWare

Expand Messages
  • Drew Gibson
    Clear your browser cache? regards, Drew
    Message 1 of 9 , Oct 26, 2007
    • 0 Attachment
      Clear your browser cache?

      regards,

      Drew

      Sid Price wrote:

      Thank you Fernando, the settings you suggested worked and I was able to reflash my NSLU2.

      After the reflash with the Linksys firmware I still see the “Unlsung” logo on the web interface. Is this correct? Is there more I need to do to revert back to an off-the-shelf NSLU2?

      Thanks,

      Sid.

       

      Sid Price Software Design

      http://www.softtools.com

       


      From: nslu2-linux@yahoogroups.com [mailto: nslu2-linux@yahoogroups.com ] On Behalf Of Fernando Carolo
      Sent: Friday, October 19, 2007 7:17 AM
      To: nslu2-linux@yahoogroups.com
      Subject: Re: [nslu2-linux] Upslug2 and WMWare

       

      On 10/17/07, Sid Price <sidprice@softtools. com> wrote:
      > Hi,
      > I am a Windows user and I am unfamiliar with Debian/Etch and VMWare. I
      > have installed VMPlayer and the Debian/etch appliance so that I can
      > reflash one of several NSLU2s I have. I downloaded upslug2 and it is
      > installed in the Debian/Etch virtual machine and it appears to be
      > running correctly, however it does not see the NSLU2 in upgrade mode. I
      > believe the problem is a network issue because VMWare is setup to use
      > NAT mode to access the network.
      > I have tried changing the VM to use "Bridged" mode but then I do not
      > appear to have network connections (i.e. browser access to internet) at
      > all.
      > Can someone please advise on how to configure my VM so that I can
      > reflash my NSLU2.

      You need to get your network connection running in Bridged mode, since
      upslug2 needs to be on the same network segment as the slug. I can
      think of two things to check why your bridged connection is not
      working.

      - If you have more than one network interface on your host, such as a
      wired interface and a wireless one, VMWare may have selected the wrong
      one for bridging. I am not familiar with VMWare Player interface, but
      in VMWare Server you have an option called "Virtual Network Settings"
      in the Host menu, that brings you a config window for the virtual
      interfaces created for the guests. Check if you can set the binding
      for VMnet0 to the correct physical interface in your machine.

      - When you use bridged networking, VMWare will create a virtual MAC
      address for the guest VM, and this address must be accepted in your
      network as if you had connected another computer to it. This can be a
      problem if your network validates MAC addresses somehow. In my office
      I had to ask the network support guy to enable an additional MAC
      address in my switch port. What kind of network setup do you have
      (home, office, wired, wi-fi)?

      Regards,

      --
      Fernando Carolo
      "Ignore the noise. Make some signal" -- Nathan Torkington

    Your message has been successfully submitted and would be delivered to recipients shortly.