Loading ...
Sorry, an error occurred while loading the content.

Feedback on Latest SlugosBE build

Expand Messages
  • sdm485
    I have just completed reflashing my 128M fatslug with the latest firmware build of slugosbe and found that it works very well so far. I am running apex as the
    Message 1 of 2 , Oct 2, 2007
    • 0 Attachment
      I have just completed reflashing my 128M fatslug with the latest
      firmware build of slugosbe and found that it works very well so far.

      I am running apex as the bootloader and so have to upload the images
      via the serial port which takes a while. I choose to use the
      zimage-ixp4xxbe image but there is no complete firmware image with
      that kernel. My solution is to upload and flash the
      slugosbe-4.6-beta-nslu2.bin image first. This boots but only sees 32M
      of memory (which can probably be changed; I didn't check). Next, I
      upload the ixp4xxbe kernel image and flash it separately and it all
      works.

      It seems to boot faster and the three beeps are nice to say that it is
      ready to go. It preserved my previous password and static IP
      configuration which is very nice too. I will continue by loading up my
      usual setup of vsftpd,httpd,ntpd and the build environment to see how
      that goes.

      On a related note, the Makefile command 'setup-host-ubuntu' works fine
      but has texinfo listed twice for installation and does not include
      help2man which is needed.

      Hope this helps the cause,

      Steve
    • Mike (mwester)
      ... helpful, and greatly appreciated. Let me take this opportunity to encourage others to try the latest builds and report back -- this sort of testing is
      Message 2 of 2 , Oct 3, 2007
      • 0 Attachment
        :-) Thanks for the feedback! That very specific feedback is extremely
        helpful, and greatly appreciated.

        Let me take this opportunity to encourage others to try the latest builds
        and report back -- this sort of testing is vital for us.

        I think everyone will agree that general quality for the SlugOS (aka
        OpenSlug) releases has been very good -- that's in large part due to the
        testing performed by the community before a version gets released. We want
        it to stay that way. So we need your help to get the next SlugOS release
        out the door (the code is done, it's ready for release from a feature
        point-of-view). At present you need to be able to build the release
        yourself; prebuilt binaries are not available. (We do this for a reason -
        it ensures that the development team gets the highest quality feedback from
        folks who are committed enough to the task of testing to go through the
        build process.)

        For those of you who can take the time to do the build (see the wiki article
        on using the Master Makefile), and conduct some testing with the various
        peripherals and applications that you use, we would greatly appreciate your
        time and effort!

        Thanks,
        ~Mike (mwester)

        ----- Original Message -----
        From: "sdm485" <steve@...>
        To: <nslu2-linux@yahoogroups.com>
        Sent: Tuesday, October 02, 2007 6:42 PM
        Subject: [nslu2-linux] Feedback on Latest SlugosBE build


        I have just completed reflashing my 128M fatslug with the latest
        firmware build of slugosbe and found that it works very well so far.

        I am running apex as the bootloader and so have to upload the images
        via the serial port which takes a while. I choose to use the
        zimage-ixp4xxbe image but there is no complete firmware image with
        that kernel. My solution is to upload and flash the
        slugosbe-4.6-beta-nslu2.bin image first. This boots but only sees 32M
        of memory (which can probably be changed; I didn't check). Next, I
        upload the ixp4xxbe kernel image and flash it separately and it all
        works.

        It seems to boot faster and the three beeps are nice to say that it is
        ready to go. It preserved my previous password and static IP
        configuration which is very nice too. I will continue by loading up my
        usual setup of vsftpd,httpd,ntpd and the build environment to see how
        that goes.

        On a related note, the Makefile command 'setup-host-ubuntu' works fine
        but has texinfo listed twice for installation and does not include
        help2man which is needed.

        Hope this helps the cause,

        Steve
      Your message has been successfully submitted and would be delivered to recipients shortly.