Loading ...
Sorry, an error occurred while loading the content.
 

Kernel Error Message -- Using Unslung

Expand Messages
  • Scott Ruckh
    I am running the latest Unslung firmware (Unslung 6.8 Beta) on my NSLU2. I have been keeping the installed packages fairly up to date. I am runing mt-dappd,
    Message 1 of 6 , Sep 19, 2007
      I am running the latest Unslung firmware (Unslung 6.8 Beta) on my NSLU2.

      I have been keeping the installed packages fairly up to date. I am runing
      mt-dappd, ccxstream, lighttpd, and OpenSSH.

      Everything was working fine for quite some time.

      Recently I noticed the following kernel errors which are being generated
      all the time:

      ixp425_eth: Error reading MII reg x on phy 0

      where "x" in "reg x" equals a number between 0 and 7.

      I believe this is causing some problems as I have been having connectivity
      issues with the NSLU2 the past few days.

      Does anyone else have this issue, and have any solutions? Any ideas where
      I can begin to look?

      Thanks.
      --
    • Rod Whitby
      ... Since we don t change the kernel or modules in our Unslung releases, then this can only be something with your hardware, your ethernet cables, or the box
      Message 2 of 6 , Sep 19, 2007
        Scott Ruckh wrote:
        > I am running the latest Unslung firmware (Unslung 6.8 Beta) on my NSLU2.
        >
        > I have been keeping the installed packages fairly up to date. I am runing
        > mt-dappd, ccxstream, lighttpd, and OpenSSH.
        >
        > Everything was working fine for quite some time.
        >
        > Recently I noticed the following kernel errors which are being generated
        > all the time:
        >
        > ixp425_eth: Error reading MII reg x on phy 0
        >
        > where "x" in "reg x" equals a number between 0 and 7.
        >
        > I believe this is causing some problems as I have been having connectivity
        > issues with the NSLU2 the past few days.
        >
        > Does anyone else have this issue, and have any solutions? Any ideas where
        > I can begin to look?

        Since we don't change the kernel or modules in our Unslung releases,
        then this can only be something with your hardware, your ethernet
        cables, or the box at the other end of the ethernet cable.

        -- Rod
      • Marc Boris
        ... Hi, I do see the same messages on my NSLU2 running uNSLUng 6.8 beta It does raise concerns but actually I do not experience any issue so far. I assume that
        Message 3 of 6 , Mar 2, 2008
          --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@...> wrote:
          > ...
          > >
          > > ixp425_eth: Error reading MII reg x on phy 0
          > >
          > > where "x" in "reg x" equals a number between 0 and 7.

          > ... something with your hardware, your ethernet
          > cables, or the box at the other end of the ethernet cable.
          >
          > -- Rod
          >

          Hi, I do see the same messages on my NSLU2 running uNSLUng 6.8 beta
          It does raise concerns but actually I do not experience any issue so
          far. I assume that it is a real hw problem with the PHY or just a
          problem with the driver for this device. Although the ethernet works
          fine for me with these errors I would like to get this fixed (unless
          the PHY is bad which requires buying another Slug. I doubt that it is
          a configuration problem or package install issue but have not found
          anything useful online so far. Does anybody know how to compile the
          ixp425 module ourselves?
          --Marc
        • Mike (mwester)
          ... The source for that driver is proprietary, and is not available. There is an opensource driver (two actually) available in the 2.6 kernels, but Unslung
          Message 4 of 6 , Mar 2, 2008
            Marc Boris wrote:
            > --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@...> wrote:
            >
            >> ...
            >>
            >>> ixp425_eth: Error reading MII reg x on phy 0
            >>>
            >>> where "x" in "reg x" equals a number between 0 and 7.
            >>>
            >
            >
            >> ... something with your hardware, your ethernet
            >> cables, or the box at the other end of the ethernet cable.
            >>
            >> -- Rod
            >>
            >>
            >
            > Hi, I do see the same messages on my NSLU2 running uNSLUng 6.8 beta
            > It does raise concerns but actually I do not experience any issue so
            > far. I assume that it is a real hw problem with the PHY or just a
            > problem with the driver for this device. Although the ethernet works
            > fine for me with these errors I would like to get this fixed (unless
            > the PHY is bad which requires buying another Slug. I doubt that it is
            > a configuration problem or package install issue but have not found
            > anything useful online so far. Does anybody know how to compile the
            > ixp425 module ourselves?
            > --Marc
            >

            The source for that driver is proprietary, and is not available. There
            is an opensource driver (two actually) available in the 2.6 kernels, but
            Unslung is, of course, stuck on the Linksys 2.4 kernel.

            Mike (mwester)
          • tonymy01
            ... NSLU2. ... am runing ... generated ... connectivity ... ideas where ... I am now getting this too, since installing nfs-utils. It seems that the install
            Message 5 of 6 , Jun 16, 2008
              --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@...> wrote:
              >
              > Scott Ruckh wrote:
              > > I am running the latest Unslung firmware (Unslung 6.8 Beta) on my
              NSLU2.
              > >
              > > I have been keeping the installed packages fairly up to date. I
              am runing
              > > mt-dappd, ccxstream, lighttpd, and OpenSSH.
              > >
              > > Everything was working fine for quite some time.
              > >
              > > Recently I noticed the following kernel errors which are being
              generated
              > > all the time:
              > >
              > > ixp425_eth: Error reading MII reg x on phy 0
              > >
              > > where "x" in "reg x" equals a number between 0 and 7.
              > >
              > > I believe this is causing some problems as I have been having
              connectivity
              > > issues with the NSLU2 the past few days.
              > >
              > > Does anyone else have this issue, and have any solutions? Any
              ideas where
              > > I can begin to look?
              >
              > Since we don't change the kernel or modules in our Unslung releases,
              > then this can only be something with your hardware, your ethernet
              > cables, or the box at the other end of the ethernet cable.
              >
              I am now getting this too, since installing nfs-utils. It seems
              that the install of portmap (which nfs-utils depends on) causes this,
              but I am not 100% sure just yet. I just googled this error and
              found this yahoo thread...
              Regards
              Tony
            • Scott Ruckh
              This is what you said tonymy01 ... I have since moved over to SlugOS/BE. My errors were due to running SNMP and having ZenOS doing SNMP probes on the SLUG.
              Message 6 of 6 , Jun 16, 2008
                This is what you said tonymy01
                > --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@...> wrote:
                >>
                >> Scott Ruckh wrote:
                >> > I am running the latest Unslung firmware (Unslung 6.8 Beta) on my
                > NSLU2.
                >> >
                >> > I have been keeping the installed packages fairly up to date. I
                > am runing
                >> > mt-dappd, ccxstream, lighttpd, and OpenSSH.
                >> >
                >> > Everything was working fine for quite some time.
                >> >
                >> > Recently I noticed the following kernel errors which are being
                > generated
                >> > all the time:
                >> >
                >> > ixp425_eth: Error reading MII reg x on phy 0
                >> >
                >> > where "x" in "reg x" equals a number between 0 and 7.
                >> >
                >> > I believe this is causing some problems as I have been having
                > connectivity
                >> > issues with the NSLU2 the past few days.
                >> >
                >> > Does anyone else have this issue, and have any solutions? Any
                > ideas where
                >> > I can begin to look?
                >>
                >> Since we don't change the kernel or modules in our Unslung releases,
                >> then this can only be something with your hardware, your ethernet
                >> cables, or the box at the other end of the ethernet cable.
                >>
                > I am now getting this too, since installing nfs-utils. It seems
                > that the install of portmap (which nfs-utils depends on) causes this,
                > but I am not 100% sure just yet. I just googled this error and
                > found this yahoo thread...
                > Regards
                > Tony

                I have since moved over to SlugOS/BE. My errors were due to running SNMP and
                having ZenOS doing SNMP probes on the SLUG. Since loading SlugOS/BE I have
                not installed SNMP or syslog-ng, so if these errors are occurring, they are
                not as visible as they were before.
              Your message has been successfully submitted and would be delivered to recipients shortly.