Loading ...
Sorry, an error occurred while loading the content.
 

problem getting xinetd to work

Expand Messages
  • mystiqu
    Hey I ve been trying to get vsftpd to work with xinetd for a while not but I just can t get it to work. I´ve configured vsftpd to be started by xinetd, and
    Message 1 of 2 , Aug 8, 2007
      Hey

      I've been trying to get vsftpd to work with xinetd for a while not but I
      just can't get it to work.

      I´ve configured vsftpd to be started by xinetd, and either xinetd is not
      starting vsftpd or xinetd is not started at all. If starting xinetd with the
      -stayalive option there should be an xinetd process when executing the ps
      command (?), but there isn't one.

      vsftpd is working fine - if starting it in standalone mode I can connect to
      it.

      Does anyone have a clue?

      /etc/xinetd.conf
      ---------------
      service ftp
      {
      disable = no
      socket_type = stream
      wait = no
      user = root
      server = /usr/sbin/vsftpd
      nice = 10
      }

      defaults
      {
      instances = 25
      log_type = FILE /var/log/servicelog
      log_on_success = HOST PID
      log_on_failure = HOST RECORD

      }

      Thanks in advance

      Regards
      Mikael

      --
      View this message in context: http://www.nabble.com/problem-getting-xinetd-to-work-tf4239154.html#a12062089
      Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
    • mystiqu
      Hey all It s working now. The problem was due to an invalid attribute value. log_on_failure = HOST RECORD (RECORD is not a valid value, don t know where I
      Message 2 of 2 , Aug 9, 2007
        Hey all

        It's working now.

        The problem was due to an invalid attribute value.
        "log_on_failure = HOST RECORD" (RECORD is not a valid value, don't know
        where I got it from)

        If starting xinetd without any parameters it didn't give me any information
        at all, nothing was added to the log file (bug?) and it died directly.
        If started in debug mode it not only stayed alive, it also said what was
        wrong with the config file.

        I thing that behaviour is a bit confusing.
        If it can't be started in normal mode (i.e. not debug mode) due to a config
        error it should at least generate a line or two in the log file, or echo it
        to the screen.


        Regards
        Mikael

        mystiqu wrote:
        >
        > Hey
        >
        > I've been trying to get vsftpd to work with xinetd for a while not but I
        > just can't get it to work.
        >
        > I´ve configured vsftpd to be started by xinetd, and either xinetd is not
        > starting vsftpd or xinetd is not started at all. If starting xinetd with
        > the -stayalive option there should be an xinetd process when executing the
        > ps command (?), but there isn't one.
        >
        > vsftpd is working fine - if starting it in standalone mode I can connect
        > to it.
        >
        > Does anyone have a clue?
        >
        > /etc/xinetd.conf
        > ---------------
        > service ftp
        > {
        > disable = no
        > socket_type = stream
        > wait = no
        > user = root
        > server = /usr/sbin/vsftpd
        > nice = 10
        > }
        >
        > defaults
        > {
        > instances = 25
        > log_type = FILE /var/log/servicelog
        > log_on_success = HOST PID
        > log_on_failure = HOST RECORD
        >
        > }
        >
        > Thanks in advance
        >
        > Regards
        > Mikael
        >
        >

        --
        View this message in context: http://www.nabble.com/problem-getting-xinetd-to-work-tf4239154.html#a12068574
        Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
      Your message has been successfully submitted and would be delivered to recipients shortly.