Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Samba: Can't detect the slug in the network

Expand Messages
  • mystiqu
    Hi - Thanks for the fast reply! The smb and nmb processes are running and the NSLU2 is on the same subnet as my windows box. I ve uploaded 2 log files that
    Message 1 of 5 , Aug 6, 2007
    • 0 Attachment
      Hi - Thanks for the fast reply!

      The smb and nmb processes are running and the NSLU2 is on the same subnet as
      my windows box.
      I've uploaded 2 log files that might be of some help.

      http://www.nabble.com/file/p12021617/log.192.168.0.100 log.192.168.0.100
      http://www.nabble.com/file/p12021617/log.smbd log.smbd

      The log files contain information from a samba restart and 1 connection
      attempt from my windows machine.

      Regards
      Mikael


      Mike (mwester) wrote:
      >
      > The firmware updater isn't going to find it unless its in upgrade mode, so
      > that's a red herring. If you can ssh into the device, then the network is
      > functional.
      >
      > That basically gets you to the point where you're troubleshooting Samba.
      > The faq or wiki on the samba site will probably be appropriate for that
      > purpose. Things that pop into my mind are do you even know if the "smb"
      > and
      > "nmb" processes are running? Is your NSLU2 on the same subnet as your
      > windows box?
      >
      > Mike (mwester)
      >
      > ----- Original Message -----
      > From: "mystiqu" <mikael@...>
      > To: <nslu2-linux@yahoogroups.com>
      > Sent: Monday, August 06, 2007 12:52 PM
      > Subject: [nslu2-linux] Samba: Can't detect the slug in the network
      >
      >
      >>
      >> Hi
      >>
      >> I have just installed and configured samba (using OpenSlug 3.10 Beta) but
      > I
      >> can't get windows to find the unit on the network. Actually, I can't even
      >> find ut using the Sercomm Firmware Updater.
      >>
      >> First I thought it might be a bad samba configuration, but since I cant
      > find
      >> the unit using Sercomm it's probably something else.
      >>
      >> Here is the output from 'testparm'
      >>
      >> root@THESLUG:/# testparm
      >> Load smb config files from /etc/samba/smb.conf
      >> Processing section "[homes]"
      >> Processing section "[tmp]"
      >> Processing section "[public]"
      >> Loaded services file OK.
      >> Server role: ROLE_STANDALONE
      >> Press enter to see a dump of your service definitions
      >>
      >> [global]
      >> server string = Mystiqu's Samba Server
      >> interfaces = lo, eth0
      >> security = SHARE
      >> null passwords = Yes
      >> guest account = guest
      >> log level = 5
      >> log file = /var/log/samba/log.%m
      >> max log size = 100
      >> socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=65535
      >> SO_RCVBUF=65535
      >> local master = No
      >> domain master = No
      >> dns proxy = No
      >> ldap ssl = no
      >> config file = /etc/samba/smb.conf
      >> create mask = 0771
      >> force create mode = 0660
      >> force directory mode = 0771
      >> hosts allow = 192.168.1.100, 127.
      >> default case = upper
      >> case sensitive = No
      >> veto files = /.ShareConfFile/quota.user/quota.user~/lost+found/
      >> map system = Yes
      >>
      >> [homes]
      >> comment = Home Directories
      >> read only = No
      >> browseable = No
      >>
      >> [tmp]
      >> comment = Temporary file space
      >> path = /tmp
      >> read only = No
      >> guest ok = Yes
      >>
      >> [public]
      >> comment = Public Stuff
      >> path = /mnt/public
      >> write list = @administrators
      >> read only = No
      >> guest ok = Yes
      >> root@THESLUG:/#
      >>
      >> If you need some more information, just ask and I'll post i asap.
      >>
      >> Any help is appreciated!
      >>
      >> Best regards
      >> Mikael
      >
      >
      >

      --
      View this message in context: http://www.nabble.com/Samba%3A-Can%27t-detect-the-slug-in-the-network-tf4225699.html#a12021617
      Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
    • Robert Hammond
      In message , mystiqu writes ... It could be your config line - hosts allow = 192.168.1.100, 127. , it
      Message 2 of 5 , Aug 6, 2007
      • 0 Attachment
        In message <12020960.post@...>, mystiqu <mikael@...>
        writes
        >
        >Hi
        >
        >I have just installed and configured samba (using OpenSlug 3.10 Beta) but I
        >can't get windows to find the unit on the network. Actually, I can't even
        >find ut using the Sercomm Firmware Updater.
        >
        >First I thought it might be a bad samba configuration, but since I cant find
        >the unit using Sercomm it's probably something else.
        >
        >Here is the output from 'testparm'
        >
        >root@THESLUG:/# testparm
        >Load smb config files from /etc/samba/smb.conf
        >Processing section "[homes]"
        >Processing section "[tmp]"
        >Processing section "[public]"
        >Loaded services file OK.
        >Server role: ROLE_STANDALONE
        >Press enter to see a dump of your service definitions
        >
        >[global]
        > server string = Mystiqu's Samba Server
        > interfaces = lo, eth0
        > security = SHARE
        > null passwords = Yes
        > guest account = guest
        > log level = 5
        > log file = /var/log/samba/log.%m
        > max log size = 100
        > socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=65535
        >SO_RCVBUF=65535
        > local master = No
        > domain master = No
        > dns proxy = No
        > ldap ssl = no
        > config file = /etc/samba/smb.conf
        > create mask = 0771
        > force create mode = 0660
        > force directory mode = 0771
        > hosts allow = 192.168.1.100, 127.
        > default case = upper
        > case sensitive = No
        > veto files = /.ShareConfFile/quota.user/quota.user~/lost+found/
        > map system = Yes
        >
        >[homes]
        > comment = Home Directories
        > read only = No
        > browseable = No
        >
        >[tmp]
        > comment = Temporary file space
        > path = /tmp
        > read only = No
        > guest ok = Yes
        >
        >[public]
        > comment = Public Stuff
        > path = /mnt/public
        > write list = @administrators
        > read only = No
        > guest ok = Yes
        >root@THESLUG:/#
        >
        It could be your config line - hosts allow = 192.168.1.100, 127. , it
        seems very restrictive.

        Mine is - host allow = 192.168., localhost

        Also with my Unslung NSLU-2 my config line - interfaces = ixp0, lo

        Samba uses two ports, port 137 for nmbd netbios-ns, and 139 for smbd
        netbios-ssn. So perhaps these are being blocked somewhere between your
        NSLU-2 and Windows machine.
        --
        Robert Hammond
        PGP:0x154144DA
      • mystiqu
        Hi Ooops *ashamed* - my computer and the NSLU-2 is on subnet 192.168.0 and in the config I restricted the access to 192.168.1.100 (wrong subnet). The smallest
        Message 3 of 5 , Aug 6, 2007
        • 0 Attachment
          Hi

          Ooops *ashamed* - my computer and the NSLU-2 is on subnet 192.168.0 and in
          the config I restricted the access to 192.168.1.100 (wrong subnet).

          The smallest things always couse alot of trouble =)

          Thanks!!!

          Regards
          Mikael



          Robert Hammond wrote:
          >
          > In message <12020960.post@...>, mystiqu <mikael@...>
          > writes
          >>
          >>Hi
          >>
          >>I have just installed and configured samba (using OpenSlug 3.10 Beta) but
          I
          >>can't get windows to find the unit on the network. Actually, I can't even
          >>find ut using the Sercomm Firmware Updater.
          >>
          >>First I thought it might be a bad samba configuration, but since I cant
          find
          >>the unit using Sercomm it's probably something else.
          >>
          >>Here is the output from 'testparm'
          >>
          >>root@THESLUG:/# testparm
          >>Load smb config files from /etc/samba/smb.conf
          >>Processing section "[homes]"
          >>Processing section "[tmp]"
          >>Processing section "[public]"
          >>Loaded services file OK.
          >>Server role: ROLE_STANDALONE
          >>Press enter to see a dump of your service definitions
          >>
          >>[global]
          >> server string = Mystiqu's Samba Server
          >> interfaces = lo, eth0
          >> security = SHARE
          >> null passwords = Yes
          >> guest account = guest
          >> log level = 5
          >> log file = /var/log/samba/log.%m
          >> max log size = 100
          >> socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=65535
          >>SO_RCVBUF=65535
          >> local master = No
          >> domain master = No
          >> dns proxy = No
          >> ldap ssl = no
          >> config file = /etc/samba/smb.conf
          >> create mask = 0771
          >> force create mode = 0660
          >> force directory mode = 0771
          >> hosts allow = 192.168.1.100, 127.
          >> default case = upper
          >> case sensitive = No
          >> veto files = /.ShareConfFile/quota.user/quota.user~/lost+found/
          >> map system = Yes
          >>
          >>[homes]
          >> comment = Home Directories
          >> read only = No
          >> browseable = No
          >>
          >>[tmp]
          >> comment = Temporary file space
          >> path = /tmp
          >> read only = No
          >> guest ok = Yes
          >>
          >>[public]
          >> comment = Public Stuff
          >> path = /mnt/public
          >> write list = @administrators
          >> read only = No
          >> guest ok = Yes
          >>root@THESLUG:/#
          >>
          > It could be your config line - hosts allow = 192.168.1.100, 127. , it
          > seems very restrictive.
          >
          > Mine is - host allow = 192.168., localhost
          >
          > Also with my Unslung NSLU-2 my config line - interfaces = ixp0, lo
          >
          > Samba uses two ports, port 137 for nmbd netbios-ns, and 139 for smbd
          > netbios-ssn. So perhaps these are being blocked somewhere between your
          > NSLU-2 and Windows machine.
          > --
          > Robert Hammond
          > PGP:0x154144DA
          >
          >

          --
          View this message in context: http://www.nabble.com/Samba%3A-Can%27t-detect-the-slug-in-the-network-tf4225699.html#a12021904
          Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
        Your message has been successfully submitted and would be delivered to recipients shortly.