Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Installing samba on OpenSlug 3.10

Expand Messages
  • mystiqu
    Hi I managed to fix it by adding the -d option: ipkg -d root install samba Could it be that the default install path did not have the sufficient free space?
    Message 1 of 5 , Aug 6, 2007
    • 0 Attachment
      Hi

      I managed to fix it by adding the -d option: "ipkg -d root install samba"
      Could it be that the default install path did not have the sufficient free space?
      It works fine now but I would like to know why it failed so I can learn something from this :)

      What is the default installation path when just typing: ipkg install ?

      Regards
      Mikael
      mystiqu wrote:
      Hey all
      I have just installed OpenSlug 3.10 Beta on my Linksys NSLU2.
      I'm trying to install samba but I keep getting the following error:
      root@THESLUG:~# ipkg install samba
      Installing samba (3.0.23c-r0) to root...
      Downloading http://ipkg.nslu2-linux.org/feeds/slugos-bag/cross/3.10-beta/samba_3.0.23c-r0_armeb.ipk
      ipkg: Unable to read all data


      ... and then it continues to configure samba even though the installation was not complete.

      Does anyone know how to install it (without having to compile the src)?
      All the dependencies are already installed.

      Regards
      Mikael


      View this message in context: Re: Installing samba on OpenSlug 3.10
      Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
    • mystiqu
      Hey everyone! After alot of reading in other forums I found a solution that works. Settings the option async when mounting the usb devices really speed
      Message 2 of 5 , Aug 8, 2007
      • 0 Attachment
        Hey everyone!

        After alot of reading in other forums I found a solution that works.
        Settings the option "async" when mounting the usb devices really speed
        things up.

        Write mb/s (sync): ~1mb/s
        Write mb/s (async): ~10mb/s

        The only thing left now is how I can get the devices to get mounted with the
        "async" option during boot.
        Can I modify that or do I have to write a script that remounts the devices
        (after boot) with the proper option and call that script from e.g.
        /etc/profile??

        Regards
        Mikael


        mystiqu wrote:
        >
        > Hey all
        > <br>
        > I have just installed OpenSlug 3.10 Beta on my Linksys NSLU2.
        > <br>
        > I'm trying to install samba but I keep getting the following error:<br>
        > root@THESLUG:~# ipkg install samba<br>
        > Installing samba (3.0.23c-r0) to root...<br>
        > Downloading
        > http://ipkg.nslu2-linux.org/feeds/slugos-bag/cross/3.10-beta/samba_3.0.23c-r0_armeb.ipk<br>
        > ipkg: Unable to read all data<br>
        > <br>
        > ... and then it continues to configure samba even though the installation
        > was not complete.<br>
        > <br>
        > Does anyone know how to install it (without having to compile the
        > src)?<br>
        > All the dependencies are already installed.<br>
        > <br>
        > Regards<br>
        > Mikael

        --
        View this message in context: http://www.nabble.com/Installing-samba-on-OpenSlug-3.10-tf4223893.html#a12058998
        Sent from the Nslu2 - Linux mailing list archive at Nabble.com.
      • Gordon Farquharson
        Hi Mikael ... You should be able to set the async option in your fstab. On Debian, according to the mount man page, async is set by default: $ man mount
        Message 3 of 5 , Aug 9, 2007
        • 0 Attachment
          Hi Mikael

          On 8/8/07, mystiqu <mikael@...> wrote:

          > The only thing left now is how I can get the devices to get mounted with the
          > "async" option during boot.
          > Can I modify that or do I have to write a script that remounts the devices
          > (after boot) with the proper option and call that script from e.g.
          > /etc/profile??

          You should be able to set the async option in your fstab. On Debian,
          according to
          the mount man page, async is set by default:

          $ man mount

          defaults
          Use default options: rw, suid, dev, exec, auto, nouser,
          and async.

          Gordon

          --
          Gordon Farquharson
          GnuPG Key ID: 32D6D676
        Your message has been successfully submitted and would be delivered to recipients shortly.