Loading ...
Sorry, an error occurred while loading the content.

who can update optware package wpa-supplicant?

Expand Messages
  • jjftoman
    The optware package wpa-supplicant is based on some old source from http://hostap.epitest.fi There is much newer source available at this side. Who can update
    Message 1 of 9 , Aug 5, 2007
    View Source
    • 0 Attachment
      The optware package wpa-supplicant is based on some old source from
      http://hostap.epitest.fi There is much newer source available at this
      side. Who can update this package with the newest stable sourcecode?
      In there is support for the madwifi driver that is delivered with the
      FSG. I think you can make a lot of people happy with a new
      wpa-supplicant package.
    • Rod Whitby
      ... wpa-supplicant 0.5.8 should hit the feeds on the next autobuild run. We expect you to report with your testing results. -- Rod
      Message 2 of 9 , Aug 5, 2007
      View Source
      • 0 Attachment
        jjftoman wrote:
        > The optware package wpa-supplicant is based on some old source from
        > http://hostap.epitest.fi There is much newer source available at this
        > side. Who can update this package with the newest stable sourcecode?
        > In there is support for the madwifi driver that is delivered with the
        > FSG. I think you can make a lot of people happy with a new
        > wpa-supplicant package.

        wpa-supplicant 0.5.8 should hit the feeds on the next autobuild run.

        We expect you to report with your testing results.

        -- Rod
      • jjftoman
        It still looks like it is the 0.3.8 version. Although installing comments say it is 0.5.8-1. See my actions below. Or am I doing something wrong? Hans Login
        Message 3 of 9 , Sep 1, 2007
        View Source
        • 0 Attachment
          It still looks like it is the 0.3.8 version. Although installing
          comments say it is 0.5.8-1. See my actions below. Or am I doing
          something wrong?

          Hans

          Login successful. Beware, you are root now!
          / # ipkg update
          Downloading
          http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
          Inflating
          http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
          Updated list of available packages in /usr/lib/ipkg/lists/cross
          Successfully terminated.
          / # ipkg install wpa-supplicant
          Installing wpa-supplicant (0.5.8-1) to root...
          Downloading
          http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/wpa-supplicant_0.5.8-1_armeb.ipk
          Configuring wpa-supplicant


          To complete the installation, you must edit /opt/etc/wpa-supplicant.conf.

          Successfully terminated.
          / # cd opt/sbin/
          /opt/sbin # wpa_supplicant -v
          wpa_supplicant v0.3.8
          Copyright (c) 2003-2005, Jouni Malinen <jkmaline@...> and
          contributors
          /opt/sbin #



          --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@...> wrote:
          >
          > jjftoman wrote:
          > > The optware package wpa-supplicant is based on some old source from
          > > http://hostap.epitest.fi There is much newer source available at this
          > > side. Who can update this package with the newest stable sourcecode?
          > > In there is support for the madwifi driver that is delivered with the
          > > FSG. I think you can make a lot of people happy with a new
          > > wpa-supplicant package.
          >
          > wpa-supplicant 0.5.8 should hit the feeds on the next autobuild run.
          >
          > We expect you to report with your testing results.
          >
          > -- Rod
          >
        • Brian Zhou
          Can you try $ /opt/sbin/wpa_supplicant -v $ which wpa_supplicant instead? Even when you re in /opt/sbin, it might invoke wpa_supplicant from somewhere else in
          Message 4 of 9 , Sep 1, 2007
          View Source
          • 0 Attachment
            Can you try

            $ /opt/sbin/wpa_supplicant -v
            $ which wpa_supplicant

            instead? Even when you're in /opt/sbin, it might invoke wpa_supplicant
            from somewhere else in the PATH, unless you have . at the forefront
            of your PATH, which is not recommended on Unix anyway.

            The version from the feed seems correct to me on nslu2.

            -Brian Zhou

            --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@...> wrote:
            >
            > It still looks like it is the 0.3.8 version. Although installing
            > comments say it is 0.5.8-1. See my actions below. Or am I doing
            > something wrong?
            >
            > Hans
            >
            > Login successful. Beware, you are root now!
            > / # ipkg update
            > Downloading
            >
            http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
            > Inflating
            >
            http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
            > Updated list of available packages in /usr/lib/ipkg/lists/cross
            > Successfully terminated.
            > / # ipkg install wpa-supplicant
            > Installing wpa-supplicant (0.5.8-1) to root...
            > Downloading
            >
            http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/wpa-supplicant_0.5.8-1_armeb.ipk
            > Configuring wpa-supplicant
            >
            >
            > To complete the installation, you must edit
            /opt/etc/wpa-supplicant.conf.
            >
            > Successfully terminated.
            > / # cd opt/sbin/
            > /opt/sbin # wpa_supplicant -v
            > wpa_supplicant v0.3.8
            > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@...> and
            > contributors
            > /opt/sbin #
            >
            >
            >
            > --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@> wrote:
            > >
            > > jjftoman wrote:
            > > > The optware package wpa-supplicant is based on some old source from
            > > > http://hostap.epitest.fi There is much newer source available at
            this
            > > > side. Who can update this package with the newest stable sourcecode?
            > > > In there is support for the madwifi driver that is delivered
            with the
            > > > FSG. I think you can make a lot of people happy with a new
            > > > wpa-supplicant package.
            > >
            > > wpa-supplicant 0.5.8 should hit the feeds on the next autobuild run.
            > >
            > > We expect you to report with your testing results.
            > >
            > > -- Rod
            > >
            >
          • jjftoman
            $ /opt/sbin/wpa_supplicant -v results in: / # /opt/sbin/wpa_supplicant -v wpa_supplicant v0.3.8 Copyright (c) 2003-2005, Jouni Malinen and
            Message 5 of 9 , Sep 2, 2007
            View Source
            • 0 Attachment
              $ /opt/sbin/wpa_supplicant -v

              results in:
              / # /opt/sbin/wpa_supplicant -v
              wpa_supplicant v0.3.8
              Copyright (c) 2003-2005, Jouni Malinen <jkmaline@...> and
              contributors

              $ which wpa_supplicant
              results in:
              / # which wpa_supplicant
              /opt/sbin/wpa_supplicant

              I work on a fsg not on a nslu2. The builds are not the same I guess.
              When I remove wpa_supplicant I get the following results:

              / # ipkg remove wpa_supplicant
              No packages removed.
              Nothing to be done
              Successfully terminated.
              / # ipkg remove wpa-supplicant
              Removing package wpa-supplicant from root...
              killall: wpa-supplicant: no process killed
              prerm script returned status 1
              Successfully terminated.

              It seems there is something wrong with - "minus" and/or _
              "underscore". But where does it come from. I still don't get it. Is
              there something wrong in the fsg build?

              Hans


              --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@...> wrote:
              >
              > Can you try
              >
              > $ /opt/sbin/wpa_supplicant -v
              > $ which wpa_supplicant
              >
              > instead? Even when you're in /opt/sbin, it might invoke wpa_supplicant
              > from somewhere else in the PATH, unless you have . at the forefront
              > of your PATH, which is not recommended on Unix anyway.
              >
              > The version from the feed seems correct to me on nslu2.
              >
              > -Brian Zhou
              >
              > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@> wrote:
              > >
              > > It still looks like it is the 0.3.8 version. Although installing
              > > comments say it is 0.5.8-1. See my actions below. Or am I doing
              > > something wrong?
              > >
              > > Hans
              > >
              > > Login successful. Beware, you are root now!
              > > / # ipkg update
              > > Downloading
              > >
              >
              http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
              > > Inflating
              > >
              >
              http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
              > > Updated list of available packages in /usr/lib/ipkg/lists/cross
              > > Successfully terminated.
              > > / # ipkg install wpa-supplicant
              > > Installing wpa-supplicant (0.5.8-1) to root...
              > > Downloading
              > >
              >
              http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/wpa-supplicant_0.5.8-1_armeb.ipk
              > > Configuring wpa-supplicant
              > >
              > >
              > > To complete the installation, you must edit
              > /opt/etc/wpa-supplicant.conf.
              > >
              > > Successfully terminated.
              > > / # cd opt/sbin/
              > > /opt/sbin # wpa_supplicant -v
              > > wpa_supplicant v0.3.8
              > > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@> and
              > > contributors
              > > /opt/sbin #
              > >
              > >
              > >
              > > --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@> wrote:
              > > >
              > > > jjftoman wrote:
              > > > > The optware package wpa-supplicant is based on some old source
              from
              > > > > http://hostap.epitest.fi There is much newer source available at
              > this
              > > > > side. Who can update this package with the newest stable
              sourcecode?
              > > > > In there is support for the madwifi driver that is delivered
              > with the
              > > > > FSG. I think you can make a lot of people happy with a new
              > > > > wpa-supplicant package.
              > > >
              > > > wpa-supplicant 0.5.8 should hit the feeds on the next autobuild run.
              > > >
              > > > We expect you to report with your testing results.
              > > >
              > > > -- Rod
              > > >
              > >
              >
            • Brian Zhou
              You are correct. I just checked on the official build machine with the strings command against the binaries. Looks like fsg3v4 and openwrt-brcm24 are two
              Message 6 of 9 , Sep 2, 2007
              View Source
              • 0 Attachment
                You are correct. I just checked on the official build machine with the
                "strings" command against the binaries. Looks like fsg3v4 and
                openwrt-brcm24 are two platforms with version problem.

                I bumped IPK_VERSION of wpa-supplicant package, please wait a couple
                of hours and hopefully the correct wpa-supplicant_0.5.8-2 ipk will be
                in the feeds.

                Thank you,

                -Brian Zhou

                --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@...> wrote:
                >
                > $ /opt/sbin/wpa_supplicant -v
                >
                > results in:
                > / # /opt/sbin/wpa_supplicant -v
                > wpa_supplicant v0.3.8
                > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@...> and
                > contributors
                >
                > $ which wpa_supplicant
                > results in:
                > / # which wpa_supplicant
                > /opt/sbin/wpa_supplicant
                >
                > I work on a fsg not on a nslu2. The builds are not the same I guess.
                > When I remove wpa_supplicant I get the following results:
                >
                > / # ipkg remove wpa_supplicant
                > No packages removed.
                > Nothing to be done
                > Successfully terminated.
                > / # ipkg remove wpa-supplicant
                > Removing package wpa-supplicant from root...
                > killall: wpa-supplicant: no process killed
                > prerm script returned status 1
                > Successfully terminated.
                >
                > It seems there is something wrong with - "minus" and/or _
                > "underscore". But where does it come from. I still don't get it. Is
                > there something wrong in the fsg build?
                >
                > Hans
                >
                >
                > --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@> wrote:
                > >
                > > Can you try
                > >
                > > $ /opt/sbin/wpa_supplicant -v
                > > $ which wpa_supplicant
                > >
                > > instead? Even when you're in /opt/sbin, it might invoke wpa_supplicant
                > > from somewhere else in the PATH, unless you have . at the forefront
                > > of your PATH, which is not recommended on Unix anyway.
                > >
                > > The version from the feed seems correct to me on nslu2.
                > >
                > > -Brian Zhou
                > >
                > > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@> wrote:
                > > >
                > > > It still looks like it is the 0.3.8 version. Although installing
                > > > comments say it is 0.5.8-1. See my actions below. Or am I doing
                > > > something wrong?
                > > >
                > > > Hans
                > > >
                > > > Login successful. Beware, you are root now!
                > > > / # ipkg update
                > > > Downloading
                > > >
                > >
                >
                http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
                > > > Inflating
                > > >
                > >
                >
                http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
                > > > Updated list of available packages in /usr/lib/ipkg/lists/cross
                > > > Successfully terminated.
                > > > / # ipkg install wpa-supplicant
                > > > Installing wpa-supplicant (0.5.8-1) to root...
                > > > Downloading
                > > >
                > >
                >
                http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/wpa-supplicant_0.5.8-1_armeb.ipk
                > > > Configuring wpa-supplicant
                > > >
                > > >
                > > > To complete the installation, you must edit
                > > /opt/etc/wpa-supplicant.conf.
                > > >
                > > > Successfully terminated.
                > > > / # cd opt/sbin/
                > > > /opt/sbin # wpa_supplicant -v
                > > > wpa_supplicant v0.3.8
                > > > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@> and
                > > > contributors
                > > > /opt/sbin #
                > > >
                > > >
                > > >
                > > > --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@> wrote:
                > > > >
                > > > > jjftoman wrote:
                > > > > > The optware package wpa-supplicant is based on some old source
                > from
                > > > > > http://hostap.epitest.fi There is much newer source available at
                > > this
                > > > > > side. Who can update this package with the newest stable
                > sourcecode?
                > > > > > In there is support for the madwifi driver that is delivered
                > > with the
                > > > > > FSG. I think you can make a lot of people happy with a new
                > > > > > wpa-supplicant package.
                > > > >
                > > > > wpa-supplicant 0.5.8 should hit the feeds on the next
                autobuild run.
                > > > >
                > > > > We expect you to report with your testing results.
                > > > >
                > > > > -- Rod
                > > > >
                > > >
                > >
                >
              • jjftoman
                Thanks I get the right version now /opt/sbin/wpa_supplicant -v wpa_supplicant v0.5.8 Copyright (c) 2003-2007, Jouni Malinen and contributors ...
                Message 7 of 9 , Sep 3, 2007
                View Source
                • 0 Attachment
                  Thanks

                  I get the right version now

                  /opt/sbin/wpa_supplicant -v
                  wpa_supplicant v0.5.8
                  Copyright (c) 2003-2007, Jouni Malinen <j@...> and contributors



                  --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@...> wrote:
                  >
                  > You are correct. I just checked on the official build machine with the
                  > "strings" command against the binaries. Looks like fsg3v4 and
                  > openwrt-brcm24 are two platforms with version problem.
                  >
                  > I bumped IPK_VERSION of wpa-supplicant package, please wait a couple
                  > of hours and hopefully the correct wpa-supplicant_0.5.8-2 ipk will be
                  > in the feeds.
                  >
                  > Thank you,
                  >
                  > -Brian Zhou
                  >
                  > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@> wrote:
                  > >
                  > > $ /opt/sbin/wpa_supplicant -v
                  > >
                  > > results in:
                  > > / # /opt/sbin/wpa_supplicant -v
                  > > wpa_supplicant v0.3.8
                  > > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@> and
                  > > contributors
                  > >
                  > > $ which wpa_supplicant
                  > > results in:
                  > > / # which wpa_supplicant
                  > > /opt/sbin/wpa_supplicant
                  > >
                  > > I work on a fsg not on a nslu2. The builds are not the same I guess.
                  > > When I remove wpa_supplicant I get the following results:
                  > >
                  > > / # ipkg remove wpa_supplicant
                  > > No packages removed.
                  > > Nothing to be done
                  > > Successfully terminated.
                  > > / # ipkg remove wpa-supplicant
                  > > Removing package wpa-supplicant from root...
                  > > killall: wpa-supplicant: no process killed
                  > > prerm script returned status 1
                  > > Successfully terminated.
                  > >
                  > > It seems there is something wrong with - "minus" and/or _
                  > > "underscore". But where does it come from. I still don't get it. Is
                  > > there something wrong in the fsg build?
                  > >
                  > > Hans
                  > >
                  > >
                  > > --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@> wrote:
                  > > >
                  > > > Can you try
                  > > >
                  > > > $ /opt/sbin/wpa_supplicant -v
                  > > > $ which wpa_supplicant
                  > > >
                  > > > instead? Even when you're in /opt/sbin, it might invoke
                  wpa_supplicant
                  > > > from somewhere else in the PATH, unless you have . at the forefront
                  > > > of your PATH, which is not recommended on Unix anyway.
                  > > >
                  > > > The version from the feed seems correct to me on nslu2.
                  > > >
                  > > > -Brian Zhou
                  > > >
                  > > > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@> wrote:
                  > > > >
                  > > > > It still looks like it is the 0.3.8 version. Although installing
                  > > > > comments say it is 0.5.8-1. See my actions below. Or am I doing
                  > > > > something wrong?
                  > > > >
                  > > > > Hans
                  > > > >
                  > > > > Login successful. Beware, you are root now!
                  > > > > / # ipkg update
                  > > > > Downloading
                  > > > >
                  > > >
                  > >
                  >
                  http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
                  > > > > Inflating
                  > > > >
                  > > >
                  > >
                  >
                  http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
                  > > > > Updated list of available packages in /usr/lib/ipkg/lists/cross
                  > > > > Successfully terminated.
                  > > > > / # ipkg install wpa-supplicant
                  > > > > Installing wpa-supplicant (0.5.8-1) to root...
                  > > > > Downloading
                  > > > >
                  > > >
                  > >
                  >
                  http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/wpa-supplicant_0.5.8-1_armeb.ipk
                  > > > > Configuring wpa-supplicant
                  > > > >
                  > > > >
                  > > > > To complete the installation, you must edit
                  > > > /opt/etc/wpa-supplicant.conf.
                  > > > >
                  > > > > Successfully terminated.
                  > > > > / # cd opt/sbin/
                  > > > > /opt/sbin # wpa_supplicant -v
                  > > > > wpa_supplicant v0.3.8
                  > > > > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@> and
                  > > > > contributors
                  > > > > /opt/sbin #
                  > > > >
                  > > > >
                  > > > >
                  > > > > --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@> wrote:
                  > > > > >
                  > > > > > jjftoman wrote:
                  > > > > > > The optware package wpa-supplicant is based on some old source
                  > > from
                  > > > > > > http://hostap.epitest.fi There is much newer source
                  available at
                  > > > this
                  > > > > > > side. Who can update this package with the newest stable
                  > > sourcecode?
                  > > > > > > In there is support for the madwifi driver that is delivered
                  > > > with the
                  > > > > > > FSG. I think you can make a lot of people happy with a new
                  > > > > > > wpa-supplicant package.
                  > > > > >
                  > > > > > wpa-supplicant 0.5.8 should hit the feeds on the next
                  > autobuild run.
                  > > > > >
                  > > > > > We expect you to report with your testing results.
                  > > > > >
                  > > > > > -- Rod
                  > > > > >
                  > > > >
                  > > >
                  > >
                  >
                • jjftoman
                  I m missing the madwifi driver in the build. The command: wpa_supplicant -d -Dmadwifi -i mwl0 -c /opt/etc/wpa_supplicant.conf results in: Initializing
                  Message 8 of 9 , Sep 5, 2007
                  View Source
                  • 0 Attachment
                    I'm missing the madwifi driver in the build.

                    The command: wpa_supplicant -d -Dmadwifi -i mwl0 -c
                    /opt/etc/wpa_supplicant.conf
                    results in:
                    Initializing interface 'mwl0' conf '/opt/etc/wpa_supplicant.conf'
                    driver 'madwifi' ctrl_interface 'N/A' bridge 'N/A'
                    Unsupported driver 'madwifi'.
                    Failed to add interface mwl0
                    Cancelling scan request
                    Cancelling authentication timeout


                    Who can help me to update the build with a new .config file? So the
                    madwifi driver will be included.


                    Options can be added to .config to select which driver
                    interfaces are included. Following example includes all features and
                    driver interfaces that are included in the wpa_supplicant package:
                    CONFIG_DRIVER_HOSTAP=y
                    CONFIG_DRIVER_HERMES=y
                    CONFIG_DRIVER_MADWIFI=y
                    CONFIG_DRIVER_ATMEL=y
                    CONFIG_DRIVER_WEXT=y
                    CONFIG_DRIVER_NDISWRAPPER=y
                    CONFIG_DRIVER_BROADCOM=y
                    CONFIG_DRIVER_IPW=y
                    CONFIG_DRIVER_BSD=y
                    CONFIG_DRIVER_NDIS=y
                    CONFIG_WIRELESS_EXTENSION=y
                    CONFIG_IEEE8021X_EAPOL=y
                    CONFIG_EAP_MD5=y
                    CONFIG_EAP_MSCHAPV2=y
                    CONFIG_EAP_TLS=y
                    CONFIG_EAP_PEAP=y
                    CONFIG_EAP_TTLS=y
                    CONFIG_EAP_GTC=y
                    CONFIG_EAP_OTP=y
                    CONFIG_EAP_SIM=y
                    CONFIG_EAP_AKA=y
                    CONFIG_EAP_PSK=y
                    CONFIG_EAP_SAKE=y
                    CONFIG_EAP_GPSK=y
                    CONFIG_EAP_PAX=y
                    CONFIG_EAP_LEAP=y
                    CONFIG_PCSC=y

                    See also
                    http://hostap.epitest.fi/gitweb/gitweb.cgi?p=hostap.git;a=blob_plain;f=wpa_supplicant/README
                    for more information.

                    Hans


                    --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@...> wrote:
                    >
                    > Thanks
                    >
                    > I get the right version now
                    >
                    > /opt/sbin/wpa_supplicant -v
                    > wpa_supplicant v0.5.8
                    > Copyright (c) 2003-2007, Jouni Malinen <j@...> and contributors
                    >
                    >
                    >
                    > --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@> wrote:
                    > >
                    > > You are correct. I just checked on the official build machine with the
                    > > "strings" command against the binaries. Looks like fsg3v4 and
                    > > openwrt-brcm24 are two platforms with version problem.
                    > >
                    > > I bumped IPK_VERSION of wpa-supplicant package, please wait a couple
                    > > of hours and hopefully the correct wpa-supplicant_0.5.8-2 ipk will be
                    > > in the feeds.
                    > >
                    > > Thank you,
                    > >
                    > > -Brian Zhou
                    > >
                    > > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@> wrote:
                    > > >
                    > > > $ /opt/sbin/wpa_supplicant -v
                    > > >
                    > > > results in:
                    > > > / # /opt/sbin/wpa_supplicant -v
                    > > > wpa_supplicant v0.3.8
                    > > > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@> and
                    > > > contributors
                    > > >
                    > > > $ which wpa_supplicant
                    > > > results in:
                    > > > / # which wpa_supplicant
                    > > > /opt/sbin/wpa_supplicant
                    > > >
                    > > > I work on a fsg not on a nslu2. The builds are not the same I guess.
                    > > > When I remove wpa_supplicant I get the following results:
                    > > >
                    > > > / # ipkg remove wpa_supplicant
                    > > > No packages removed.
                    > > > Nothing to be done
                    > > > Successfully terminated.
                    > > > / # ipkg remove wpa-supplicant
                    > > > Removing package wpa-supplicant from root...
                    > > > killall: wpa-supplicant: no process killed
                    > > > prerm script returned status 1
                    > > > Successfully terminated.
                    > > >
                    > > > It seems there is something wrong with - "minus" and/or _
                    > > > "underscore". But where does it come from. I still don't get it. Is
                    > > > there something wrong in the fsg build?
                    > > >
                    > > > Hans
                    > > >
                    > > >
                    > > > --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@> wrote:
                    > > > >
                    > > > > Can you try
                    > > > >
                    > > > > $ /opt/sbin/wpa_supplicant -v
                    > > > > $ which wpa_supplicant
                    > > > >
                    > > > > instead? Even when you're in /opt/sbin, it might invoke
                    > wpa_supplicant
                    > > > > from somewhere else in the PATH, unless you have . at the
                    forefront
                    > > > > of your PATH, which is not recommended on Unix anyway.
                    > > > >
                    > > > > The version from the feed seems correct to me on nslu2.
                    > > > >
                    > > > > -Brian Zhou
                    > > > >
                    > > > > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@> wrote:
                    > > > > >
                    > > > > > It still looks like it is the 0.3.8 version. Although installing
                    > > > > > comments say it is 0.5.8-1. See my actions below. Or am I doing
                    > > > > > something wrong?
                    > > > > >
                    > > > > > Hans
                    > > > > >
                    > > > > > Login successful. Beware, you are root now!
                    > > > > > / # ipkg update
                    > > > > > Downloading
                    > > > > >
                    > > > >
                    > > >
                    > >
                    >
                    http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
                    > > > > > Inflating
                    > > > > >
                    > > > >
                    > > >
                    > >
                    >
                    http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
                    > > > > > Updated list of available packages in /usr/lib/ipkg/lists/cross
                    > > > > > Successfully terminated.
                    > > > > > / # ipkg install wpa-supplicant
                    > > > > > Installing wpa-supplicant (0.5.8-1) to root...
                    > > > > > Downloading
                    > > > > >
                    > > > >
                    > > >
                    > >
                    >
                    http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/wpa-supplicant_0.5.8-1_armeb.ipk
                    > > > > > Configuring wpa-supplicant
                    > > > > >
                    > > > > >
                    > > > > > To complete the installation, you must edit
                    > > > > /opt/etc/wpa-supplicant.conf.
                    > > > > >
                    > > > > > Successfully terminated.
                    > > > > > / # cd opt/sbin/
                    > > > > > /opt/sbin # wpa_supplicant -v
                    > > > > > wpa_supplicant v0.3.8
                    > > > > > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@> and
                    > > > > > contributors
                    > > > > > /opt/sbin #
                    > > > > >
                    > > > > >
                    > > > > >
                    > > > > > --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@> wrote:
                    > > > > > >
                    > > > > > > jjftoman wrote:
                    > > > > > > > The optware package wpa-supplicant is based on some old
                    source
                    > > > from
                    > > > > > > > http://hostap.epitest.fi There is much newer source
                    > available at
                    > > > > this
                    > > > > > > > side. Who can update this package with the newest stable
                    > > > sourcecode?
                    > > > > > > > In there is support for the madwifi driver that is delivered
                    > > > > with the
                    > > > > > > > FSG. I think you can make a lot of people happy with a new
                    > > > > > > > wpa-supplicant package.
                    > > > > > >
                    > > > > > > wpa-supplicant 0.5.8 should hit the feeds on the next
                    > > autobuild run.
                    > > > > > >
                    > > > > > > We expect you to report with your testing results.
                    > > > > > >
                    > > > > > > -- Rod
                    > > > > > >
                    > > > > >
                    > > > >
                    > > >
                    > >
                    >
                  • Brian Zhou
                    The best way to have your request fulfilled is to become a developer and add them yourself, since you re motivated and have the test environment. Go to
                    Message 9 of 9 , Sep 6, 2007
                    View Source
                    • 0 Attachment
                      The best way to have your request fulfilled is to become a developer
                      and add them yourself, since you're motivated and have the test
                      environment. Go to #linux-nslu2 and some of us can help when you have
                      problem.

                      -Brian Zhou

                      --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@...> wrote:
                      >
                      > I'm missing the madwifi driver in the build.
                      >
                      > The command: wpa_supplicant -d -Dmadwifi -i mwl0 -c
                      > /opt/etc/wpa_supplicant.conf
                      > results in:
                      > Initializing interface 'mwl0' conf '/opt/etc/wpa_supplicant.conf'
                      > driver 'madwifi' ctrl_interface 'N/A' bridge 'N/A'
                      > Unsupported driver 'madwifi'.
                      > Failed to add interface mwl0
                      > Cancelling scan request
                      > Cancelling authentication timeout
                      >
                      >
                      > Who can help me to update the build with a new .config file? So the
                      > madwifi driver will be included.
                      >
                      >
                      > Options can be added to .config to select which driver
                      > interfaces are included. Following example includes all features and
                      > driver interfaces that are included in the wpa_supplicant package:
                      > CONFIG_DRIVER_HOSTAP=y
                      > CONFIG_DRIVER_HERMES=y
                      > CONFIG_DRIVER_MADWIFI=y
                      > CONFIG_DRIVER_ATMEL=y
                      > CONFIG_DRIVER_WEXT=y
                      > CONFIG_DRIVER_NDISWRAPPER=y
                      > CONFIG_DRIVER_BROADCOM=y
                      > CONFIG_DRIVER_IPW=y
                      > CONFIG_DRIVER_BSD=y
                      > CONFIG_DRIVER_NDIS=y
                      > CONFIG_WIRELESS_EXTENSION=y
                      > CONFIG_IEEE8021X_EAPOL=y
                      > CONFIG_EAP_MD5=y
                      > CONFIG_EAP_MSCHAPV2=y
                      > CONFIG_EAP_TLS=y
                      > CONFIG_EAP_PEAP=y
                      > CONFIG_EAP_TTLS=y
                      > CONFIG_EAP_GTC=y
                      > CONFIG_EAP_OTP=y
                      > CONFIG_EAP_SIM=y
                      > CONFIG_EAP_AKA=y
                      > CONFIG_EAP_PSK=y
                      > CONFIG_EAP_SAKE=y
                      > CONFIG_EAP_GPSK=y
                      > CONFIG_EAP_PAX=y
                      > CONFIG_EAP_LEAP=y
                      > CONFIG_PCSC=y
                      >
                      > See also
                      >
                      http://hostap.epitest.fi/gitweb/gitweb.cgi?p=hostap.git;a=blob_plain;f=wpa_supplicant/README
                      > for more information.
                      >
                      > Hans
                      >
                      >
                      > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@> wrote:
                      > >
                      > > Thanks
                      > >
                      > > I get the right version now
                      > >
                      > > /opt/sbin/wpa_supplicant -v
                      > > wpa_supplicant v0.5.8
                      > > Copyright (c) 2003-2007, Jouni Malinen <j@...> and contributors
                      > >
                      > >
                      > >
                      > > --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@> wrote:
                      > > >
                      > > > You are correct. I just checked on the official build machine
                      with the
                      > > > "strings" command against the binaries. Looks like fsg3v4 and
                      > > > openwrt-brcm24 are two platforms with version problem.
                      > > >
                      > > > I bumped IPK_VERSION of wpa-supplicant package, please wait a couple
                      > > > of hours and hopefully the correct wpa-supplicant_0.5.8-2 ipk
                      will be
                      > > > in the feeds.
                      > > >
                      > > > Thank you,
                      > > >
                      > > > -Brian Zhou
                      > > >
                      > > > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@> wrote:
                      > > > >
                      > > > > $ /opt/sbin/wpa_supplicant -v
                      > > > >
                      > > > > results in:
                      > > > > / # /opt/sbin/wpa_supplicant -v
                      > > > > wpa_supplicant v0.3.8
                      > > > > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@> and
                      > > > > contributors
                      > > > >
                      > > > > $ which wpa_supplicant
                      > > > > results in:
                      > > > > / # which wpa_supplicant
                      > > > > /opt/sbin/wpa_supplicant
                      > > > >
                      > > > > I work on a fsg not on a nslu2. The builds are not the same I
                      guess.
                      > > > > When I remove wpa_supplicant I get the following results:
                      > > > >
                      > > > > / # ipkg remove wpa_supplicant
                      > > > > No packages removed.
                      > > > > Nothing to be done
                      > > > > Successfully terminated.
                      > > > > / # ipkg remove wpa-supplicant
                      > > > > Removing package wpa-supplicant from root...
                      > > > > killall: wpa-supplicant: no process killed
                      > > > > prerm script returned status 1
                      > > > > Successfully terminated.
                      > > > >
                      > > > > It seems there is something wrong with - "minus" and/or _
                      > > > > "underscore". But where does it come from. I still don't get
                      it. Is
                      > > > > there something wrong in the fsg build?
                      > > > >
                      > > > > Hans
                      > > > >
                      > > > >
                      > > > > --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@> wrote:
                      > > > > >
                      > > > > > Can you try
                      > > > > >
                      > > > > > $ /opt/sbin/wpa_supplicant -v
                      > > > > > $ which wpa_supplicant
                      > > > > >
                      > > > > > instead? Even when you're in /opt/sbin, it might invoke
                      > > wpa_supplicant
                      > > > > > from somewhere else in the PATH, unless you have . at the
                      > forefront
                      > > > > > of your PATH, which is not recommended on Unix anyway.
                      > > > > >
                      > > > > > The version from the feed seems correct to me on nslu2.
                      > > > > >
                      > > > > > -Brian Zhou
                      > > > > >
                      > > > > > --- In nslu2-linux@yahoogroups.com, "jjftoman" <jjftoman@>
                      wrote:
                      > > > > > >
                      > > > > > > It still looks like it is the 0.3.8 version. Although
                      installing
                      > > > > > > comments say it is 0.5.8-1. See my actions below. Or am I
                      doing
                      > > > > > > something wrong?
                      > > > > > >
                      > > > > > > Hans
                      > > > > > >
                      > > > > > > Login successful. Beware, you are root now!
                      > > > > > > / # ipkg update
                      > > > > > > Downloading
                      > > > > > >
                      > > > > >
                      > > > >
                      > > >
                      > >
                      >
                      http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
                      > > > > > > Inflating
                      > > > > > >
                      > > > > >
                      > > > >
                      > > >
                      > >
                      >
                      http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/Packages.gz
                      > > > > > > Updated list of available packages in
                      /usr/lib/ipkg/lists/cross
                      > > > > > > Successfully terminated.
                      > > > > > > / # ipkg install wpa-supplicant
                      > > > > > > Installing wpa-supplicant (0.5.8-1) to root...
                      > > > > > > Downloading
                      > > > > > >
                      > > > > >
                      > > > >
                      > > >
                      > >
                      >
                      http://ipkg.nslu2-linux.org/feeds/optware/fsg3v4/cross/stable/wpa-supplicant_0.5.8-1_armeb.ipk
                      > > > > > > Configuring wpa-supplicant
                      > > > > > >
                      > > > > > >
                      > > > > > > To complete the installation, you must edit
                      > > > > > /opt/etc/wpa-supplicant.conf.
                      > > > > > >
                      > > > > > > Successfully terminated.
                      > > > > > > / # cd opt/sbin/
                      > > > > > > /opt/sbin # wpa_supplicant -v
                      > > > > > > wpa_supplicant v0.3.8
                      > > > > > > Copyright (c) 2003-2005, Jouni Malinen <jkmaline@> and
                      > > > > > > contributors
                      > > > > > > /opt/sbin #
                      > > > > > >
                      > > > > > >
                      > > > > > >
                      > > > > > > --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@> wrote:
                      > > > > > > >
                      > > > > > > > jjftoman wrote:
                      > > > > > > > > The optware package wpa-supplicant is based on some old
                      > source
                      > > > > from
                      > > > > > > > > http://hostap.epitest.fi There is much newer source
                      > > available at
                      > > > > > this
                      > > > > > > > > side. Who can update this package with the newest stable
                      > > > > sourcecode?
                      > > > > > > > > In there is support for the madwifi driver that is
                      delivered
                      > > > > > with the
                      > > > > > > > > FSG. I think you can make a lot of people happy with a new
                      > > > > > > > > wpa-supplicant package.
                      > > > > > > >
                      > > > > > > > wpa-supplicant 0.5.8 should hit the feeds on the next
                      > > > autobuild run.
                      > > > > > > >
                      > > > > > > > We expect you to report with your testing results.
                      > > > > > > >
                      > > > > > > > -- Rod
                      > > > > > > >
                      > > > > > >
                      > > > > >
                      > > > >
                      > > >
                      > >
                      >
                    Your message has been successfully submitted and would be delivered to recipients shortly.