Loading ...
Sorry, an error occurred while loading the content.

Solved: Re: MC over Putty does not show correct line characters

Expand Messages
  • bloedmann999
    ... directory ... worked ... Well I didn t know much about locales when I started this, but I know a bit more now. Due to the second installation attempt only
    Message 1 of 4 , Jul 2, 2007
    • 0 Attachment
      --- In nslu2-linux@yahoogroups.com, "bloedmann999" <Brian_Dorling@...>
      wrote:
      >
      > --- In nslu2-linux@yahoogroups.com, "bloedmann999" <Brian_Dorling@>
      > wrote:
      > >
      > > --- In nslu2-linux@yahoogroups.com, "bloedmann999" <Brian_Dorling@>
      > > wrote:
      > > >
      > > > Hi,
      > > > I needed to reinstall Debian on my test slug. Now, when I login over
      > > > Putty (set to UTF8) and start mc, the line characters in MC are all
      > > > shown as letters. Searching on this I see many cases where putty
      > > > itself was not set to UTF8. Mine is set, so I assume something is
      > > > different under the present debian install.
      > > > Here is the output of the locale command:
      > > >
      > > > Slug2:~# locale
      > > > locale: Cannot set LC_CTYPE to default locale: No such file or
      > directory
      > > > locale: Cannot set LC_MESSAGES to default locale: No such file or
      > > > directory
      > > > locale: Cannot set LC_ALL to default locale: No such file or
      directory
      > > > LANG=de_DE.UTF-8
      > > > LC_CTYPE="de_DE.UTF-8"
      > > > LC_NUMERIC="de_DE.UTF-8"
      > > > LC_TIME="de_DE.UTF-8"
      > > > LC_COLLATE="de_DE.UTF-8"
      > > > LC_MONETARY="de_DE.UTF-8"
      > > > LC_MESSAGES="de_DE.UTF-8"
      > > > LC_PAPER="de_DE.UTF-8"
      > > > LC_NAME="de_DE.UTF-8"
      > > > LC_ADDRESS="de_DE.UTF-8"
      > > > LC_TELEPHONE="de_DE.UTF-8"
      > > > LC_MEASUREMENT="de_DE.UTF-8"
      > > > LC_IDENTIFICATION="de_DE.UTF-8"
      > > > LC_ALL=
      > > >
      > > > Anything else where I need to check? Like I said, first attempt
      worked
      > > > perfectly, this one does not.
      > > >
      > > > Cheers Brian
      > > >
      > > I just tried setting "terminal type" to linux instead of xterm in
      > > putty, that has now something a bit nearer, but still not the correct
      > > characters.
      > >
      > > Cheers Brian
      > >
      > And trying an export LANG=C and then starting with "mc -a" gets me a
      > set of the simple line drawing characters. Putty can be set to either
      > "use unicode" or "use font in both ANSI and OEM modes", I still get
      > the simple lines drawn.
      > At least now all columns line up correctly, in all other settings some
      > characters were unprintable and that meant that the columns did not
      > all line up.
      >
      > I know this can be made to work, and I am sure it is a debian setting,
      > not putty that is incorrect. After the first install I just changed
      > putty to use UTF-8 and it all worked.
      >
      > Cheers Brian
      >

      Well I didn't know much about locales when I started this, but I know
      a bit more now. Due to the second installation attempt only having a
      swap of 32MB, instead of 96MB for the first attempt, locale-gen was
      dying with an OOM when trying to generate any UTF8 locales.
      Adding more swap space allows it to complete OK, I saw that it was
      using up to 67 MB swap during the gen.

      Now I have the locale set correctly and all is OK.

      Cheers Brian
    Your message has been successfully submitted and would be delivered to recipients shortly.