Loading ...
Sorry, an error occurred while loading the content.

Re: Moving from Unslung to Debian...

Expand Messages
  • James
    Thanks guys, worked perfectly... /duh. Can t believe I missed that. The Debian install was incredibly smooth and is running quite nicely. Thanks again - James
    Message 1 of 4 , Jun 2, 2007
    • 0 Attachment
      Thanks guys, worked perfectly... /duh. Can't believe I missed that.
      The Debian install was incredibly smooth and is running quite nicely.

      Thanks again - James

      --- In nslu2-linux@yahoogroups.com, Rod Whitby <rod@...> wrote:
      >
      > James wrote:
      > > So my shiny new NSLU2 arrive today. I booted it up, played with
      the
      > > stock firmware (v73) for a bit and then installed Unslung. That
      worked
      > > fine but then I tried moving to Debian... that's where things got
      a bit
      > > wierd. For some reason I can't reflash my slug no matter what I
      do.
      > > Here's what happened.
      > >
      > > 1. Got the slug, unpacked it hooked it up and messed around with
      the
      > > stock Linksys firmware. Neat, it works.
      >
      > Did you fully complete the network settings, including gateway and
      DNS
      > settings? If not, Debian will not install.
      >
      > > 2. I checki the www.nslu2-linux.org site and decide to start with
      > > Unslung. After lots of reading the Unslung howto docs etc, I
      nervously
      > > install the image. I'm just using a 1GB flash drive so getting
      that
      > > formatted and recognized is a bit funky but no major issues. The
      flash
      > > and unsling work perfectly and everythings cool. I happily
      install
      > > packages with ipkg. Lots of slug hugging ensues (it's a really
      cool
      > > little machine).
      >
      > "Slug hugging" :-)
      >
      > > 3. OK on to Debian. Unslung is cool but I'll feel like a wuss if
      I
      > > don't do a real install. I download the unofficial image with the
      > > IXP4xx microcode drivers and run the upgrade from the
      Unslung/legacy
      > > Linksys UI. I get a "Bad format or filename" message back from
      the web
      > > ui.
      >
      > You can't use the web interface to upgrade from Unslung.
      >
      > > No big deal I'll try again... same thing. OK maybe it's something
      > > with Unslung so I try to revert to Linksys firmware (v68 is all I
      can
      > > find so I try that) same deal "Bad format or filename".
      >
      > You can't use the web interface to downgrade from Unslung.
      >
      > > Next I try
      > > setting the slug to a private IP and accessing it via an isolated
      hub
      > > in case there were notwork problems etc interfering with the
      flash
      > > upgrade but it reverts to my original IP settings. OK, I'll try
      > > Redboot... nu-uh it just boots up to the original IP. Picture
      lots of
      > > head banging against a desk, cussing, etc...
      >
      > Did you try the recommended reflash method, which is the reset
      button
      > upgrade mode and upslug2 or the SerComm windows upgrade tool?
      >
      > > I've tried all these post Unslung install flash upgrades with the
      usb
      > > drive unplugged (the Unslung firmware running on built in flash)
      could
      > > that be the problem? If so is there any way to get it pointing
      back to
      > > the built in flash rather than looking for the USB drive and then
      going
      > > into RO mode? Is there something else I'm missing?
      >
      > Yes: <http://www.nslu2-linux.org/wiki/HowTo/InstallUnslungFirmware>
      >
      > Use that procedure for any firmware installation.
      >
      > -- Rod
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.