Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] How to force lighttpd to use the 8082 port

Expand Messages
  • Robert Hammond
    In message , crombeenhans writes ... I think that you should be using /opt/etc/init.d/S80lighttpd restart --
    Message 1 of 3 , Jun 2, 2007
    • 0 Attachment
      In message <f3kehl+d8na@...>, crombeenhans
      <muppets4@...> writes
      >I have lighttpd on port 8082 right now. I'm still in the process of
      >learning how to use the webserver, so I do a lot in the conf file.
      >After
      >I've made changes I restart lighttpd with this command:
      >
      >lighttpd -f /opt/etc/lighttpd/lighttpd.conf restart
      >
      >The server won't restart and gives the following errormessage:
      >
      >(network.c.300) can't bind to port: 8082 Address already in use.
      >
      >In my router I have forwarded port 8082 to the internal Ip adresss (ie
      >192.168.1.39). Resetting the router doesn't help. Only changing the
      >port adress in the .conf file. But I can't keep doing that. Is there a
      >way to force lighttpd to use port 8082?
      >
      I think that you should be using

      /opt/etc/init.d/S80lighttpd restart


      --
      Robert Hammond
      PGP:0x154144DA
    • crombeenhans
      Hi Robert, Thanks for looking into my problem again. It is solved! With a ps aux I check other instances running and kill them with kill -9. Works a charm,
      Message 2 of 3 , Jun 2, 2007
      • 0 Attachment
        Hi Robert,

        Thanks for looking into my problem again. It is solved! With a ps aux
        I check other instances running and kill them with kill -9. Works a
        charm, lighttpd installed as you suggested. Works great now!

        Thanks again.

        Hans


        --- In nslu2-linux@yahoogroups.com, Robert Hammond <rob.hammond@...>
        wrote:
        >
        > In message <f3kehl+d8na@...>, crombeenhans
        > <muppets4@...> writes
        > >I have lighttpd on port 8082 right now. I'm still in the process of
        > >learning how to use the webserver, so I do a lot in the conf file.
        > >After
        > >I've made changes I restart lighttpd with this command:
        > >
        > >lighttpd -f /opt/etc/lighttpd/lighttpd.conf restart
        > >
        > >The server won't restart and gives the following errormessage:
        > >
        > >(network.c.300) can't bind to port: 8082 Address already in use.
        > >
        > >In my router I have forwarded port 8082 to the internal Ip adresss
        (ie
        > >192.168.1.39). Resetting the router doesn't help. Only changing the
        > >port adress in the .conf file. But I can't keep doing that. Is
        there a
        > >way to force lighttpd to use port 8082?
        > >
        > I think that you should be using
        >
        > /opt/etc/init.d/S80lighttpd restart
        >
        >
        > --
        > Robert Hammond
        > PGP:0x154144DA
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.