Loading ...
Sorry, an error occurred while loading the content.

Re: more than 2 usb drive?

Expand Messages
  • kvnmcgough
    I have a description of this part of the project in the wiki information section: ... office ...
    Message 1 of 4 , Oct 1, 2004
    • 0 Attachment
      I have a description of this part of the project in the wiki
      information section:

      <http://www.nslu2-linux.org/wiki/Info/CardReaderInformation>

      --- In nslu2-linux@yahoogroups.com, "Tino" <tino@i...> wrote:
      > I finally got my hands on one of these nifty nslu2 units at the
      office
      > today.. i promptly threw out the directions and got telnet to work
      so
      > i can start playing with the innards of this thing. Has anyone tried
      > hooking up a powered usb hub to it to see if it can use more than 2
      > usb devices?
    • deijlite
      I can t seem to find a definitive answer with respect to adding a powered USB hub to either USB port of the slug and adding an arbitraty number of drives
      Message 2 of 4 , Oct 13, 2004
      • 0 Attachment
        I can't seem to find a definitive answer with respect to adding a
        powered USB hub to either USB port of the slug and adding an arbitraty
        number of drives (native or vfat fs). Can somebody point me in the
        right direction or pronounce themselves on this issue.

        Obviously the slug would have to be unslung.

        Thanks,

        Martin.

        --- In nslu2-linux@yahoogroups.com, "kvnmcgough" <kevin@m...> wrote:
        > I have a description of this part of the project in the wiki
        > information section:
        >
        > <http://www.nslu2-linux.org/wiki/Info/CardReaderInformation>
        >
        > --- In nslu2-linux@yahoogroups.com, "Tino" <tino@i...> wrote:
        > > I finally got my hands on one of these nifty nslu2 units at the
        > office
        > > today.. i promptly threw out the directions and got telnet to
        work
        > so
        > > i can start playing with the innards of this thing. Has anyone
        tried
        > > hooking up a powered usb hub to it to see if it can use more than
        2
        > > usb devices?
      • Kai Steinbach
        Hello deijlite ... I want to find out, too. Tried it today, but failed somehow. Sorry to bring bad news. :-( Here are the details. The hub with a single disk
        Message 3 of 4 , Oct 16, 2004
        • 0 Attachment
          Hello deijlite

          On Wed, 13 Oct 2004 19:55:13 -0000, deijlite wrote:
          > I can't seem to find a definitive answer with respect to adding a
          > powered USB hub to either USB port of the slug and adding an arbitraty
          > number of drives (native or vfat fs). Can somebody point me in the
          > right direction or pronounce themselves on this issue.

          I want to find out, too. Tried it today, but failed somehow. Sorry to
          bring bad news. :-(

          Here are the details. The hub with a single disk attached works, so
          there is some hope ... but I am not sure how I should proceed from
          this. Any advice much appreciated.

          I am running unslung 1.11 beta on the slug and have 3 external usb2
          disks and a usb2 flash stick available here.
          disk 1 is connected to the port 1 of the slug. Obviously I am not
          touching that, as
          the os runs of this drive.

          (1) fresh boot of the slug with only disk 1 attached to port 1. port 2 is empty.

          (2) plug my "Trust 4 port usb 2.0 hub" in the port 2 of the slug
          <46>Oct 16 17:40:49 klogd: hub.c: new USB device 00:01.2-2, assigned address 3
          <46>Oct 16 17:40:49 klogd: hub.c: USB hub found
          <46>Oct 16 17:40:49 klogd: hub.c: 4 ports detected
          so far so good.

          (3) plug disk 2 in one of the ports of the hub
          <44>Oct 16 17:41:08 klogd: *** 50
          <44>Oct 16 17:41:08 klogd: 32 port connect!!!!!
          <44>Oct 16 17:41:08 klogd: Vendor: IC35L180 Model: AVV207-1
          Rev: 0 0
          <44>Oct 16 17:41:08 klogd: Type: Direct-Access
          ANSI SCSI revision: 02
          <44>Oct 16 17:41:08 klogd: the host no is 0
          <44>Oct 16 17:41:08 klogd: * sd_attach:1
          <44>Oct 16 17:41:08 klogd: Attached scsi disk sdb at scsi0, channel 0,
          id 0, lun 0
          <44>Oct 16 17:41:08 klogd: SCSI device sdb: 361882080 512-byte hdwr
          sectors (185284 MB)
          <46>Oct 16 17:41:08 klogd: sdb1
          <47>Oct 16 17:41:08 klogd: WARNING: USB Mass Storage data integrity not assured
          <47>Oct 16 17:41:08 klogd: USB Mass Storage device found at 4
          That looks kind of OK, too. the data integrity warning I get with the
          disk attached directly, too. Does anyone know what that is and how to
          get rid of it ?

          (4) checking with fdisk ... all looks good.
          / # fdisk -l

          Disk /dev/sda: 255 heads, 63 sectors, 19457 cylinders
          Units = cylinders of 16065 * 512 bytes

          Device Boot Start End Blocks Id System
          /dev/sda1 1 19435 156111606 83 Linux
          /dev/sda2 19436 19450 120487+ 83 Linux
          /dev/sda3 19451 19457 56227+ 82 Linux swap

          Disk /dev/sdb: 255 heads, 63 sectors, 22526 cylinders
          Units = cylinders of 16065 * 512 bytes

          Device Boot Start End Blocks Id System
          /dev/sdb1 1 22526 180940063+ 83 Linux
          / #

          (5) connect disk 3 to another port of the usb hub. now the problems started:
          <46>Oct 16 17:41:52 klogd: hub.c: new USB device 00:01.2-2.3, assigned address 5
          <44>Oct 16 17:41:52 klogd: Protocol: Transparent SCSI
          <44>Oct 16 17:41:52 klogd: before kernel thread
          <44>Oct 16 17:41:52 klogd: max_p is 16 ;start is 16
          <44>Oct 16 17:41:52 klogd: * release
          <44>Oct 16 17:41:52 klogd: scsi unregister!!!!!!!!!!!
          <46>Oct 16 17:41:52 klogd: scsi : 1 host left.
          <44>Oct 16 17:41:52 klogd: *** detect:usb-storage
          <44>Oct 16 17:41:52 klogd: * scsi_register: usb-storage-0,
          <44>Oct 16 17:41:52 klogd: * scsi_reg, retval->host_no:0
          <46>Oct 16 17:41:52 klogd: scsi0 : SCSI emulation for USB Mass Storage devices
          <44>Oct 16 17:41:52 klogd: ! scan_scsis
          <44>Oct 16 17:41:52 klogd: do read capacity!!!
          <44>Oct 16 17:41:52 klogd: read capacity ok!!!
          <44>Oct 16 17:41:52 klogd: The capacity is 156301488
          <44>Oct 16 17:41:52 klogd: *** 50
          <44>Oct 16 17:41:52 klogd: 32 port connect!!!!!
          <44>Oct 16 17:41:52 klogd: Vendor: IC25N080 Model: ATMR04-0
          Rev: MO4O
          <44>Oct 16 17:41:52 klogd: Type: Direct-Access
          ANSI SCSI revision: 02
          <44>Oct 16 17:41:52 klogd: the host no is 0
          <44>Oct 16 17:41:52 klogd: * sd_attach:1
          <44>Oct 16 17:41:52 klogd: Attached scsi disk sdb at scsi0, channel 0,
          id 0, lun 0
          <44>Oct 16 17:41:52 klogd: SCSI device sdb: 156301488 512-byte hdwr
          sectors (80026 MB)
          <46>Oct 16 17:41:53 klogd: sdb1
          <47>Oct 16 17:41:53 klogd: WARNING: USB Mass Storage data integrity not assured
          <47>Oct 16 17:41:53 klogd: USB Mass Storage device found at 5

          Looks to me as if the slug 'rejects' disk 2 and let disk 3 take its place.
          Running fdisk confirms this:

          / # fdisk -l

          Disk /dev/sda: 255 heads, 63 sectors, 19457 cylinders
          Units = cylinders of 16065 * 512 bytes

          Device Boot Start End Blocks Id System
          /dev/sda1 1 19435 156111606 83 Linux
          /dev/sda2 19436 19450 120487+ 83 Linux
          /dev/sda3 19451 19457 56227+ 82 Linux swap

          Disk /dev/sdb: 255 heads, 63 sectors, 9729 cylinders
          Units = cylinders of 16065 * 512 bytes

          Device Boot Start End Blocks Id System
          /dev/sdb1 1 9729 78148161 c Win95 FAT32 (LBA)
          / #

          Glad I didn't mount the sdb1 from step 4, otherwise I would probably
          be in some trouble now.

          I checked that the devices for sdc are available:
          # ls -la /dev/sdc*
          brw-rw-r-- 1 root root 8, 32 Jul 28 04:37 /dev/sdc
          brw-rw-r-- 1 root root 8, 33 Jul 28 04:37 /dev/sdc1
          brw-rw-r-- 1 root root 8, 34 Jul 28 04:37 /dev/sdc2
          brw-rw-r-- 1 root root 8, 35 Jul 28 04:37 /dev/sdc3
          #

          Any ideas what is going wrong ?
          Would it be working on any of the other development streams ?

          Kai

          PS: I understand that multiple exclamation marks might be perceived as
          extremly rude ... I didn't add any, all the output is 1 to 1 copy from
          /var/log/messages.
        Your message has been successfully submitted and would be delivered to recipients shortly.