Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Openslug 3.10 comilation problems

Expand Messages
  • Peter Campion-Bye
    I solved this tar problem on my Gentoo system by installing BSD tar, which still has wildcard support. I renamed /bin/tar to /bin/gnutar, the BSD tar package
    Message 1 of 5 , Mar 2 4:47 AM
    • 0 Attachment
      I solved this tar problem on my Gentoo system by installing BSD tar, which
      still has wildcard support. I renamed /bin/tar to /bin/gnutar, the BSD tar
      package installs /bin/bsdtar, I then symbolic link /bin/tar to whichever tar I
      want to use at the time. You will need both as BSDtar doesn't support the
      -owner parameter used later on in the build process.
      Another option which I haven't tried would be to add --wildcards to
      TAR_OPTIONS in
      openslug-nslu2.tmp/work/autoconf-native-2.59-r4/autoconf-2.59/GNUmakefile and
      anywhere else you can find it.


      > I am using Debian Etch. tar version I am using is 1.16
      >
      > Thanks
      > Vish
      > --- Rod Whitby <rod@...> wrote:
      >
      >> Viswanathan Sankararam wrote:
      >> > Some one please respond to my question. I would
      >> really
      >> > appreciate it if some one can :)
      >>
      >> If you provided more information about the host you
      >> are using to build,
      >> someone might. For instance, operating system type
      >> and version ...
      >>
      >> > tar: Pattern matching characters used in file
      >> names.
      >> > Please,
      >> > tar: use --wildcards to enable pattern matching,
      >> or
      >> > --no-wildcards to
      >> > tar: suppress this warning.
      >> > tar: *control: Not found in archive
      >> > tar: Error exit delayed from previous errors
      >> > tar: Pattern matching characters used in file
      >> names.
      >> > Please,
      >> > tar: use --wildcards to enable pattern matching,
      >> or
      >> > --no-wildcards to
      >> > tar: suppress this warning.
      >> > tar: *control: Not found in archive
      >> >
      >> > And the above seems to be repeating.
      >> >
      >> > Any body any ideas how I can get past this? I
      >> really
      >> > appreciate any help. This procedure used to work
      >> > before. I wanted to create a new build but I dont
      >> know
      >> > why its not working now.
      >>
      >> Looks like your 'tar' executable has changed to a
      >> different version on
      >> the host.
      >>
      >> -- Rod
      >>
      >
      >
      >
      >
      > ____________________________________________________________________________________
      > Don't pick lemons.
      > See all the new 2007 cars at Yahoo! Autos.
      > http://autos.yahoo.com/new_cars.html
      >
      >
      >
      >
      > Yahoo! Groups Links
      >
      >
      >
      >
    Your message has been successfully submitted and would be delivered to recipients shortly.