Loading ...
Sorry, an error occurred while loading the content.

Fwd: [nslu2-linux] Openslug 3.10 comilation problems

Expand Messages
  • Viswanathan Sankararam
    Some one please respond to my question. I would really appreciate it if some one can :) Thanks Vish
    Message 1 of 5 , Mar 1, 2007
    • 0 Attachment
      Some one please respond to my question. I would really
      appreciate it if some one can :)

      Thanks
      Vish



      ____________________________________________________________________________________
      Have a burning question?
      Go to www.Answers.yahoo.com and get answers from real people who know.
    • Rod Whitby
      ... If you provided more information about the host you are using to build, someone might. For instance, operating system type and version ... ... Looks like
      Message 2 of 5 , Mar 1, 2007
      • 0 Attachment
        Viswanathan Sankararam wrote:
        > Some one please respond to my question. I would really
        > appreciate it if some one can :)

        If you provided more information about the host you are using to build,
        someone might. For instance, operating system type and version ...

        > tar: Pattern matching characters used in file names.
        > Please,
        > tar: use --wildcards to enable pattern matching, or
        > --no-wildcards to
        > tar: suppress this warning.
        > tar: *control: Not found in archive
        > tar: Error exit delayed from previous errors
        > tar: Pattern matching characters used in file names.
        > Please,
        > tar: use --wildcards to enable pattern matching, or
        > --no-wildcards to
        > tar: suppress this warning.
        > tar: *control: Not found in archive
        >
        > And the above seems to be repeating.
        >
        > Any body any ideas how I can get past this? I really
        > appreciate any help. This procedure used to work
        > before. I wanted to create a new build but I dont know
        > why its not working now.

        Looks like your 'tar' executable has changed to a different version on
        the host.

        -- Rod
      • Viswanathan Sankararam
        I am using Debian Etch. tar version I am using is 1.16 Thanks Vish ... ____________________________________________________________________________________
        Message 3 of 5 , Mar 1, 2007
        • 0 Attachment
          I am using Debian Etch. tar version I am using is 1.16

          Thanks
          Vish
          --- Rod Whitby <rod@...> wrote:

          > Viswanathan Sankararam wrote:
          > > Some one please respond to my question. I would
          > really
          > > appreciate it if some one can :)
          >
          > If you provided more information about the host you
          > are using to build,
          > someone might. For instance, operating system type
          > and version ...
          >
          > > tar: Pattern matching characters used in file
          > names.
          > > Please,
          > > tar: use --wildcards to enable pattern matching,
          > or
          > > --no-wildcards to
          > > tar: suppress this warning.
          > > tar: *control: Not found in archive
          > > tar: Error exit delayed from previous errors
          > > tar: Pattern matching characters used in file
          > names.
          > > Please,
          > > tar: use --wildcards to enable pattern matching,
          > or
          > > --no-wildcards to
          > > tar: suppress this warning.
          > > tar: *control: Not found in archive
          > >
          > > And the above seems to be repeating.
          > >
          > > Any body any ideas how I can get past this? I
          > really
          > > appreciate any help. This procedure used to work
          > > before. I wanted to create a new build but I dont
          > know
          > > why its not working now.
          >
          > Looks like your 'tar' executable has changed to a
          > different version on
          > the host.
          >
          > -- Rod
          >




          ____________________________________________________________________________________
          Don't pick lemons.
          See all the new 2007 cars at Yahoo! Autos.
          http://autos.yahoo.com/new_cars.html
        • luis_velasquez00
          I think you shuld try Debian for the NSLU2, I have been using the os and is great, all debian arm programs, no more copilations. 1 NSLU2/Debian@266Mhz Runing:
          Message 4 of 5 , Mar 1, 2007
          • 0 Attachment
            I think you shuld try Debian for the NSLU2, I have been using the os
            and is great, all debian arm programs, no more copilations.

            1 NSLU2/Debian@266Mhz
            Runing:
            lightftpd + php4 + MySQL
            MPD music player and server, to play my mp3 files (using an external
            usb soundcard)
            Samba for file sharing
            CTorrent (downloading all the time)
            proFTPd
            Dovecot + Qmail for my personal mail server

            APT has Super Cow Powers

            Swap? it use a lot of it(60 mb), don't forget to make a partition, I
            use 1GB of my hard drive





            --- In nslu2-linux@yahoogroups.com, Viswanathan Sankararam
            <nslu2vishu@...> wrote:
            >
            > Some one please respond to my question. I would really
            > appreciate it if some one can :)
            >
            > Thanks
            > Vish
            >
            >
            >
            >
            ____________________________________________________________________________________
            > Have a burning question?
            > Go to www.Answers.yahoo.com and get answers from real people who know.
            > All,
            > I have downloaded the SlugOS 3.10 source files and
            > tried to compile the sources. I created the directory
            > downloads with the IPL_ixp400AccessLibrary_2.1.zip and
            > IPL_ixp400NpeLibrary_2.1.zip and respective md5 files.
            > I then ran make openslug-distro. But I get the
            > following error
            >
            > NOTE: Unpacking
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openembedded/packages/meta/slugos-image.bb
            > to
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/work/slugos-image-1.0-r28/
            > NOTE: package slugos-image-1.0-r28: task do_unpack:
            > completed
            > NOTE: package slugos-image-1.0-r28: task do_patch:
            > started
            > NOTE: package slugos-image-1.0-r28: task do_patch:
            > completed
            > NOTE: package slugos-image-1.0-r28: task do_configure:
            > started
            > NOTE: package slugos-image-1.0-r28: task do_configure:
            > completed
            > NOTE: package slugos-image-1.0-r28: task do_compile:
            > started
            > NOTE: package slugos-image-1.0-r28: task do_compile:
            > completed
            > NOTE: package slugos-image-1.0-r28: task
            > do_populate_staging: started
            > NOTE: package slugos-image-1.0-r28: task
            > do_populate_staging: completed
            > NOTE: package slugos-image-1.0-r28: task do_install:
            > started
            > NOTE: package slugos-image-1.0-r28: task do_install:
            > completed
            > NOTE: package slugos-image-1.0-r28: task do_rootfs:
            > started
            > ERROR: function do_rootfs failed
            > ERROR: see log in
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/work/slugos-image-1.0-r28/temp/log.do_rootfs.2574
            > NOTE: Task failed:
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/work/slugos-image-1.0-r28/temp/log.do_rootfs.2574
            > NOTE: package slugos-image-1.0-r28: task do_rootfs:
            > failed
            > ERROR: TaskFailed event exception, aborting
            > NOTE: package slugos-image-1.0: failed
            > ERROR: Build of openslug-packages failed
            > make: *** [distro-unsafe] Error 1
            > make[2]: *** [distro-safe] Error 2
            > make[2]: Leaving directory
            > `/home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta'
            > make[1]: *** [configuration] Error 2
            > make[1]: Leaving directory
            > `/home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta'
            > make: *** [openslug-distro] Error 2
            >
            > The log file shows the following
            > + rm -rf
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/rootfs
            > + '[' 1 '!=' 1 ']'
            > + real_do_rootfs
            > + set -x
            > + mkdir -p
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/rootfs/dev
            > + '[' -z '' ']'
            > + rm -f
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/deploy/ipk/Packages
            > + touch
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/deploy/ipk/Packages
            > + ipkg-make-index -r
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/deploy/ipk/Packages
            > -p
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/deploy/ipk/Packages
            > -l
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/deploy/ipk/Packages.filelist
            > -m
            >
            /home/vsankara/NSLU2_stuff/SlugOS_src/slugos-3.10-beta/openslug-nslu2.tmp/deploy/ipk
            > tar: Pattern matching characters used in file names.
            > Please,
            > tar: use --wildcards to enable pattern matching, or
            > --no-wildcards to
            > tar: suppress this warning.
            > tar: *control: Not found in archive
            > tar: Error exit delayed from previous errors
            > tar: Pattern matching characters used in file names.
            > Please,
            > tar: use --wildcards to enable pattern matching, or
            > --no-wildcards to
            > tar: suppress this warning.
            > tar: *control: Not found in archive
            >
            > And the above seems to be repeating.
            >
            > Any body any ideas how I can get past this? I really
            > appreciate any help. This procedure used to work
            > before. I wanted to create a new build but I dont know
            > why its not working now.
            >
            > Thanks
            > Vish
            >
            >
            >
            >
            >
            >
            ____________________________________________________________________________________
            > Want to start your own business?
            > Learn how on Yahoo! Small Business.
            > http://smallbusiness.yahoo.com/r-index
            >
          • Peter Campion-Bye
            I solved this tar problem on my Gentoo system by installing BSD tar, which still has wildcard support. I renamed /bin/tar to /bin/gnutar, the BSD tar package
            Message 5 of 5 , Mar 2, 2007
            • 0 Attachment
              I solved this tar problem on my Gentoo system by installing BSD tar, which
              still has wildcard support. I renamed /bin/tar to /bin/gnutar, the BSD tar
              package installs /bin/bsdtar, I then symbolic link /bin/tar to whichever tar I
              want to use at the time. You will need both as BSDtar doesn't support the
              -owner parameter used later on in the build process.
              Another option which I haven't tried would be to add --wildcards to
              TAR_OPTIONS in
              openslug-nslu2.tmp/work/autoconf-native-2.59-r4/autoconf-2.59/GNUmakefile and
              anywhere else you can find it.


              > I am using Debian Etch. tar version I am using is 1.16
              >
              > Thanks
              > Vish
              > --- Rod Whitby <rod@...> wrote:
              >
              >> Viswanathan Sankararam wrote:
              >> > Some one please respond to my question. I would
              >> really
              >> > appreciate it if some one can :)
              >>
              >> If you provided more information about the host you
              >> are using to build,
              >> someone might. For instance, operating system type
              >> and version ...
              >>
              >> > tar: Pattern matching characters used in file
              >> names.
              >> > Please,
              >> > tar: use --wildcards to enable pattern matching,
              >> or
              >> > --no-wildcards to
              >> > tar: suppress this warning.
              >> > tar: *control: Not found in archive
              >> > tar: Error exit delayed from previous errors
              >> > tar: Pattern matching characters used in file
              >> names.
              >> > Please,
              >> > tar: use --wildcards to enable pattern matching,
              >> or
              >> > --no-wildcards to
              >> > tar: suppress this warning.
              >> > tar: *control: Not found in archive
              >> >
              >> > And the above seems to be repeating.
              >> >
              >> > Any body any ideas how I can get past this? I
              >> really
              >> > appreciate any help. This procedure used to work
              >> > before. I wanted to create a new build but I dont
              >> know
              >> > why its not working now.
              >>
              >> Looks like your 'tar' executable has changed to a
              >> different version on
              >> the host.
              >>
              >> -- Rod
              >>
              >
              >
              >
              >
              > ____________________________________________________________________________________
              > Don't pick lemons.
              > See all the new 2007 cars at Yahoo! Autos.
              > http://autos.yahoo.com/new_cars.html
              >
              >
              >
              >
              > Yahoo! Groups Links
              >
              >
              >
              >
            Your message has been successfully submitted and would be delivered to recipients shortly.