Loading ...
Sorry, an error occurred while loading the content.

Re: NSLU2, Netatalk and Shadow Passwords

Expand Messages
  • Brian Zhou
    netatalk_2.0.3-2 should be compiled --without-shadow already. -Brian Zhou ... connect from
    Message 1 of 4 , Feb 28, 2007
    • 0 Attachment
      netatalk_2.0.3-2 should be compiled --without-shadow already.

      -Brian Zhou

      --- In nslu2-linux@yahoogroups.com, "bmambo2001" <bmambo2001@...> wrote:
      >
      > --- In nslu2-linux@yahoogroups.com, "bmambo2001" <bmambo2001@> wrote:
      > >
      > > I'm trying to get netatalk to work on my NSLU2 running Unslung 6.8. I
      > > have netatalk successfully installed and afpd running, and it almost
      > > works, but I get the following in the log when attempting a
      connect from
      > > an OS/X client:
      > >
      > > <30>Feb 22 13:32:09 afpd[1039]: ASIP session:548(5) from
      > > 192.168.0.5:52503(7)
      > > <30>Feb 22 13:32:09 afpd[1037]: server_child[1] 1039 done
      > > <30>Feb 22 13:32:22 afpd[1041]: ASIP session:548(5) from
      > > 192.168.0.5:52504(7)
      > > <30>Feb 22 13:32:22 afpd[1041]: cleartext login: office
      > > <30>Feb 22 13:32:22 afpd[1041]: no shadow passwd entry for office
      > >
      > > The user "office" is successfully defined in /etc/passwd, and I can
      > > successfully login with that id using telnet.
      > >
      > > So it looks to me like I don't have shadow passwords enabled on the
      > > NSLU2. Well, this is a dumb question, but how do I turn them on? The
      > > busybox doc seems to indicate that shadow is included, but I have no
      > > /etc/shadow file. I can't figure it out! What do I need to install, or
      > > how do i turn shadowing on?
      > >
      > > Alternatively, is there a way to tell netatalk NOT to use shadow
      > > passwords? I went thru the config files and did not see anything
      > > obvious.
      > >
      >
      > I've done a bit more research, and learned that shadowing is enabled
      > by the pwconv command. This command DOES NOT exist on UNSLUNG6.8,
      > according the find / -name 'pwconv' -print
      >
      > shadow-utils does not seem to be a current ipkg, so it cannot be
      > easily installed, unless someone has one handy.
      >
      > Netatalk does not have a run-time option to proceed w/o shadow
      > passwords, unless it is recompiled with the --without-shadow option.
      > It appears that the current ipkg WAS NOT compiled with that option.
      >
      > So it appears that I will have to either compile my own shadow-utils
      > or netatalk, which will no doubt be a bit of work for me to set up. Or
      > am I missing something? It is totally surprising to me that UNSLUNG
      > doesn't already have shadowing enabled, since I would expect that many
      > applications would assume shadowing is enabled.
      >
    • bmambo2001
      That did the trick! Turns out I had netatalk_2.0.3-1 installed, and I performed an ipkg upgrade netatalk to get to version 2.0.3-2, and this version indeed
      Message 2 of 4 , Mar 1, 2007
      • 0 Attachment
        That did the trick! Turns out I had netatalk_2.0.3-1 installed, and I
        performed an "ipkg upgrade netatalk" to get to version 2.0.3-2, and
        this version indeed does not require shadow passwords. After some
        minor configuration edits, I now can access a shared drive via afp.
        Thank you for your help!

        --- In nslu2-linux@yahoogroups.com, "Brian Zhou" <b88zhou@...> wrote:
        >
        > netatalk_2.0.3-2 should be compiled --without-shadow already.
        >
        > -Brian Zhou
        >
        > --- In nslu2-linux@yahoogroups.com, "bmambo2001" <bmambo2001@> wrote:
        > >
        > > --- In nslu2-linux@yahoogroups.com, "bmambo2001" <bmambo2001@> wrote:
        > > >
        > > > I'm trying to get netatalk to work on my NSLU2 running Unslung
        6.8. I
        > > > have netatalk successfully installed and afpd running, and it almost
        > > > works, but I get the following in the log when attempting a
        > connect from
        > > > an OS/X client:
        > > >
        > > > <30>Feb 22 13:32:09 afpd[1039]: ASIP session:548(5) from
        > > > 192.168.0.5:52503(7)
        > > > <30>Feb 22 13:32:09 afpd[1037]: server_child[1] 1039 done
        > > > <30>Feb 22 13:32:22 afpd[1041]: ASIP session:548(5) from
        > > > 192.168.0.5:52504(7)
        > > > <30>Feb 22 13:32:22 afpd[1041]: cleartext login: office
        > > > <30>Feb 22 13:32:22 afpd[1041]: no shadow passwd entry for office
        > > >
        > > > The user "office" is successfully defined in /etc/passwd, and I can
        > > > successfully login with that id using telnet.
        > > >
        > > > So it looks to me like I don't have shadow passwords enabled on the
        > > > NSLU2. Well, this is a dumb question, but how do I turn them on? The
        > > > busybox doc seems to indicate that shadow is included, but I have no
        > > > /etc/shadow file. I can't figure it out! What do I need to
        install, or
        > > > how do i turn shadowing on?
        > > >
        > > > Alternatively, is there a way to tell netatalk NOT to use shadow
        > > > passwords? I went thru the config files and did not see anything
        > > > obvious.
        > > >
        > >
        > > I've done a bit more research, and learned that shadowing is enabled
        > > by the pwconv command. This command DOES NOT exist on UNSLUNG6.8,
        > > according the find / -name 'pwconv' -print
        > >
        > > shadow-utils does not seem to be a current ipkg, so it cannot be
        > > easily installed, unless someone has one handy.
        > >
        > > Netatalk does not have a run-time option to proceed w/o shadow
        > > passwords, unless it is recompiled with the --without-shadow option.
        > > It appears that the current ipkg WAS NOT compiled with that option.
        > >
        > > So it appears that I will have to either compile my own shadow-utils
        > > or netatalk, which will no doubt be a bit of work for me to set up. Or
        > > am I missing something? It is totally surprising to me that UNSLUNG
        > > doesn't already have shadowing enabled, since I would expect that many
        > > applications would assume shadowing is enabled.
        > >
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.