Loading ...
Sorry, an error occurred while loading the content.

BFTP

Expand Messages
  • rolandratrob
    I ve been trying to get my little unslung turbo ed NSLU visible to the internet via FTP.... but I keep getting disconnected. I ve got a Dlink DSL-604T, which
    Message 1 of 5 , Feb 27, 2007
    • 0 Attachment
      I've been trying to get my little unslung turbo'ed NSLU visible to the
      internet via FTP.... but I keep getting disconnected.


      I've got a Dlink DSL-604T, which I've port forwarded 21 to the NSLU
      and ports 10000-10030.

      I've added the following lines into the bftpd.conf
      PASSIVE_PORTS="10000-10030". However, no joy. The ftp works inside of
      the firewall.. but not on the outside. Considering the way FTP servers
      work, don't they need to know their external IP address, if so I think
      I can fix this using the OVERRIDE_IP=.. but how would I up date this
      everytime my IP changes?!
    • Robert Hammond
      In message , rolandratrob writes ... Your port forwarding rules look OK. But this looks to be a router
      Message 2 of 5 , Feb 27, 2007
      • 0 Attachment
        In message <es1b1h+o13s@...>, rolandratrob
        <robanderson78@...> writes
        >I've been trying to get my little unslung turbo'ed NSLU visible to the
        >internet via FTP.... but I keep getting disconnected.
        >
        >
        >I've got a Dlink DSL-604T, which I've port forwarded 21 to the NSLU
        >and ports 10000-10030.
        >
        >I've added the following lines into the bftpd.conf
        >PASSIVE_PORTS="10000-10030". However, no joy. The ftp works inside of
        >the firewall.. but not on the outside. Considering the way FTP servers
        >work, don't they need to know their external IP address, if so I think
        >I can fix this using the OVERRIDE_IP=.. but how would I up date this
        >everytime my IP changes?!
        >
        Your port forwarding rules look OK.

        But this looks to be a router problem so you my find your answer in the
        following group

        <http://www.dslreports.com/forum/dlink>

        I quickly scanned through this forum and one suggestion is to turn off
        the SPI in the router config.
        --
        Robert Hammond
        PGP:0x154144DA
      • nettsr
        ... Does your router support dynamic DNS? I m using ZoneEdit with my router and domain. When my router sees an IP change it updates my DNS zonefile. Works
        Message 3 of 5 , Feb 27, 2007
        • 0 Attachment
          --- In nslu2-linux@yahoogroups.com, "rolandratrob" <robanderson78@...>
          wrote:
          >
          > I've been trying to get my little unslung turbo'ed NSLU visible to the
          > internet via FTP.... but I keep getting disconnected.
          >
          >
          > I've got a Dlink DSL-604T, which I've port forwarded 21 to the NSLU
          > and ports 10000-10030.
          >
          > I've added the following lines into the bftpd.conf
          > PASSIVE_PORTS="10000-10030". However, no joy. The ftp works inside of
          > the firewall.. but not on the outside. Considering the way FTP servers
          > work, don't they need to know their external IP address, if so I think
          > I can fix this using the OVERRIDE_IP=.. but how would I up date this
          > everytime my IP changes?!

          Does your router support dynamic DNS? I'm using ZoneEdit with my router
          and domain. When my router sees an IP change it updates my DNS
          zonefile. Works well.

          Does your router provide a "special applications" page? With this, it
          inspects packets and modifies the IP address so the external users
          never know that your behind a router.
        • rolandratrob
          ... My router has DynDNS.. but doesn t do the stateful packet inspection and modification.. I spoke to one of the authors of BFTPD, he s replied with this...
          Message 4 of 5 , Feb 28, 2007
          • 0 Attachment
            --- In nslu2-linux@yahoogroups.com, "nettsr" <public@...> wrote:
            >
            > --- In nslu2-linux@yahoogroups.com, "rolandratrob" <robanderson78@>
            > wrote:
            > >
            > > I've been trying to get my little unslung turbo'ed NSLU visible to the
            > > internet via FTP.... but I keep getting disconnected.
            > >
            > >
            > > I've got a Dlink DSL-604T, which I've port forwarded 21 to the NSLU
            > > and ports 10000-10030.
            > >
            > > I've added the following lines into the bftpd.conf
            > > PASSIVE_PORTS="10000-10030". However, no joy. The ftp works inside of
            > > the firewall.. but not on the outside. Considering the way FTP servers
            > > work, don't they need to know their external IP address, if so I think
            > > I can fix this using the OVERRIDE_IP=.. but how would I up date this
            > > everytime my IP changes?!
            >
            > Does your router support dynamic DNS? I'm using ZoneEdit with my router
            > and domain. When my router sees an IP change it updates my DNS
            > zonefile. Works well.
            >
            > Does your router provide a "special applications" page? With this, it
            > inspects packets and modifies the IP address so the external users
            > never know that your behind a router.
            >


            My router has DynDNS.. but doesn't do the stateful packet inspection
            and modification.. I spoke to one of the authors of BFTPD, he's
            replied with this...

            Jesse said
            "Well Rob, you've found the override_ip setting.
            That's half the battle.

            The way it is supposed to work (and it's still in
            the testing stages) is that you put the
            IP of your server as the value to OVERRIDE_IP.

            So let's say your computer is behind a router
            and has a LAN address of 192.168.0.100. However,
            to the outside world, your IP address is
            101.64.85.120. (Just for the sake of example.)

            When someone on the net connects to 101.64.85.120
            the router forwards the connection to your
            server. However, when switching to passive mode
            (which many ftp clients use) the server sends it
            192.168.0.100. Because that's what your server
            thinks it is. So, in your config file, use
            OVERRIDE_IP="101.64.85.120" before you run bftpd.

            This should cause bftpd to send your real-world
            IP address when the client sends in the passive
            request.

            You said the firewall's IP can change, which may
            make for further problems. But one step at a time.

            As I said, the feature is still in the testing
            phase. Please let me know if it works for you.

            Cheers,
            Jesse"
          • Marcel Nijenhof
            ... Wouldn t it be easier to switch to ssh/sftp ? It just uses one port and is completely encrypted to protect your data. -- marceln
            Message 5 of 5 , Feb 28, 2007
            • 0 Attachment
              On Wed, 2007-02-28 at 08:24 +0000, rolandratrob wrote:

              > "Well Rob, you've found the override_ip setting.
              > That's half the battle.

              Wouldn't it be easier to switch to "ssh/sftp"?

              It just uses one port and is completely encrypted to
              protect your data.

              --
              marceln
            Your message has been successfully submitted and would be delivered to recipients shortly.