Loading ...
Sorry, an error occurred while loading the content.

Re: [nslu2-linux] Re: Update on my crashed slug

Expand Messages
  • David Walstra
    Hi, Well, thanks alot for this tip because it helped. I found out that my USB harddisk still works and only the USB stick (old one and a new one) don t work
    Message 1 of 11 , Feb 2, 2007
    • 0 Attachment
      Hi,
       
      Well, thanks alot for this tip because it helped.
      I found out that my USB harddisk still works and only the USB stick (old one and a new one) don't work anymore. Possibly, this has something to do with power, since de HD is externally powered.
       
      Ran the unsling script again, this time to HD. It works!
      Now have to install all packages again, but I'm up and running again already!
       
      Regards and thanks again,
      David.

      sdm485 <steve@...> wrote:
      I have had problems with power when plugging a disk into a running
      slug. It appears that the startup current causes the voltage to drop
      enough to 'glitch' the it. A way around this is to power the disk
      externally for the unslung(ing? ) process. Once the system is working,
      you can remove the external power. Also, when running the disk powered
      from the slug, the power surge is at startup and does not cause a
      later problem.

      sdm485

      --- In nslu2-linux@ yahoogroups. com, David Walstra <walstrad@.. .> wrote:
      >
      > Hi,
      >
      > I tried, but unfortunately it didn't work.
      >
      > I also tried this:
      >
      > ---
      > boot the NSLU2 without a disk
      >
      > login as root (root/uNSLUng if you use the standard password)
      > check if there are two processes running with the name USB_Detect
      > if USB_Detect is running this will probably not help. If you
      encounter that and find a solution, please mention it here.
      > if not, go to /var/run
      > in this dir there is a file called usb_det.pid; it probably has
      an older date than the other files in the dir
      > remove this file. do the same in /var.state/run/ if it has a
      usb_det.pid
      > reboot
      > ---
      >
      > Indeed, USB_Detect was not running and it is now, each time I
      reboot with no disk attached.
      > But at the very moment I plugin a new (unformatted) disk, the slug
      hangs. The leds go flashing and it doesn't respond to requests to the
      internal webserver anymore. Also, my telnet session is killed at that
      moment.
      >
      > I think the only thing I can do now, is reflash and hope that is
      isn't a hardware issue...
      >
      > Shall I try the original Linksys firmware or maybe try unslung 5.5
      again?
      >
      > Kind regards!
      >
      > Marcel Nijenhof <nslu2@...> wrote:
      > Hi,
      >
      > >
      > >
      > > Well, maybe you read my previous message. In the meanwhile, I tried
      > > backing up my pendrive. I now have two image files that I think are
      > > fine.
      >
      > You have to know for sure that they are fine.
      >
      > > When I boot Knoppix with the pen drive attached, Knoppix sees
      > > only two partitions. However, When I insert it under Windows (write
      > > protection enabled, just to be sure), the disk manager sees three
      > > partitions. I have not been able to backup the third partition (which
      > > is 62 Mb in size. the first one is 312 Mb and the second one is 125
      > > Mb). Is this a problem?
      >
      > No.
      >
      > The third partition is the swap and doesn't contain information that
      > is interesting to save.
      >
      > > I asked about how to partition the new pen drive I bought. I suddenly
      > > recalled that I just let the web interface of the slug format the old
      > > pen drive when I used it for the first time. So I thought that when
      > > I'd do the same with the new pen drive (which is also 512 Mb in
      > > size), the slug will use the same partition sizes. However, here
      > > comes the next problem: I can only boot the slug when I have no
      > > devices attached.
      >
      > Please remove the file "/.sd<a|b>root" from the internal flash
      > first.
      >
      > --
      > marceln
      >
      >
      >
      >
      >
      >
      > ------------ --------- --------- ---
      > Now that's room service! Choose from over 150,000 hotels
      > in 45,000 destinations on Yahoo! Travel to find your fit.
      >



      Need a quick answer? Get one in minutes from people who know. Ask your question on Yahoo! Answers.

    Your message has been successfully submitted and would be delivered to recipients shortly.