Loading ...
Sorry, an error occurred while loading the content.

Re: how to chmod files fro external machine?

Expand Messages
  • swissreporter
    THX Paul - exactly what I needed. ... for ... the ... the ... permissions
    Message 1 of 6 , Jan 31, 2007
    • 0 Attachment
      THX Paul - exactly what I needed.


      --- In nslu2-linux@yahoogroups.com, "paul518869" <paul.bargewell@...>
      wrote:
      >
      > --- In nslu2-linux@yahoogroups.com, "swissreporter" <nslug@> wrote:
      > >
      > > Hi all.
      > >
      > > Just unslung, installed openssh, mc and the wonderful script for
      > > dyndnsupdate - and then apache. Everything works just fine.
      > >
      > > Now: I would like to make a directory on disk2 (NFS) accessible
      for
      > > surfers through a webpage. The Dir has been copied to HD2 through
      the
      > > network from a WinXP-machine.
      > >
      > > - I simlinked the dir to a link in /opt/share/www
      > > - I tried to access it - I get Forbidden in the browser.
      > > - I checked permissions on the target Folder: rwx rwx ---, owner
      > > "guest", group "everyone".
      > > - I am root and just cannot chwon or chmod neither the target nor
      the
      > > symlink.
      > >
      > > How do I do it?
      > >
      > > THX - Peter
      > >
      >
      > If you copied them their using windows the answer lies in your
      > smb.conf which has a umask setting to set the default file
      permissions
      > when you create a file in that share.
      >
      > As to why you can't chown files in there... well that's something I
      > have no answer for.
      >
    • nslu2@pion.xs4all.nl
      ... The ntfs driver doesn t support chown. There is only a mount time option to set the owner for all files at mount time. -- marceln
      Message 2 of 6 , Feb 1, 2007
      • 0 Attachment
        On Thu, Feb 01, 2007 at 12:31:42AM -0000, swissreporter wrote:
        > ntfs on the disk, which i tried to symlink to a www-dir on ext3-
        > partition on HDD2.

        The ntfs driver doesn't support chown. There is only a mount time
        option to set the owner for all files at mount time.

        --
        marceln
      Your message has been successfully submitted and would be delivered to recipients shortly.